You are not logged in.

#1 2003-08-04 20:20:40

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,366
Website

tuxracer

has anyone tried to run tuxracer?

i tried, and it works except that it is no 3d-accelerated, and i dont know why

the output was:
libGL error: InitDriver failed

any idea why? any idea how to find out more info about that?

i have a ati-radeon-firegl-7800 and X works with the radeon-module ... but i dont get 3d-acceleration

(using all current packages)


The impossible missions are the only ones which succeed.

Offline

#2 2003-08-04 20:23:21

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,366
Website

Re: tuxracer

... and yes

Section "DRI"
    Group      "video"
    Mode       0666
EndSection

is set correctly (i hope)


The impossible missions are the only ones which succeed.

Offline

#3 2003-08-05 18:42:05

andy
Member
From: Germany
Registered: 2002-10-11
Posts: 374

Re: tuxracer

What about the

Section "Device"
  Option     "DRI"  "on"
  Driver      "FIXME"
  BusID      "FIXME"
EndSection

Driver is I think radeon. There are possibly more options. I don't have a radeon, so don't know the details of the options. You can get the BusID from looking at

/proc/dri/0/name
/proc/dri/1/name
/proc/dri/2/name
/proc/dri/3/name
/proc/dri/4/name
/proc/dri/5/name

or similar. The activated one has detailed information.

Offline

#4 2003-08-06 23:17:57

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,366
Website

Re: tuxracer

thanx for your info, but i think it is set everything all right:

the Device-section looks like this:

Section "Device"
  Identifier   "FireGL7800_Int"
  BoardName    "Mobility FireGL 7800 (Radeon LX)"
  BusID        "1:0:0"
  Driver       "radeon"
  VendorName   "ATI"
  Screen       0
  Option       "NoDDC"
  Option       "DRI""on"
EndSection

and the server itself runs without problems ... except there is no 3d-acceleration and if you run a app that need it, there apears the line

libGL error: InitDriver failed

and the app works extremly slow (software acceleration?)

... the funniest thing is that i know someone with SuSE8.2 working with the same card (and also using radeon-driver) and it works --- the only difference in versions is: i use the 2.4.21-archlinux-kernel --- she the 2.4.20-SuSE

-> any other archlinux-users with a radeon module also having trouble with 3d-accel?


The impossible missions are the only ones which succeed.

Offline

#5 2003-08-06 23:51:58

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,366
Website

Re: tuxracer

more /proc/dri/2/clients
a dev   pid    uid      magic     ioctls

y   2 13855     0          0    1672830

does this mean that it is active? why then there is a problem to "InitDriver" in the libGL ?

someone any ideas?


The impossible missions are the only ones which succeed.

Offline

#6 2003-08-07 00:47:42

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: tuxracer

out of curiosity have you tried rebuilding tuxracer using the PKGBUILD in abs?


AKA uknowme

I am not your friend

Offline

#7 2003-08-07 13:49:23

andy
Member
From: Germany
Registered: 2002-10-11
Posts: 374

Re: tuxracer

What does /proc/dri/2/name contain ?

Also, before throwing the heavyweight tuxracer at it, what do glxinfo and glxgears report ?

glxinfo is a bit hard to digest but it will tell you if it is hardware accelerated or not.

Offline

#8 2003-08-07 17:59:49

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,366
Website

Re: tuxracer

more /proc/dri/2/name
radeon 0xe202 PCI:1:0:0

and glxinfo returned:

glxinfo
name of display: :0.0
libGL error: InitDriver failed
display: :0  screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
client glx vendor string: SGI
client glx version string: 1.2
client glx extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
GLX extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.3 Mesa 4.0.4
OpenGL extensions:
    GL_ARB_imaging, GL_ARB_multitexture, GL_ARB_texture_border_clamp,
    GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
    GL_ARB_texture_env_combine, GL_ARB_texture_env_dot3,
    GL_ARB_transpose_matrix, GL_EXT_abgr, GL_EXT_blend_color,
    GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_texture_env_add,
    GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
    GL_EXT_texture_lod_bias
glu version: 1.3
glu extensions:
    GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
0x23 24 tc  0 24  0 r  .  .  8  8  8  8  0 24  0  0  0  0  0  0 0 None
0x24 24 tc  0 24  0 r  .  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x25 24 tc  0 24  0 r  .  .  8  8  8  8  0 24  0 16 16 16 16  0 0 Slow
0x26 24 tc  0 24  0 r  .  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x27 24 tc  0 24  0 r  y  .  8  8  8  8  0 24  0  0  0  0  0  0 0 None
0x28 24 tc  0 24  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x29 24 tc  0 24  0 r  y  .  8  8  8  8  0 24  0 16 16 16 16  0 0 Slow
0x2a 24 tc  0 24  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x2b 24 dc  0 24  0 r  .  .  8  8  8  8  0 24  0  0  0  0  0  0 0 None
0x2c 24 dc  0 24  0 r  .  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x2d 24 dc  0 24  0 r  .  .  8  8  8  8  0 24  0 16 16 16 16  0 0 Slow
0x2e 24 dc  0 24  0 r  .  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x2f 24 dc  0 24  0 r  y  .  8  8  8  8  0 24  0  0  0  0  0  0 0 None
0x30 24 dc  0 24  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x31 24 dc  0 24  0 r  y  .  8  8  8  8  0 24  0 16 16 16 16  0 0 Slow
0x32 24 dc  0 24  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow

-> thanx for this note: i never heard of glxinfo
-> the third line is exactly what tuxracer returned ... but now here i can see what happened: there is a fallback (line 5 ...) to Mesa :-(

i took also a exact look at the XFree86.0.log and the RADEON things are like this:

[...]
(--) RADEON(0): Chipset: "ATI Mobility FireGL 7800 M7 LX (AGP)" (ChipID = 0x4c58)
(--) RADEON(0): Linear framebuffer at 0xe8000000
(--) RADEON(0): MMIO registers at 0xd0100000
(--) RADEON(0): VideoRAM: 65536 kByte (64-bit DDR SDRAM)
(II) RADEON(0): CloneDisplay option not set -- defaulting to auto-detect
(II) RADEON(0): Primary Display == Type 2
(II) RADEON(0): Panel ID string: 1600x1200
(II) RADEON(0): Panel Size from BIOS: 1600x1200
[...]
(II) RADEON(0): AGP Fast Write disabled by default
(II) RADEON(0): Depth moves disabled by default
(II) Loading sub module "shadowfb"
(II) LoadModule: "shadowfb"
(II) Loading /usr/X11R6/lib/modules/libshadowfb.a
(II) Module shadowfb: vendor="The XFree86 Project"
        compiled for 4.3.0, module version = 1.0.0
        ABI class: XFree86 ANSI C Emulation, version 0.2
(II) RADEON(0): Page flipping disabled
(!!) RADEON(0): For information on using the multimedia capabilities
 of this adapter, please see http://gatos.sf.net.
(--) Depth 24 pixmap format is 32 bpp
[...]
(II) RADEON(0): [drm] created "radeon" driver at busid "PCI:1:0:0"
(II) RADEON(0): [drm] added 8192 byte SAREA at 0xf0a7c000
(II) RADEON(0): [drm] mapped SAREA 0xf0a7c000 to 0x40015000
(II) RADEON(0): [drm] framebuffer handle = 0xe8000000
(II) RADEON(0): [drm] added 1 reserved context for kernel
(WW) RADEON(0): [dri] Some DRI features disabled because of version mismatch.

i think the next line is the reason:

[dri] radeon.o kernel module version is 1.1.1 but 1.3.1 or later is preferred.

i will try to build a new kernel with radeon.o 1.3.1 if i find the patch on the internet (i dont want to use a 2.5.x kernel --- only waiting for 2.6.x is the alternative)

(II) RADEON(0): [agp] Mode 0x1f000201 [AGP 0x8086/0x1a30; Card 0x1002/0x4c58]
(II) RADEON(0): [agp] 8192 kB allocated with handle 0xf4a80000
(II) RADEON(0): [agp] ring handle = 0xe0000000
(II) RADEON(0): [agp] Ring mapped at 0x44262000
(II) RADEON(0): [agp] ring read ptr handle = 0xe0101000
(II) RADEON(0): [agp] Ring read ptr mapped at 0x40017000
(II) RADEON(0): [agp] vertex/indirect buffers handle = 0xe0102000
(II) RADEON(0): [agp] Vertex/indirect buffers mapped at 0x44363000
(II) RADEON(0): [agp] AGP texture map handle = 0xe0302000
(II) RADEON(0): [agp] AGP Texture map mapped at 0x44563000
(II) RADEON(0): [drm] register handle = 0xd0100000
(II) RADEON(0): [dri] Visual configs initialized
(II) RADEON(0): CP in BM mode
(II) RADEON(0): Using 8 MB AGP aperture
(II) RADEON(0): Using 1 MB for the ring buffer
(II) RADEON(0): Using 2 MB for vertex/indirect buffers
(II) RADEON(0): Using 5 MB for AGP textures
(II) RADEON(0): Memory manager initialized to (0,0) (1600,8191)
(II) RADEON(0): Memory manager initialized to (0,0) (1600,8191)
(II) RADEON(0): Reserved area from (0,1200) to (1600,1202)
(II) RADEON(0): Largest offscreen area available: 1600 x 6989
(II) RADEON(0): Will use back buffer at offset 0xf5a000
(II) RADEON(0): Will use depth buffer at offset 0x16ad000
(II) RADEON(0): Will use 34816 kb for textures at offset 0x1e00000
(II) RADEON(0): Using XFree86 Acceleration Architecture (XAA)
        Screen to screen bit blits
        Solid filled rectangles
        8x8 mono pattern filled rectangles
        Indirect CPU to Screen color expansion
        Solid Lines
        Scanline Image Writes
        Offscreen Pixmaps
        Setting up tile and stipple cache:
                32 128x128 slots
                32 256x256 slots
                16 512x512 slots
(II) RADEON(0): Acceleration enabled
(==) RADEON(0): Backing store disabled
(==) RADEON(0): Silken mouse enabled
(II) RADEON(0): Using hardware cursor (scanline 1202)
(II) RADEON(0): Largest offscreen area available: 1600 x 6986
(WW) RADEON(0): Option "DRI" is not used
(WW) RADEON(0): Option "CalcAlgorithm" is not used
(II) RADEON(0): X context handle = 0x00000001
(II) RADEON(0): [drm] installed DRM signal handler
(II) RADEON(0): [DRI] installation complete
(II) RADEON(0): [DRI] installation complete
(II) RADEON(0): [drm] Added 32 65536 byte vertex/indirect buffers
(II) RADEON(0): [drm] Mapped 32 vertex/indirect buffers
(II) RADEON(0): [drm] failure adding irq handler, there is a device already using that irq
[drm] falling back to irq-free operation
(II) RADEON(0): [drm] Kernel module too old (1.1) for agp heap manager
(II) RADEON(0): Direct rendering enabled

funny but here it said that Direct rendering is enabled ... so everything must be OK --- unfortunately it isn't

glxgears works, but i think it is also Mesa, because the console output of glxgears is

glxgears
libGL error: InitDriver failed
684 frames in 5.0 seconds = 136.800 FPS

The impossible missions are the only ones which succeed.

Offline

#9 2003-08-07 20:01:07

Jagged
Member
From: Blacksburg, VA
Registered: 2003-07-18
Posts: 153

Re: tuxracer

wow.... ive seen double-posts with phpbb before... but not a quituple post, how many times didi you click the button wink


Nkawtg...n!

Offline

#10 2003-08-12 09:36:56

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,366
Website

Re: tuxracer

i was right: to solve the problem was to use radeon-modules >=1.3.0 ... now 3d-accelleration works

-> but this leads to another problem :

now my X blanks the screen (it become black) after not using keyboard for 5 min ! (not for movements of mouse and other interupts) ... this is very bad, since when i work in openoffice on a presentation it blanks every 5 minutes ... and also if i present something ::  :evil: very bad at presentatios that the slides disapear every 5 min

-> is there a way to change this blanking without disabling the 3d-accel?


The impossible missions are the only ones which succeed.

Offline

#11 2003-08-12 09:43:57

andy
Member
From: Germany
Registered: 2002-10-11
Posts: 374

Re: tuxracer

dp, I think the version mismatch is the reason (I also have a machine where this is the case, but don't really need 3D acceleration, it would be nice though, and eventually it will have 3D again).

The last line saying "Direct rendering enabled" is probably bogus, since eveything before says otherwise.

Also note, glxgears fails similarly. If glxgears can't get hardware 3d, it'll do software 3d ... and I would guess 136FPS is damn slow :-) ... I get way more than 1000FPS on a Voodoo3 3000 ...

I guess you'll have to dig through the GATOS ( http://gatos.sf.net ) and DRI ( http://dri.sf.net ) web pages until you find matching drivers. Good luck !

Offline

#12 2003-08-12 19:55:36

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,366
Website

Re: tuxracer

andy wrote:

dp, I think the version mismatch is the reason (I also have a machine where this is the case, but don't really need 3D acceleration, it would be nice though, and eventually it will have 3D again).

The last line saying "Direct rendering enabled" is probably bogus, since eveything before says otherwise.

Also note, glxgears fails similarly. If glxgears can't get hardware 3d, it'll do software 3d ... and I would guess 136FPS is damn slow :-) ... I get way more than 1000FPS on a Voodoo3 3000 ...

I guess you'll have to dig through the GATOS ( http://gatos.sf.net ) and DRI ( http://dri.sf.net ) web pages until you find matching drivers. Good luck !

i have solved the problem with no-hardware-3d-accel; (got the newer radeon modules for xfree86, compiled them, and then exchanged the original ones of the server --- this is actually normal with radeon -> see internet for more information) but with the new modules (the ones i installed over the old ones) the server blanks X every 5 minutes if the keyboard is idle ... this blanking is normal, but somehow the movements of the mouse is not the trigger for the timeout --- so now (on my 3d-accelerated X) the display is blanked if you not type something on the keyboard

sorry if the post above is not understanable ... my english is not really good


The impossible missions are the only ones which succeed.

Offline

#13 2003-08-12 22:36:14

andy
Member
From: Germany
Registered: 2002-10-11
Posts: 374

Re: tuxracer

Check the times. There was some overlap :-) When I started my reply (I usually get distracted when writing replies ... :-) ...) you hadn't posted yet that you got it working.

But about the blanking ... sorry ... I have no experience with that.

Offline

#14 2003-11-30 20:28:34

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,366
Website

Re: tuxracer

just to have closed subjects on this forum:

"ATI Mobility FireGL 7800" using "radeon" is at least in (stock)kernel(-scsi)=2.4.23 fully supported (no version conflict, full hardware 3d-acceleration)

thanx to the gatos-project and the kernel developers


The impossible missions are the only ones which succeed.

Offline

Board footer

Powered by FluxBB