You are not logged in.

#1 2004-11-03 16:10:41

gfg
Member
Registered: 2004-11-02
Posts: 6

Xorg mouse problem

Hi! I'm new to arch, and have run into a problem with xorg. When i issue startx my whole screen goes black and the computer hangs, and i have to reboot. I have looked in my xorglog and the error i get is: "No core pointer fatal server info: failed to initalize core devices. Fatal error re-entered. Caught signal 11".

I have tried several mouse setups and nothing seems to work. My mouse is a Microsoft intellitmouse explorer.

Offline

#2 2004-11-03 16:38:17

gfg
Member
Registered: 2004-11-02
Posts: 6

Re: Xorg mouse problem

Hehe! I will try hwd and see if it works. Thanks for the help anyway

Offline

#3 2004-11-03 16:38:41

ScottTFrazer
Member
Registered: 2004-10-20
Posts: 47

Re: Xorg mouse problem

make sure there aren't any errors further up in the log.

No core pointer shouldn't cause a hang like that, it should just mean no mouse.

When I've had startx hangs of that nature it's almost always been frequency problems with my vid card.

Offline

#4 2004-11-03 17:13:02

xerxes2
Member
From: Malmoe, Sweden
Registered: 2004-04-23
Posts: 1,249
Website

Re: Xorg mouse problem

you must load usb-modules in arch kernel 2.6.9 yourself if you are not using hotplug in startup,
see the news on the frontpage,

good luck  big_smile


arch + gentoo + initng + python = enlisy

Offline

#5 2004-11-03 17:18:05

gfg
Member
Registered: 2004-11-02
Posts: 6

Re: Xorg mouse problem

Ok. I have now dobble checked my log and i can't find any other errors.

In my log map I have two logs one named Xorg.0.log and another named Xorg.8.log. In Xorg.8.log i have different error: Xf860OpenSerial cannot open device /dev/mouse no such file or directory. Mouse0 cannot open input device. Could not init font path element /usr/X11R6/lib/x11/fonts/CID: Removing from list!

Offline

#6 2004-11-03 21:22:51

Bzillins8906
Member
Registered: 2004-10-22
Posts: 31

Re: Xorg mouse problem

Isn't that /dev/input/mice ?????


My biggest problem is that arch is de-skilling me. All I have to do is type pacman -Syu everyday - where's the fun in that??
When I used rpm I could spend hours trying to make basic packages work... "robot5x"
Joined:  22 Oct 2004
User # 2279

Offline

#7 2004-11-04 00:01:21

lanrat
Member
From: Poland
Registered: 2003-10-28
Posts: 1,274

Re: Xorg mouse problem

Check these urls for config examples:

http://forums.gentoo.org/viewtopic.php? … e+explorer
http://forums.gentoo.org/viewtopic.php? … e+explorer

For more info check
http://www.linux-gamers.net/modules/wfs … ticleid=46

For a device name use /dev/input/mice (should work for USB and PS/2) or /dev/psaux (PS/2). You can check if mouse is visible by running

cat /dev/input/mice

and randomly moving your mouse. You should see some trash output.

I'm not sure if current xorg supports evdev protocol so it might not be possible to use more than 9 buttons. There are at least a few xorg patches floating around (you can find most of them on gentoo forums) which enable this protocol. I'm not using any of them though.

This is my config for Logitech MX700:

Section "InputDevice"
        Identifier      "LogitechMX700"
        Driver          "mouse"
        Option          "CorePointer"
        Option          "Protocol"              "ExplorerPS/2"
        Option          "Device"                "/dev/psaux"    # "/dev/input/mice"
        Option          "InputFashion"          "Mouse"
        Option          "Name"                  "Logitech MX700"
        Option          "Buttons"               "7"
        Option          "ZAxisMapping"          "6 7"
        Option          "Resolution"            "800"
EndSection

I also load these settings with xmodmap (from .xinitrc)

pointer = 1 2 3 6 7 4 5

All this gives 7 buttons really as up/down buttons near the wheel replicate wheel moves.

You can check which and how your mouse buttons are visible by running xev while in x.

For the future: to enable starting x even without the mouse add

Option          "AllowMouseOpenFail"    "true"

to serverflags section in your xorg.conf.

Offline

Board footer

Powered by FluxBB