You are not logged in.

#1 2004-11-06 14:41:01

lanrat
Member
From: Poland
Registered: 2003-10-28
Posts: 1,274

and another nvidia driver release: 1.0-6629

Nvidia released 1.0-6629 yesterday:
http://www.nvidia.com/object/linux_disp … -6629.html

Among changes: "Improved support for Linux 2.6 kernels" but I couldn't find a clear answer about support for 2.6.9 kernels. No clear answer on nvidia linux forums too (so far).

Anybody can answer if it works with 2.6.9 and latest arch packages without patching?

Some new things are now covered in README file (including xorg extenstions). The readme mentions 2.6.9 kernel (in "Intel's EM64T platform and SWIOTLB" section) and it advises to use it:

If you are using a kernel from kernel.org, it is
suggested to use kernel 2.6.9 or later

so it looks nvidia likes it which is a good news IMO :-)

BTW new gcc version was just released too.

Offline

#2 2004-11-06 16:33:16

StringCheesian
Member
Registered: 2004-09-18
Posts: 5

Re: and another nvidia driver release: 1.0-6629

I'm using it right now with kernel26 2.6.9-1 smile

Offline

#3 2004-11-06 16:53:34

celeron2002
Member
From: Santiago, Chile.
Registered: 2004-02-18
Posts: 150

Re: and another nvidia driver release: 1.0-6629

other version of nvidia drivers, and other problem xD
i have just upgraded gcc, and when i tried install the new nvidia drivers, i execute modprobe nvidia, and this is the ouput
FAILED TO LOAD THE MODULE, INVALID MODULE

i recompiled the kernel with the new gcc, but the same problem


irc.bsd.cl #linux
irc.freenode.org #archlinux-es

Offline

#4 2004-11-06 22:10:48

dk
Member
Registered: 2004-04-20
Posts: 106

Re: and another nvidia driver release: 1.0-6629

I just upgraded to the the new nvidia package. I get as
far as the splash screen then nothing else. It's just stuck
there on the splash... ctrl+alt+bkspc and no error message.
I check /var/log/Xorg.log and didn't see anything. Maybe there is
a new default setting I need to change :?

Anyway, back to 6111-3 and all works

Offline

#5 2004-11-07 08:08:28

tezem
Member
Registered: 2004-11-04
Posts: 51
Website

Re: and another nvidia driver release: 1.0-6629

For me this version works so far.
No problems at the moment with vanilla kernel 2.6.9 gcc 3.4.2-1 and xorg 6.8.1-1

Offline

#6 2004-11-07 09:02:55

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,260

Re: and another nvidia driver release: 1.0-6629

for me it runs with 2.6.9-ARCH ide kernel and gcc 3.4.3
without a problem

Offline

#7 2004-11-07 13:06:52

esack
Member
From: Poland
Registered: 2004-10-31
Posts: 8

Re: and another nvidia driver release: 1.0-6629

I've upgraded yesterday and it works nice so far (with current/kernel26 2.6.9-1).
BTW I was expecting more from this release - problem with XVideo/GLX + Composite still remains unsolved hmm

Offline

#8 2004-11-07 13:31:15

kleptophobiac
Member
From: Sunnyvale, CA
Registered: 2004-04-25
Posts: 481

Re: and another nvidia driver release: 1.0-6629

dk wrote:

I just upgraded to the the new nvidia package. I get as
far as the splash screen then nothing else. It's just stuck
there on the splash... ctrl+alt+bkspc and no error message.
I check /var/log/Xorg.log and didn't see anything. Maybe there is
a new default setting I need to change :?

Anyway, back to 6111-3 and all works

I'm also having that exact same problem. Does your cursor change to a text selection bar then get stuck there?

Anyway, I'm calling bad release on this one. sad

I'm using a GF4 MX440 on an Abit NF7-S.

Do you have the 6111 package?

Offline

#9 2004-11-07 13:58:25

punkrockguy318
Member
From: New Jersey
Registered: 2004-02-15
Posts: 706
Website

Re: and another nvidia driver release: 1.0-6629

kleptophobiac wrote:
dk wrote:

I just upgraded to the the new nvidia package. I get as
far as the splash screen then nothing else. It's just stuck
there on the splash... ctrl+alt+bkspc and no error message.
I check /var/log/Xorg.log and didn't see anything. Maybe there is
a new default setting I need to change :?

Anyway, back to 6111-3 and all works

I'm also having that exact same problem. Does your cursor change to a text selection bar then get stuck there?

Anyway, I'm calling bad release on this one. sad

I'm using a GF4 MX440 on an Abit NF7-S.

Do you have the 6111 package?

Same problem for me... Here's the 6111 pkg:
http://punkrockguy318.ne1.net


If I have the gift of prophecy and can fathom all mysteries and all knowledge, and if I have a faith that can move mountains, but have not love, I am nothing.   1 Corinthians 13:2

Offline

#10 2004-11-07 13:59:24

punkrockguy318
Member
From: New Jersey
Registered: 2004-02-15
Posts: 706
Website

Re: and another nvidia driver release: 1.0-6629

Get it soon, i won't be hosting it much longer


If I have the gift of prophecy and can fathom all mysteries and all knowledge, and if I have a faith that can move mountains, but have not love, I am nothing.   1 Corinthians 13:2

Offline

#11 2004-11-07 14:24:52

kleptophobiac
Member
From: Sunnyvale, CA
Registered: 2004-04-25
Posts: 481

Re: and another nvidia driver release: 1.0-6629

Thanks a ton!

Offline

#12 2004-11-07 18:12:32

punkrockguy318
Member
From: New Jersey
Registered: 2004-02-15
Posts: 706
Website

Re: and another nvidia driver release: 1.0-6629

np man big_smile


If I have the gift of prophecy and can fathom all mysteries and all knowledge, and if I have a faith that can move mountains, but have not love, I am nothing.   1 Corinthians 13:2

Offline

#13 2004-11-07 20:08:04

sweiss
Member
Registered: 2004-02-16
Posts: 635

Re: and another nvidia driver release: 1.0-6629

punkrockguy318 wrote:
kleptophobiac wrote:
dk wrote:

I just upgraded to the the new nvidia package. I get as
far as the splash screen then nothing else. It's just stuck
there on the splash... ctrl+alt+bkspc and no error message.
I check /var/log/Xorg.log and didn't see anything. Maybe there is
a new default setting I need to change :?

Anyway, back to 6111-3 and all works

I'm also having that exact same problem. Does your cursor change to a text selection bar then get stuck there?

Anyway, I'm calling bad release on this one. sad

I'm using a GF4 MX440 on an Abit NF7-S.

Do you have the 6111 package?

Same problem for me... Here's the 6111 pkg:
http://punkrockguy318.ne1.net

And same here.

Offline

#14 2004-11-07 21:27:53

Martillo1
Member
From: My kabila in Lavapiés
Registered: 2004-02-20
Posts: 66

Re: and another nvidia driver release: 1.0-6629

OpenGL does not initialize so GL screensavers and Doom3 do not run.

Back to previous version and everything fine.

Offline

#15 2004-11-07 21:29:56

dk
Member
Registered: 2004-04-20
Posts: 106

Re: and another nvidia driver release: 1.0-6629

sweiss wrote:
punkrockguy318 wrote:
kleptophobiac wrote:

I'm also having that exact same problem. Does your cursor change to a text selection bar then get stuck there?

Anyway, I'm calling bad release on this one. sad

I'm using a GF4 MX440 on an Abit NF7-S.

Do you have the 6111 package?

Same problem for me... Here's the 6111 pkg:
http://punkrockguy318.ne1.net

And same here.

Well, I did try the nvidia-installer downloaded from the nvidia site and that gave the same results. It just sits there on the splash screen. I then tried the the diff patch for the release, but I was told that was for 2.6.10-rc1. I still eneded up with just a splash screen. There are a few post over at nv news (see below) that report the same type of problem. 6111-3 works till the new on is fixed.

http://www.nvnews.net/vbulletin/forumdisplay.php?f=14

Offline

#16 2004-11-08 04:21:41

hyp0luxa
Member
From: Miami, FL
Registered: 2004-07-10
Posts: 70

Re: and another nvidia driver release: 1.0-6629

this driver disables GLX when the composite extension is enabled. to fix add

Option "AllowGLXWithComposite" "1"

in your card device section of /etc/X11/xorg.conf

Offline

#17 2004-11-08 07:21:39

nggalai
Member
From: Switzerland
Registered: 2004-08-01
Posts: 215
Website

Re: and another nvidia driver release: 1.0-6629

esack wrote:

I've upgraded yesterday and it works nice so far (with current/kernel26 2.6.9-1).
BTW I was expecting more from this release - problem with XVideo/GLX + Composite still remains unsolved hmm

I'm quite happy, but then, I like to play DooM3. wink

61.11, GFFX 5800: 22fps
66.29, GFFX 5800: 32fps

61.11, 6800GT: 57fps
66.29, 6800GT: 75fps

Yesssssssssssssssss. wink

Apart from that: no problems what so ever with this driver release. Running on current/kernel26 2.6.9-1, too.

93,
-Sascha.rb

Offline

#18 2004-11-10 00:47:37

kleptophobiac
Member
From: Sunnyvale, CA
Registered: 2004-04-25
Posts: 481

Re: and another nvidia driver release: 1.0-6629

Hey! My name is Sasha too. How cool is that?

Offline

#19 2004-11-13 14:18:49

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,260

Re: and another nvidia driver release: 1.0-6629

it doesn't make a difference if you take the nvidia-installer or the package !

tpowa wonders if someone reads his wiki wink

nice weekend smile

Offline

#20 2004-11-14 12:15:48

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,260

Re: and another nvidia driver release: 1.0-6629

no meant i mention there somewhere
that the nvidia package just run the nvidia-install for you smile
--> it's the same as you run it manually
but this way it's traced by pacman

Offline

#21 2004-11-15 14:08:43

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,260

Re: and another nvidia driver release: 1.0-6629

to all guys with problems with the new driver
it would be interesting to know:
what cards you are using?
what kernel do you run?
do you use a custom kernel?
did you use the nvidia-settings tool before?

post it here and all can see what setup might cause trouble

or with this info you could look at the nv forum if there are guys out with the same problems

or try to look at the included readme perhaps a solution is in it


i don't run nvidia-settings at all, perhaps old config is incompatible with new drivers
i run it on 3 different cards without a problem with the standard arch kernel 2.6.9
geforce 3 ti
geforce 4 ti
and a geforce mobile

Offline

#22 2004-11-15 15:45:08

dk
Member
Registered: 2004-04-20
Posts: 106

Re: and another nvidia driver release: 1.0-6629

There is a known problem with TNT2 and GeForce4 440MX cards.

I'm sure wink  they are working on it .

http://www.nvnews.net/vbulletin/showthr … ge=3&pp=15

Offline

#23 2004-11-15 20:00:09

punkrockguy318
Member
From: New Jersey
Registered: 2004-02-15
Posts: 706
Website

Re: and another nvidia driver release: 1.0-6629

dk wrote:

There is a known problem with TNT2 and GeForce4 440MX cards.

I'm sure wink  they are working on it .

http://www.nvnews.net/vbulletin/showthr … ge=3&pp=15

Yup, i'm running kernel 2.6.9, never touched nvidia-settings, geforce4 mx... doesn't work... hangs at the logo


If I have the gift of prophecy and can fathom all mysteries and all knowledge, and if I have a faith that can move mountains, but have not love, I am nothing.   1 Corinthians 13:2

Offline

#24 2004-11-16 00:05:11

mico
Member
From: Slovenia
Registered: 2004-02-08
Posts: 239

Re: and another nvidia driver release: 1.0-6629

I have:

geforce 2
kernel 2.4.27

My system hangs with the new driver when using some 3D stuff, like when the xscreensaver displays a 3D saver or when I play Neverball. It hangs in a few minutes or even seconds.

All previous versions work fine:
1.0-5336 - OK
1.0-6111 - OK
1.0-6629 - system hangs

So I just installed an older version. I wonder why nobody else experienced this.

Offline

#25 2004-11-16 12:12:03

lanrat
Member
From: Poland
Registered: 2003-10-28
Posts: 1,274

Re: and another nvidia driver release: 1.0-6629

Regarding module loading - you really should load it from /etc/rc.conf MODULES line (nvidia-installer loads the module at the end of build process IIRC but obviously it's not a good way to do this :-))

I'm running latest unpatched nvidia drivers with latest xorg (no new extensions enabled) and kernel 2.6.9 (arch stock kernel - unpatched too). I'm using it with standard geforce4 mx 440.

So far it works ok for me. Glxgears reports a little lower fps but I can play bzflag without losing quality. I still have to try more games to be sure it's ok.

I think mode autodetection has been improved a little. Unfortunatelly I didn't save previous logs but I think x log in nvidia section is now more descriptive.

I'm using 19" crt with 1600x1200x85 Hz and there are no problems switching to lower resolutions and back. I also use tv-out but without tweenview and cloning - just two separate x screens. Tv-out resolution is 1024x768. I'm using s-video cable that connects to euro connector plugged in tv aux. I didn't set video signal standard in my xorg.conf and as it's described in nvidia readme file the driver tries to guess it (which is not always right).
With the previous drivers I had to switch tv to use composite video signal standard but now tv output is much less stable with it. The letters are unreadable and it's flickering a little.
However when I switch the tv to use s-video standard the screen is rock solid and stable. Even small letters are readable, colors are better, etc. etc. I guess autodetection was really improved. Movies and subtitles look much better now so I'm quite happy with the new driver.

I hope they will fix soon all the bad things that you guys are experiencing and I also hope nvidia will cooperate with kernel developers more closely so we won't need to patch anything when new kernel or nvidia drivers are released.

Offline

Board footer

Powered by FluxBB