You are not logged in.

#1 2004-10-18 22:40:35

c0ldevil
Member
Registered: 2004-10-10
Posts: 22

no áÁéÉ...etc... in amsn and openoffice

Hi archers! I'm from Portugal and as such i use special characters like á and Á, ã, etc... but in amsn - installed using the linux installer - and openoffice - arch package - i can't write those characters using the keyboard. I can copy and paste them and they appear perfectly readable but i can't write them! The thing is i can write them perfectly in every other program, be it console or X! I have the correct character set configured in the kernel and in each of these programs. Oh, and FYI I'm not the only one having this problem so i guess it's pretty common.

Can anyone help me? Thanks in advance!

Update: I should also say that in amsn i can read these special characters if someone i'm talking to writes them.

Offline

#2 2004-10-18 23:17:20

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: no áÁéÉ...etc... in amsn and openoffice

as far as amsn is concerned, it may just be the program itself - i would suggest taking a look at gaim, as it supposedly has good language support (i'm a native english speaker, so I have no clue).

as far as openoffice is concerned, I think that's similar but I think arch may be able to fix that - I can do some digging later, but i thing openoffice-en implies individual language package for openoffice which may make a difference....

Offline

#3 2004-10-19 10:33:10

Pajaro
Member
Registered: 2004-04-21
Posts: 878

Re: no áÁéÉ...etc... in amsn and openoffice

latest amsn cvs version has support for aéúíó and more, including €
big_smile

Offline

#4 2004-10-19 12:03:19

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,262

Re: no áÁéÉ...etc... in amsn and openoffice

try to disable deadkeys
in xorg.conf keyboard section

Offline

#5 2004-10-21 10:58:35

c0ldevil
Member
Registered: 2004-10-10
Posts: 22

Re: no áÁéÉ...etc... in amsn and openoffice

I don't want to use gaim, i want to solve this problem. It's clearly a distro problem since all my friends using other distros (slack, debian) don't have this problem.

Disabling deadkeys turns off for every X program characters like ãáé and just writes ~a'a'e so this doesn't seem to be the solution.

I don't think it has to do with X configuration because EVERY OTHER PROGRAM WORKS FINE! Only amsn and openoffice have this problem... 'tis really annoying! There must be other people, namely french, german, spanish, etc... who have this problem.

Help Please! Thanks!

Offline

#6 2004-10-21 11:28:40

Mith
Member
From: out there
Registered: 2004-10-05
Posts: 163

Re: no áÁéÉ...etc... in amsn and openoffice

c0ldevil wrote:

There must be other people, namely french, german, spanish, etc... who have this problem.

hi, just so you know you are not alone. I have the same problem as you. I tried for a couple days with tpowa to fix this problem but the keys just won't work in OOo while working everywhere else...
Quite honestly I sort of gave up trying to fix the problem and just the key table whenever I need accents. Right now I am getting an original build from the openoffice website, just to see if maybe this helps.. I kinda doubt it but hey there's nothing to loose.

EDIT: didn't help using the "original" package. I'm going back to the arch OOo package


ArchLinux (x86_64) w/ kdemod

Offline

#7 2004-10-21 16:08:39

c0ldevil
Member
Registered: 2004-10-10
Posts: 22

Re: no áÁéÉ...etc... in amsn and openoffice

If this isn't a know bug i guess i'll file a bug report.

Offline

#8 2004-10-21 16:16:25

z4ziggy
Member
From: Israel
Registered: 2004-03-29
Posts: 573
Website

Re: no áÁéÉ...etc... in amsn and openoffice

as an heberw user, i had similar problems using some kbd codes. i dunno if this will help u too, but u can try : i created a utf-8 file to hold all my hebrew/english chars and set LC_ALL to use it. also, i had to change the default english keyboard layout in KDE control center to 'U.S. English w/ ISO9995-3 (en_US)'.

hope this helps.

Offline

#9 2004-10-21 17:49:13

c0ldevil
Member
Registered: 2004-10-10
Posts: 22

Re: no áÁéÉ...etc... in amsn and openoffice

I already filed a bug report. Everyone who has this problem or everyone who uses accents, please post here or in the bugtracker, possible solutions or further problems so that this can be solved more easily.

Offline

#10 2004-10-23 12:15:28

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,262

Re: no áÁéÉ...etc... in amsn and openoffice

solution found for openoffice
you have to define LANG variable in /etc/profile
add this to /etc/profile
export LANG=de_DE #for german
change the de_DE to your favourite language then it works
perhaps in the future there will be an option for lang setting in rc.conf

Offline

#11 2004-10-23 12:43:23

c0ldevil
Member
Registered: 2004-10-10
Posts: 22

Re: no áÁéÉ...etc... in amsn and openoffice

YAY! It really works! Thanks a lot Tobias! aMSN still doesn't work but it's good  to have openoffice working correctly. BTW, it works even if you set your LANG variable to en_US.

Only aMSN left now!

Thanks!

Offline

#12 2004-10-23 15:32:04

Mith
Member
From: out there
Registered: 2004-10-05
Posts: 163

Re: no áÁéÉ...etc... in amsn and openoffice

THX !
that was the solution I was looking for ever since I installed arch ( like 3 weeks ago *g* )

btw,
I had to " source /etc/profile " before it actually worked. maybe that's because I didn't restart.
.Mith


ArchLinux (x86_64) w/ kdemod

Offline

#13 2004-10-23 16:19:49

c0ldevil
Member
Registered: 2004-10-10
Posts: 22

Re: no áÁéÉ...etc... in amsn and openoffice

Even if you don't put anything in rc.conf, i think that the LANG variable should be defined by default, it doesn't matter if it's en_US because openoffice works that way, with accents, too!

BTW, to all those who use aMSN and need to use accents, i've already filed a new bug report on this. If every other distro can have it working, something must be wrong with Arch.

Thanks again Tobias  tongue

Offline

#14 2004-11-07 20:12:08

Cobra
Member
Registered: 2004-07-30
Posts: 104

Re: no áÁéÉ...etc... in amsn and openoffice

I'm having the same problem smile
I hope the new release (0.94) fixes this problem.

Offline

Board footer

Powered by FluxBB