You are not logged in.

#1 2009-03-17 15:41:55

bangkok_manouel
Member
From: indicates a starting point
Registered: 2005-02-07
Posts: 1,554

evdev 2.2.0 and keyboard speed

Recently updated evdev 2.2.0 has changed the previous default keyboard speed settings (delay and repeat). I've STFW'd and saw many different ways to manage the keyboard speed but as we are now in the age of hal policies, what would be the right way to handle this?

TIA


All design goals must be phrased in such a way that it is hard to use them as slogans to justify stupidity.

Offline

#2 2009-03-17 16:33:15

skottish
Forum Fellow
From: Here
Registered: 2006-06-16
Posts: 7,932

Re: evdev 2.2.0 and keyboard speed

I had the same problem and making a regular xorg.conf didn't change anything. I ended up adding this to ~/.xinitrc and things are the way that they use to be:

xset r rate 200 30

Offline

#3 2009-03-17 16:57:16

bangkok_manouel
Member
From: indicates a starting point
Registered: 2005-02-07
Posts: 1,554

Re: evdev 2.2.0 and keyboard speed

Thanks skottish, that's exactly what I did (and had the same issue with xorg.conf BTW) and it's working perfectly. So no hal policy should be involved in this? I don't want to look insistent but I'd rather fix it now this way (should hal be an option in that case) if that could avoid us surprises in the future.


All design goals must be phrased in such a way that it is hard to use them as slogans to justify stupidity.

Offline

#4 2009-03-17 17:01:21

skottish
Forum Fellow
From: Here
Registered: 2006-06-16
Posts: 7,932

Re: evdev 2.2.0 and keyboard speed

bangkok_manouel wrote:

Thanks skottish, that's exactly what I did (and had the same issue with xorg.conf BTW) and it's working perfectly. So no hal policy should be involved in this? I don't want to look insistent but I'd rather fix it now this way (should hal be an option in that case) if that could avoid us surprises in the future.

That's a great question that I don't have an answer for. Hopefully someone more knowledgeable than I will jump in.

Offline

#5 2009-03-20 12:50:47

jacko
Member
Registered: 2007-11-23
Posts: 840

Re: evdev 2.2.0 and keyboard speed

ok, I ran into this too, seems there has to be a better way to set this then in bashrc or similar.

Has to be a hal policy for this, what would be the point of centralized policies if they didn't always work?

Offline

#6 2009-03-26 12:56:44

whashnez
Member
From: Greece
Registered: 2008-10-14
Posts: 69
Website

Re: evdev 2.2.0 and keyboard speed

For me the problem was not solved...Why is that?


Prepei na xtisw ena tzami gia ola ta ntervisia

Offline

#7 2009-04-12 12:25:22

Ramses de Norre
Member
From: Leuven - Belgium
Registered: 2007-03-27
Posts: 1,289

Re: evdev 2.2.0 and keyboard speed

Same issue, "xset r rate 200 25" helped but gave me an error:

Xlib:  extension "XFree86-Misc" missing on display ":0.0".

I hope this is nothing serious? And it feels a bit hackish indeed..

Offline

#8 2009-04-12 14:18:28

Bogart
Member
From: Madrid, Spain
Registered: 2005-06-22
Posts: 263

Re: evdev 2.2.0 and keyboard speed

In KDE you can configure it in the control center, under keyboard & mouse. The default is a too slow 600 or something like that, so you can change it to 200 to get the old behaviour.

Offline

#9 2009-04-12 15:06:43

R00KIE
Forum Moderator
From: Between a computer and a chair
Registered: 2008-09-14
Posts: 3,609

Re: evdev 2.2.0 and keyboard speed

I have noticed that too and I have tried xset and it didn't work complaining about a missing extension I think (this on my Arch64 fully up to date) (now I'm still using xorg-server 1.5 in my arch32 and can't confirm that because all works well).
The other solution I have seen was to use kbdrate, which half works, the repeat rate changes but in my case the delay stayed the same at 500ms (according to "xset q").


R00KIE
Tm90aGluZyB0byBzZWUgaGVyZSwgbW92ZSBhbG9uZy4K

Offline

#10 2009-04-12 18:54:07

skottish
Forum Fellow
From: Here
Registered: 2006-06-16
Posts: 7,932

Re: evdev 2.2.0 and keyboard speed

Ramses de Norre wrote:

Same issue, "xset r rate 200 25" helped but gave me an error:

Xlib:  extension "XFree86-Misc" missing on display ":0.0".

I hope this is nothing serious? And it feels a bit hackish indeed..

Strange. My system isn't loading XFree86-Misc and I'm not seeing this message:

xdpyinfo | grep -i misc
    XC-MISC

Offline

#11 2009-04-12 19:09:13

litemotiv
Forum Fellow
Registered: 2008-08-01
Posts: 5,026

Re: evdev 2.2.0 and keyboard speed

skottish wrote:
bangkok_manouel wrote:

Thanks skottish, that's exactly what I did (and had the same issue with xorg.conf BTW) and it's working perfectly. So no hal policy should be involved in this? I don't want to look insistent but I'd rather fix it now this way (should hal be an option in that case) if that could avoid us surprises in the future.

That's a great question that I don't have an answer for. Hopefully someone more knowledgeable than I will jump in.

it's supposedly a bug introduced in evdev 2.2.0, a patch has already been submitted upstream but has not made it back down through official channels yet.

concluding from this thread: http://www.spinics.net/lists/xorg/msg43936.html


ᶘ ᵒᴥᵒᶅ

Offline

#12 2009-04-12 19:18:17

skottish
Forum Fellow
From: Here
Registered: 2006-06-16
Posts: 7,932

Re: evdev 2.2.0 and keyboard speed

litemotiv wrote:

it's supposedly a bug introduced in evdev 2.2.0, a patch has already been submitted upstream but has not made it back down through official channels yet.

concluding from this thread: http://www.spinics.net/lists/xorg/msg43936.html

Interesting. I found a site that said that it's fixed in evdev 2.2.1, which I'm running. I removed the line out of .xinitrc and started X. It changed nothing. I guess we'll just have to wait.

Offline

#13 2009-04-13 14:38:13

linkmaster03
Member
Registered: 2008-12-27
Posts: 269

Re: evdev 2.2.0 and keyboard speed

Ramses de Norre wrote:

Same issue, "xset r rate 200 25" helped but gave me an error:

Xlib:  extension "XFree86-Misc" missing on display ":0.0".

I hope this is nothing serious? And it feels a bit hackish indeed..

I get that error too on this command and when trying to use "alock" screen locker.

Offline

#14 2009-04-29 01:30:04

Evanlec
Member
From: NH, USA
Registered: 2007-12-16
Posts: 140
Website

Re: evdev 2.2.0 and keyboard speed

linkmaster03 wrote:
Ramses de Norre wrote:

Same issue, "xset r rate 200 25" helped but gave me an error:

Xlib:  extension "XFree86-Misc" missing on display ":0.0".

I hope this is nothing serious? And it feels a bit hackish indeed..

I get that error too on this command and when trying to use "alock" screen locker.

I get this error as well.

 Xlib:  extension "XFree86-Misc" missing on display ":0.0".

Is it caused by using 'xset r rate 200 40 &' in my .xinitrc ?

Offline

#15 2009-04-30 03:15:36

nsf
Member
From: Yekaterinburg, Russia
Registered: 2007-09-15
Posts: 160
Website

Re: evdev 2.2.0 and keyboard speed

The "error" is just a warning. There are few ways to change keyboard repeat rate in xset and apparently it tries them all (depends on how it was built).
I get this error too, but keyboard rate is being set, so.. It works.


Bmpanel2 and obkey developer.

Offline

Board footer

Powered by FluxBB