You are not logged in.

#1 2009-05-16 19:47:05

afiestas
Member
Registered: 2008-12-28
Posts: 18

Intel 2.7.1+kernel 2.6.29.3-1 makes Xorg crash almost for everything:/

Hi there!
After the last kernel ugprade (I'm not sure what was the last upgrade I made, but is the kernel I guess) my X server crash almost for everything, let me explain.

I can boot, login in kdm (KDE4), and everything is fine, but once I'm inside KDE4, if I decide for example, make any operation with xrandr, Xorg seems crash and go back to kdm.

Another example, if I'm in KDE4 with composite and I decide turn of it, in this process Xorg seems crash, and again go back to kdm.

I'm not sure what I've to attach on this post, but is so rare that nobody else had post this issue in this forum nor bugtrack hmm

So, I'm really alone on this?

Xorg.conf
http://rafb.net/p/6ZdMYP86.html

Xorg log
http://rafb.net/p/ZSVSJ117.html

Thanks!

Edit: I almost forget this, this issue also appear without having Xorg.conf.
Edit2: intel-dri 7.4.2-1

Last edited by afiestas (2009-05-16 19:58:05)

Offline

#2 2009-05-16 19:55:54

Lazer
Banned
Registered: 2007-08-02
Posts: 111

Re: Intel 2.7.1+kernel 2.6.29.3-1 makes Xorg crash almost for everything:/

I don't think it's a problem with intel driver 2.7.1, as I'm using the intel-legacy driver and since the update of intel-dri the same thing is happening to me: when switching compositing on or off X crashes (FYI the command succeeds, so after an X restart the selected option works fine).
I'm on KDEmod4 and a 945gm.
EDIT: It's not a problem with the kernel too, as I'm using an older 2.6.29.1 kernel.

Last edited by Lazer (2009-05-16 19:57:02)

Offline

#3 2009-05-16 20:08:08

afiestas
Member
Registered: 2008-12-28
Posts: 18

Re: Intel 2.7.1+kernel 2.6.29.3-1 makes Xorg crash almost for everything:/

I'm trying now the last pkg's my pacman cache saved, and nothing seems to be fixed, so I'm not sure if the problem is the intel-dri

intel-dri-7.4.1-1-x86_64.pkg.tar.gz
xf86-video-intel-2.7.0-3-x86_64.pkg.tar.gz

Offline

#4 2009-05-17 14:58:37

leeyee
Member
From: Kingston, Canada
Registered: 2009-01-07
Posts: 150

Re: Intel 2.7.1+kernel 2.6.29.3-1 makes Xorg crash almost for everything:/

afiestas wrote:

I'm trying now the last pkg's my pacman cache saved, and nothing seems to be fixed, so I'm not sure if the problem is the intel-dri

intel-dri-7.4.1-1-x86_64.pkg.tar.gz
xf86-video-intel-2.7.0-3-x86_64.pkg.tar.gz

you may also need to downgrade mesa, libgl to former versions. I also had some graphics problems related to the recent upgrade, for example shuting down information disappeared. Downgrade mesa, libgl, intel-dri, and xf86-video-intel to former version seems fix it. But I really don't know why.

xf86-video-intel 2.7.0-3
libgl 7.4.1-1
mesa 7.4.1-1
intel-dri 7.4.1-1


Archlinux x86_64 on Thinkpad T400
Intel X4500MHD / ATI HD3470 Graphics, 2G RAM, 160G HD

Offline

#5 2009-05-17 18:45:20

afiestas
Member
Registered: 2008-12-28
Posts: 18

Re: Intel 2.7.1+kernel 2.6.29.3-1 makes Xorg crash almost for everything:/

leeyee wrote:
afiestas wrote:

I'm trying now the last pkg's my pacman cache saved, and nothing seems to be fixed, so I'm not sure if the problem is the intel-dri

intel-dri-7.4.1-1-x86_64.pkg.tar.gz
xf86-video-intel-2.7.0-3-x86_64.pkg.tar.gz

you may also need to downgrade mesa, libgl to former versions. I also had some graphics problems related to the recent upgrade, for example shuting down information disappeared. Downgrade mesa, libgl, intel-dri, and xf86-video-intel to former version seems fix it. But I really don't know why.

xf86-video-intel 2.7.0-3
libgl 7.4.1-1
mesa 7.4.1-1
intel-dri 7.4.1-1

Wowow! big_smile so nice! I'm really appreciated! I need my dualscreen to have a happy hacking big_smile
I'm going to fill a bug report, so the developers can be aware of this.

Once again, Thanks!

Offline

#6 2009-05-18 17:40:33

gborzi
Member
From: Sicilia
Registered: 2009-03-18
Posts: 102

Re: Intel 2.7.1+kernel 2.6.29.3-1 makes Xorg crash almost for everything:/

Thanks leeyee, I had noticed some problem after the update (using assaultcube), downgraded and now it's working fine. I've noticed that the 7.4.1 packages include a 7.4-branch.patch and 7.4.2 packages don't include this patch. Perhaps this is the source of the problems.


Giuseppe Borzi' - Registered Linux user #34028

Offline

#7 2009-05-19 14:56:49

kenshis
Member
Registered: 2008-12-16
Posts: 52

Re: Intel 2.7.1+kernel 2.6.29.3-1 makes Xorg crash almost for everything:/

Don't know if this is related, but after not so long full system upgrade, when i try to change external monitor resolution X'es crashes. I still can move my mouse, but thats all.
My internal laptop display works flawlessly.
I downgraded to:

xf86-video-intel 2.7.0-3
libgl 7.4.1-1
mesa 7.4.1-1
intel-dri 7.4.1-1

but no changes.

the only culprit in my ayes are X'es ....

Offline

#8 2009-05-21 08:38:58

grey
Member
From: Europe
Registered: 2007-08-23
Posts: 679

Re: Intel 2.7.1+kernel 2.6.29.3-1 makes Xorg crash almost for everything:/

kenshis: if the downgrade doesn't fix your problem, it is not related. The issue here is a bug that was introduced in mesa 7.4.2.


Good ideas do not need lots of lies told about them in order to gain public acceptance.

Offline

#9 2009-05-21 10:47:31

Dheart
Member
From: Sofia, Bulgaria
Registered: 2006-10-26
Posts: 943

Re: Intel 2.7.1+kernel 2.6.29.3-1 makes Xorg crash almost for everything:/

For me using exa in stead of uxa fixes the problem with frequent crashes.


My victim you are meant to be
No, you cannot hide nor flee
You know what I'm looking for
Pleasure your torture, I will endure...

Offline

#10 2009-05-21 14:11:54

gborzi
Member
From: Sicilia
Registered: 2009-03-18
Posts: 102

Re: Intel 2.7.1+kernel 2.6.29.3-1 makes Xorg crash almost for everything:/

I've updated libgl to 7.4.2-2 that includes 7.4-branch.patch again (I also updated mesa, intel-dri and xf86-video-intel), and it is working fine, tested with assaultcube.


Giuseppe Borzi' - Registered Linux user #34028

Offline

#11 2009-05-22 21:45:14

grey
Member
From: Europe
Registered: 2007-08-23
Posts: 679

Re: Intel 2.7.1+kernel 2.6.29.3-1 makes Xorg crash almost for everything:/

Same here - with the latest packages sanity is restored. I suggest marking this thread as SOLVED.


Good ideas do not need lots of lies told about them in order to gain public acceptance.

Offline

#12 2009-05-23 03:27:08

demian
Member
From: Frankfurt, Germany
Registered: 2009-05-06
Posts: 709

Re: Intel 2.7.1+kernel 2.6.29.3-1 makes Xorg crash almost for everything:/

I am experiencing similar X crashes with system build of yesterday (therefore latest kernel and libgl, mesa and intel-dri).
The two weeks old system build I had before gave me the same crashes.
I get dropped to shell when X crashes since I don't have any login manager. When dropped to shell i can start X again although i sometimes get dropped back to shell immediately.
The crashes appear regardless of wether I use xorg.conf (not modified) or xf86-input-evdev.
Hardware is Intel GM45 chipset with Intel X4500HD.

Some error messages i could find:
dmesg | tail either gives:

[drm: gm45_get_vblank_counter] *ERROR* trying to get vblank count for disabled page 0

or:

[drm: gm45_get_vblank_counter] *ERROR* trying to get vblank count for disabled page 1

also, when dropped to shell I sometimes get something like this:

gnome-settings-daemon:5914: GStreamer plugin cannot open shared object file: No such file or directory
window manager warning: Failed to read saved session file /some/file/... Failed to open file. No such file or directory.
Nautilus  .... also complaining about a file or directory not found

Fatal server error:
Caught signal 11. Server aborting. (Signal 11 is /usr/bin/X [0x8071401] i think)
Dropping master
Window manager warning: Fatal IO Error 11 (Resource temp. unavailable) on display ':0.0'.
gnome-settings-daemon: Fatal IO Error 11 (Resource temp. unavailable) on X Server :0.0
xinit: connection to X server lost

grep EE /var/log/Xorg.0.log

(II) Loading extension MIT-SCREEN-SAVER

grep WW /var/log/Xorg.0.log

(WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
(WW) Disabling Mouse0
(WW) Disabling Keyboard0
(WW) intel(0): libpciaccess reported 0 rom size, guessing 64kB
(WW) intel(0): Register 0x61110 (PORT_HOTPLUG_EN) changed from 0x10000120 to 0x38000120
(WW) intel(0): Register 0x61114 (PORT_HOTPLUG_STAT) changed from 0x10000000 to 0x38000000
(WW) intel(0): Register 0x321b (FBC_FENCE_OFF) changed from 0x20001000 to 0x11001000
(WW) intel(0): DRI2 requires UXA

Up to now, I downgraded mesa, libgl and intel-dri from the very latest (7.4.2-*) to 7.2-*. The problem remains.

I will check my hardware today but since Windows is running fine right now I assume it is a driver issue.
I will also try downgrading even further, maybe reinstall Xorg and reconfigure and tweak the xorg.conf but any hints on what I could do to solve the problem would be greatly appreciated.

/edit: I just tried out vesa instead of xf86-video-intel. With vesa Xorg crashes almost immediately while the intel driver lasts longer.

/edit: Switched from GNOME to Openbox yesterday. The problem vanished.

process 2990 (=gnome-session): arguments to 'dbus_connection_send_with_reply_and_block() were incorrect, assertion "connection!=NULL" failed in file dbus-connection.c line 3298.

However, I just installed many programs i used to use in Gnome (+ gnome dependencies of course) and the problem occurred again. I would assume it's gnome-specific but since one of the previous posters has that problem with KDE i really don't know what's causing this. Starting without hal and dbus didn't help either.
I will stick with Openbox now and remove all gnome dependencies.

Regards,

demian

Have to correct myself: Problem did not vanish but it's rather rare now. Only happens once every few hours or when switching to vc/2.

Last edited by demian (2009-06-01 10:13:20)


no place like /home
github

Offline

Board footer

Powered by FluxBB