You are not logged in.

#1 2009-05-20 18:29:43

Raffles10
Member
From: London, UK
Registered: 2009-05-09
Posts: 115

(SOLVED) System Beep

Please try and help me kill this thing !

I've used search & google, I've tried the old way of 'blacklist pcspkr' in /etc/modprobe.d/blacklist, Ive tried !pcspkr !snd_pcsp in /etc/rc.conf, I've even tried the deprecated method of MOD_BLACKLIST=(pcspkr), and still I have the system beep driving me crazy ! At the moment I'm just using rmmod pcspkr to kill it every time I login, but I want to kill it stone dead, permanently.

I've been using Linux for a over year, and I've done a fair amount of distro' hopping and I've always been able to kill the beep using the '/etc/modprobe.d/blacklist' method, except in arch, why is the system beep so hard to kill in arch ?

Last edited by Raffles10 (2009-05-22 21:06:19)

Offline

#2 2009-05-20 18:36:56

djgera
Developer
From: Buenos Aires - Argentina
Registered: 2008-12-24
Posts: 717
Website

Re: (SOLVED) System Beep

bell in the console on tab-completion?

Edit your /etc/inputrc and uncomment:

set bell-style none

Offline

#3 2009-05-20 18:41:06

Procyon
Member
Registered: 2008-05-07
Posts: 1,819

Re: (SOLVED) System Beep

!snd_pcsp in /etc/rc.conf

it should be !snd-pcsp

Offline

#4 2009-05-20 18:53:53

ataraxia
Member
From: Pittsburgh
Registered: 2007-05-06
Posts: 1,553

Re: (SOLVED) System Beep

Make sure you mute the "PC Beep" channel in alsamixer once your regular sound driver is loaded, and run "alsactl store" to nail it down. (The shutdown of the alsa initscript will do the store for you, if you have that loaded.)

Offline

#5 2009-05-20 20:20:45

rzodkiewka
Member
Registered: 2009-04-19
Posts: 41

Re: (SOLVED) System Beep

If you like drastic solutions, you can just remove it - I did it and it's OK.

# rmmod pcspkr

Offline

#6 2009-05-20 20:36:57

Pyntux
Member
From: Serbia
Registered: 2008-12-21
Posts: 310

Re: (SOLVED) System Beep

I just muted pcspkr and after reboot KDE asked if I wanr to remove pcspkr because dont working...blacklisting wasn` work for me eather...


I do not speak English, but I understand...

Offline

#7 2009-05-20 22:00:34

Raffles10
Member
From: London, UK
Registered: 2009-05-09
Posts: 115

Re: (SOLVED) System Beep

Thanks for your responses.

I've uncommented 'set bell-style none' in /etc/inputrc, but still get beeped every time I delete a file or folder.

I've changed !snd_pcsp to !snd-pcsp, still beeps.

I don't have a 'PC Beep' in alsamixer.

I'm using 'rmmod pcspkr' every session but this is not permanent, a reboot brings it back.

I'm using Xfce 4.6

And having tried every solution I have read, here and elsewhere, the ****ing beep is still alive and beeping !

Offline

#8 2009-05-20 22:23:55

SamC
Member
From: Calgary
Registered: 2008-05-13
Posts: 611
Website

Re: (SOLVED) System Beep

You could set it up so that rmmod pcspkr is run every time at boot. Perhaps in rc.local?

Offline

#9 2009-05-20 22:58:10

R00KIE
Forum Moderator
From: Between a computer and a chair
Registered: 2008-09-14
Posts: 4,734

Re: (SOLVED) System Beep

Maybe you can try to alias it in modprobe.conf as one should do to disable ipv6

alias pcspkr off

Mind you that I have blacklisted both pcspkr and snd_pcsp in rc.conf .... sometime ago it seemed to me that if you just blacklisted one it would load the other and keep making noise .... I don't like the beep too I had to kill it big_smile


R00KIE
Tm90aGluZyB0byBzZWUgaGVyZSwgbW92ZSBhbG9uZy4K

Offline

#10 2009-05-20 23:12:11

Ferrenrock
Member
Registered: 2008-11-22
Posts: 36

Re: (SOLVED) System Beep

you know, your computer might be like mine, where the system bell isn't even the same device as the pc speaker. Did you try this?

xset b off
xset b 0 0 0

Offline

#11 2009-05-20 23:17:11

karol
Archivist
Registered: 2009-05-06
Posts: 25,440

Re: (SOLVED) System Beep

It's like that old chestnut:
-- Doctor, it hurts when I do _this_.
= Than don't.

Don't delete files etc. :-)

'setterm -blength 0' works for me in the console. All the other ways don't. When I get to my Arch box I'll try to check the other methods listed in the wiki in X. You did try them, right?


EDIT:
http://wiki.archlinux.org/index.php/Dis … eaker_beep
Follow the wiki / Ferrenrock's advice - worked for me. I seems to be a per-user setting.

Remember that 'echo -e "\a"' won't beep anymore (some people use it in their scripts).

Last edited by karol (2009-05-20 23:25:16)

Offline

#12 2009-05-21 01:04:25

Odysseus
Member
Registered: 2009-02-15
Posts: 138

Re: (SOLVED) System Beep

I have to blacklist both snd_pcsp and pcspkr.


I'm the type to fling myself headlong through the magical wardrobe, and then incinerate the ornate mahogany portal behind me with a Molotov cocktail.

Offline

#13 2009-05-22 21:05:15

Raffles10
Member
From: London, UK
Registered: 2009-05-09
Posts: 115

Re: (SOLVED) System Beep

Succes ! After trying all of the above I now have a silent arch.:D

Slence is golden,;)

Offline

#14 2009-05-23 01:28:04

Misfit138
Misfit Emeritus
From: USA
Registered: 2006-11-27
Posts: 4,172

Re: (SOLVED) System Beep

Raffles10 wrote:

Succes ! After trying all of the above I now have a silent arch.:D

Slence is golden,;)

..but which solution did you use?

Offline

#15 2009-05-23 12:31:06

dmartins
Member
Registered: 2006-09-23
Posts: 360

Re: (SOLVED) System Beep

For me, adding !snd_pcsp !pcspkr to the MODULES array in /etc/rc.conf silences the speaker.

Offline

#16 2009-05-23 19:04:16

Raffles10
Member
From: London, UK
Registered: 2009-05-09
Posts: 115

Re: (SOLVED) System Beep

dmartins wrote:

For me, adding !snd_pcsp !pcspkr to the MODULES array in /etc/rc.conf silences the speaker.

Yes. You have to use both, one doesn't seem to do it on it's own.

Offline

Board footer

Powered by FluxBB