You are not logged in.

#1 2009-05-31 15:46:58

eldragon
Member
From: Buenos Aires
Registered: 2008-11-18
Posts: 1,026

cannot replace lzma-utils due to dependencies from yelp

:: Replace lzma-utils with testing/xz-utils? [Y/n] 
error: failed to prepare transaction (could not satisfy dependencies)
:: Starting full system upgrade...
resolving dependencies...
:: yelp: requires lzma-utils>=4.32.7

Offline

#2 2009-05-31 15:51:00

Allan
Developer
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,361
Website

Re: cannot replace lzma-utils due to dependencies from yelp

This has been fixed.  Wait for your mirror to sync.

(and you should read arch-dev-public...  it is recommended for all [testing] users)

Offline

#3 2009-05-31 15:55:11

eldragon
Member
From: Buenos Aires
Registered: 2008-11-18
Posts: 1,026

Re: cannot replace lzma-utils due to dependencies from yelp

Allan wrote:

This has been fixed.  Wait for your mirror to sync.

(and you should read arch-dev-public...  it is recommended for all [testing] users)

i do read arch-dev-public... missed it sad

just read it, those messages passed before i did the update sad

Last edited by eldragon (2009-05-31 16:00:44)

Offline

#4 2009-05-31 16:05:46

Roberth
Member
From: Norway
Registered: 2007-01-12
Posts: 887

Re: cannot replace lzma-utils due to dependencies from yelp

Libarchive also depends on xz-utils.


Use the Source, Luke!

Offline

#5 2009-06-02 00:38:55

cb474
Member
Registered: 2009-04-04
Posts: 465

Re: cannot replace lzma-utils due to dependencies from yelp

I'm not a testing user, although I have testing in my pacman.conf, because I originally installed go-openoffice from testing, before it was in extra. But I have testing listed in pacman.conf below core and extra, which I thought was supposed to prevent upgrading my system to testing in general. So should I not do the upgrade to xz-utils, if I'm not really a testing user?

Also is this eventually going to percolate down to extra or core anyway?

Offline

#6 2009-06-02 08:21:36

philacorns
Member
From: Beijing
Registered: 2009-01-25
Posts: 21

Re: cannot replace lzma-utils due to dependencies from yelp

@cb474
There is no need for you to do the upgrade unless you need xz format very much.
Almost all testing packages will enter extra or core after testing work.

Offline

#7 2009-06-03 01:06:19

cb474
Member
Registered: 2009-04-04
Posts: 465

Re: cannot replace lzma-utils due to dependencies from yelp

Thanks. Given that I didn't even know what the xz format is until this came up, I'm going to assume I don't need it. But is there any harm in my upgrading to xz utils if for no other reason than to get pacman to stop bugging me about it? Is this the way things are going, as it were, anyway?

Offline

#8 2009-06-03 03:54:54

Allan
Developer
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,361
Website

Re: cannot replace lzma-utils due to dependencies from yelp

Just remove the [testing] repo from pacman.conf.  You really shouldn't have it below [core] and [extra] anyway...

Offline

#9 2009-06-04 01:26:30

cb474
Member
Registered: 2009-04-04
Posts: 465

Re: cannot replace lzma-utils due to dependencies from yelp

Allan wrote:

Just remove the [testing] repo from pacman.conf.  You really shouldn't have it below [core] and [extra] anyway...

Not to hijack the thread, but really? I read somewhere that was the thing to do, if I wanted to install a package from testing, but didn't want to upgrade my whole system to testing. Is there a different more proper way to do that, if the need should arise for in the future?

Offline

#10 2009-06-07 22:39:02

synonym24
Member
Registered: 2009-01-27
Posts: 3

Re: cannot replace lzma-utils due to dependencies from yelp

Allan wrote:

This has been fixed.  Wait for your mirror to sync.

(and you should read arch-dev-public...  it is recommended for all [testing] users)

I'm sorry, but I can't update. I always get the same error as eldragon! I've tried it with the mirror I always use  and the original Arch one. Am I doing something wrong?

Offline

#11 2009-06-21 19:26:48

whot
Member
Registered: 2005-03-13
Posts: 18

Re: cannot replace lzma-utils due to dependencies from yelp

@synonym24

I had the same problem.  For me, the old version of yelp needed lzma-utils, the new version didn't.  So I updated yelp first, then I was able to pacman -Syu sucessfully.

good luck.

Last edited by whot (2009-06-21 19:27:14)

Offline

Board footer

Powered by FluxBB