You are not logged in.

#1 2004-12-10 22:15:58

nacnud
Member
From: Brooklyn
Registered: 2004-11-04
Posts: 22

Soundserver (artsd) crashes when using Noatun

Hi folks,

After upgrade to KDE 3.3.2 Noatun causes artsd to crash when I try to open an mp3 stream from an internet radio station (it worked prior to upgrade).  I get a SIGSEVD (signal 11) notification, with the following backtrace:

Using host libthread_db library "/lib/tls/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1208068416 (LWP 1843)]
[New Thread -1236288592 (LWP 2131)]
[Thread debugging using libthread_db enabled]
[New Thread -1208068416 (LWP 1843)]
[New Thread -1236288592 (LWP 2131)]
[Thread debugging using libthread_db enabled]
[New Thread -1208068416 (LWP 1843)]
[New Thread -1236288592 (LWP 2131)]
[KCrash handler]
#42 0x437aa3d0 in Arts::Synth_MULTI_ADD_impl::calculateBlock () from /opt/kde/lib/libartsflow.so.1
#43 0x437a8f96 in Arts::StdScheduleNode::gslProcess () from /opt/kde/lib/libartsflow.so.1
#44 0x4381acc9 in master_process_locked_node () from /opt/kde/lib/libartsflow.so.1
#45 0x4381c1da in _engine_master_dispatch () from /opt/kde/lib/libartsflow.so.1
#46 0x43818a56 in gsl_engine_dispatch () from /opt/kde/lib/libartsflow.so.1
#47 0x437ae9a8 in Arts::StdScheduleNode::requireFlow () from /opt/kde/lib/libartsflow.so.1
#48 0x437c256c in Arts::Synth_PLAY_impl::needMore () from /opt/kde/lib/libartsflow.so.1
#49 0x437b242e in Arts::AudioSubSystem::handleIO () from /opt/kde/lib/libartsflow.so.1
#50 0x437b2636 in Arts::AudioIOALSA::notifyIO () from /opt/kde/lib/libartsflow.so.1
#51 0x436fb5b9 in Arts::StdIOManager::processOneEvent () from /opt/kde/lib/libmcop.so.1
#52 0x436c9681 in Arts::StdIOManager::run () from /opt/kde/lib/libmcop.so.1
#53 0x436c9507 in Arts::Dispatcher::run () from /opt/kde/lib/libmcop.so.1
#54 0x0805957e in ?? ()
#55 0xbffff740 in ?? ()
#56 0x0806b13c in vtable for Arts::TimeNotify ()
#57 0x00000000 in ?? ()
#58 0x080be034 in ?? ()
#59 0x00000013 in ?? ()
#60 0xbffff77c in ?? ()
#61 0x4107bfe1 in _int_malloc () from /lib/tls/libc.so.6
#62 0x4102d19d in __libc_start_main () from /lib/tls/libc.so.6
#63 0x08053f11 in ?? ()

Now I have no idea what this means....  Anyone have any ideas?  This may not be related, but mplayer is also having some problems: when I try to watch a movie trailer in firefox, mplayer starts, downloads the data, then doesn't show anything.

Thanks.

Offline

#2 2004-12-12 03:52:18

cjdj
Member
From: Perth, Western Australia
Registered: 2004-05-07
Posts: 121

Re: Soundserver (artsd) crashes when using Noatun

I have a similar problem but a bit different.
MP3's work ok, but playing any mpeg or avi causes artsd to crash.
I was able to play movies with xine, but kaboodle or noatun failed.

Offline

#3 2004-12-12 16:18:05

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,261

Re: Soundserver (artsd) crashes when using Noatun

i can confirm that
don't know why kaffeine works (possible because it was build with old glibc)
amarok seems to have problems too ( was build with new glibc i guess)

arts rebuild kdemultimedia rebuild doesn't help at all

my favourite is xine-lib will try if a rebuild would help

Offline

#4 2004-12-12 18:35:10

nacnud
Member
From: Brooklyn
Registered: 2004-11-04
Posts: 22

Re: Soundserver (artsd) crashes when using Noatun

I installed Amarok and got it to work with the mp3/ogg stream by having it use the artsd engine and making sure Firefox opens it by default rather than noatun.

I too am able to play regular mp3s with noatun and mplayer; it's just streaming on the internet that doesn't work, I guess.

Offline

#5 2004-12-12 19:09:11

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,261

Re: Soundserver (artsd) crashes when using Noatun

xine-lib rebuild doesn't help sad
you can also not change arts output in kcontrol
system will hang or will show you a sigssev 11

Offline

#6 2004-12-13 13:10:56

audaly
Member
From: France
Registered: 2004-12-13
Posts: 60

Re: Soundserver (artsd) crashes when using Noatun

I have a similar problem but a bit different.
MP3's work ok, but playing any mpeg or avi causes artsd to crash.
I was able to play movies with xine, but kaboodle or noatun failed.

Same problem...

What's your sound card? intel8x0?

Offline

#7 2004-12-13 22:29:54

colnago
Member
From: Victoria, BC
Registered: 2004-03-25
Posts: 438

Re: Soundserver (artsd) crashes when using Noatun

I have the problem and it is an intel8x0, but maye just a coincidence, as there are so many.

Offline

#8 2004-12-13 23:50:36

audaly
Member
From: France
Registered: 2004-12-13
Posts: 60

Re: Soundserver (artsd) crashes when using Noatun

I don't think it's a coincidence. I installed arch on 3 pc this week and I've this problem on the two with a intel8x0...
I searched on the web and I found many people having the same problem and every time they had intel8x0...

Offline

#9 2004-12-13 23:59:06

nacnud
Member
From: Brooklyn
Registered: 2004-11-04
Posts: 22

Re: Soundserver (artsd) crashes when using Noatun

Yep, I have that card too.

Offline

#10 2004-12-14 03:52:39

cjdj
Member
From: Perth, Western Australia
Registered: 2004-05-07
Posts: 121

Re: Soundserver (artsd) crashes when using Noatun

yes, I also have the intel8x0...

Offline

#11 2004-12-14 12:39:46

audaly
Member
From: France
Registered: 2004-12-13
Posts: 60

Re: Soundserver (artsd) crashes when using Noatun

Ok it's not a coincidence.... What can we do now?

Offline

#12 2004-12-14 17:32:13

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,261

Re: Soundserver (artsd) crashes when using Noatun

hi i found something in kde bug tracker:
http://bugs.kde.org/show_bug.cgi?id=91497

there is a patch inlcuded i rebuild kdelibs now and look if it helps

Offline

#13 2004-12-14 22:17:35

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,261

Re: Soundserver (artsd) crashes when using Noatun

hi the patch fixed kcontrol soundserver gui
but xine is not really working
i managed to get it working when starting artscontrol and then load the menu environment
then you can watch files with xine but it segfaults from time to time
artswrapper setting to suid doesn't help sad
if you have any ideas post them here else i think we have to wait for a new xine or kde release sad

Offline

#14 2004-12-14 23:16:55

audaly
Member
From: France
Registered: 2004-12-13
Posts: 60

Re: Soundserver (artsd) crashes when using Noatun

The problem is not only with xine, also with mplayer... I think we must wait for a new version of KDE! When is the next version planned?

Offline

#15 2004-12-15 01:15:22

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: Soundserver (artsd) crashes when using Noatun

audaly wrote:

The problem is not only with xine, also with mplayer... I think we must wait for a new version of KDE! When is the next version planned?

http://developer.kde.org/development-ve … -plan.html
For KDE 3.4 : Wednesday March 16th, 2005: Targeted Release date

Seems like we'll have to wait  3 months!

Offline

#16 2004-12-15 01:19:31

audaly
Member
From: France
Registered: 2004-12-13
Posts: 60

Re: Soundserver (artsd) crashes when using Noatun

3 months....  :? ....ok, let's find another solution!!

Offline

#17 2004-12-15 18:16:36

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,261

Re: Soundserver (artsd) crashes when using Noatun

new xine rc8 will fix it smile

Offline

#18 2004-12-16 04:34:47

sabrewolf
Member
Registered: 2004-10-26
Posts: 45

Re: Soundserver (artsd) crashes when using Noatun

me too, sometimes, kaffeine cant play videos, then, killall artsd and artsd y ok, but amarok ok, not problem, my sound card is a via82xxx  :?


[code]sorry for my english [/code]

Offline

#19 2004-12-19 00:50:03

audaly
Member
From: France
Registered: 2004-12-13
Posts: 60

Re: Soundserver (artsd) crashes when using Noatun

pacman -Syu and everything is working again with the new kdebase and xine package!

Offline

#20 2004-12-22 02:15:46

dekernel
Member
From: Vassar, MI USA
Registered: 2004-03-22
Posts: 117

Re: Soundserver (artsd) crashes when using Noatun

Now I am at least getting this when I did a system upgrade

Using host libthread_db library "/lib/tls/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1216791776 (LWP 1757)]
[New Thread -1219339344 (LWP 1822)]
[Thread debugging using libthread_db enabled]
[New Thread -1216791776 (LWP 1757)]
[New Thread -1219339344 (LWP 1822)]
[Thread debugging using libthread_db enabled]
[New Thread -1216791776 (LWP 1757)]
[New Thread -1219339344 (LWP 1822)]
[KCrash handler]
#22 0xb7ff2ba0 in do_lookup_x () from /lib/ld-linux.so.2
#23 0xb7ff31e8 in _dl_lookup_symbol_x () from /lib/ld-linux.so.2
#24 0xb7ff4499 in _dl_relocate_object () from /lib/ld-linux.so.2
#25 0xb787f3ca in dl_open_worker () from /lib/tls/libc.so.6
#26 0xb7ff6b5e in _dl_catch_error () from /lib/ld-linux.so.2
#27 0xb787fc48 in _dl_open () from /lib/tls/libc.so.6
#28 0xb7a4ae48 in dlopen_doit () from /lib/tls/libdl.so.2
#29 0xb7ff6b5e in _dl_catch_error () from /lib/ld-linux.so.2
#30 0xb7a4b3de in _dlerror_run () from /lib/tls/libdl.so.2
#31 0xb7a4aea1 in dlopen@@GLIBC_2.1 () from /lib/tls/libdl.so.2
#32 0xb7542c7b in collect_plugins () from /usr/lib/libxine.so.1

Offline

#21 2004-12-22 02:26:58

dekernel
Member
From: Vassar, MI USA
Registered: 2004-03-22
Posts: 117

Re: Soundserver (artsd) crashes when using Noatun

Well, all of a sudden, things are working. For some reason, once I right-clicked in Konq, a file and selected "Preview in Embedded Media Player" things started working!!!

Offline

#22 2004-12-22 21:32:54

LB06
Member
From: The Netherlands
Registered: 2003-10-29
Posts: 435

Re: Soundserver (artsd) crashes when using Noatun

I also had artsd related problems with my snd-intel8x0

Offline

Board footer

Powered by FluxBB