You are not logged in.

#1 2004-05-22 18:39:51

@leX
Member
From: Israel
Registered: 2003-11-06
Posts: 76

SciTE 1.60 UTF-8 problem

I can't write Russian or Hebrew when i set "File-> Encoding->UTF-8"
In Kate for example it's work properly.

Offline

#2 2004-05-22 21:31:54

neri
Forum Fellow
From: Victoria, Canada
Registered: 2003-05-04
Posts: 552

Re: SciTE 1.60 UTF-8 problem

@leX wrote:

I can't write Russian or Hebrew when i set "File-> Encoding->UTF-8"
In Kate for example it's work properly.

I can write german Umlauts like ü,ä,ö without problems.  I also copied a text
from the Russian truth (prawda) to it and saw the text correctly.

My crystal ball says you dont have enabled the pango engine in scite. Instead
you sticked with the oridinary gtk textarea. To enable it you need specify
your font settings in your /usr/share/scite/SciTEGlobal.properties (or you
local copy of itin ~) with setting an exclamation mark infron of the font.

Here is a copy of mine:

# Give symbolic names to the set of fonts used in the standard styles.
if PLAT_WIN
    font.base=font:Verdana,size:10
    font.small=font:Verdana,size:8
    font.comment=font:Comic Sans MS,size:9
    font.code.comment.box=$(font.comment)
    font.code.comment.line=$(font.comment)
    font.code.comment.doc=$(font.comment)
    font.text=font:Times New Roman,size:11
    font.text.comment=font:Verdana,size:9
    font.embedded.base=font:Verdana,size:9
    font.embedded.comment=font:Comic Sans MS,size:8
    font.monospace=font:Courier New,size:10
    font.vbs=font:Lucida Sans Unicode,size:10
if PLAT_GTK
    font.base=font:!bitstream vera sans mono,size:10
    font.small=font:!bitstream vera sans mono,size:9
    font.comment=font:!bitstream vera sans mono,italics,size:10
    font.code.comment.box=$(font.comment)
    font.code.comment.line=$(font.comment)
    font.code.comment.doc=$(font.comment)
    font.text=font:!bitstream vera sans mono,size:10
    font.text.comment=font:!bitstream vera sans mono,size:10
    font.embedded.base=font:!bitstream vera sans mono,size:9
    font.embedded.comment=font:!bitstream vera sans monosize:9
    font.monospace=font:!andale mono,size:10
    font.vbs=font:!bitstream vera sans mono,size:10
font.js=$(font.comment)

Try this, HTH

bye neri

Offline

#3 2004-11-05 17:11:25

@leX
Member
From: Israel
Registered: 2003-11-06
Posts: 76

Re: SciTE 1.60 UTF-8 problem

neri
Grate.
Thank you.
It's work.
I put its text to my SciteUser.properties

Offline

#4 2004-12-14 19:11:06

@leX
Member
From: Israel
Registered: 2003-11-06
Posts: 76

Re: SciTE 1.60 UTF-8 problem

My font proposition

font.face=!Bitstream Vera Sans Mono
font_size.big=9
font_size.small=9
font_size.verysmall=9

font.base=font:$(font.face),size:$(font_size.big)
font.small=font:$(font.face),size:$(font_size.small)
font.verysmall=font:$(font.face),size:$(font_size.verysmall)
font.comment=$(font.small)
font.code.comment.box=$(font.comment)
font.code.comment.line=$(font.comment)
font.code.comment.doc=$(font.comment)
font.text=$(font.small)
font.text.comment=$(font.small)
font.embedded.base=$(font.small)
font.embedded.comment=$(font.small)
font.monospace=$(font.small)
font.vbs=$(font.monospace)
font.js=$(font.monospace)

Offline

Board footer

Powered by FluxBB