You are not logged in.

#1 2004-12-16 03:32:23

makz
Member
Registered: 2004-12-07
Posts: 27

udev not setting correct user and group for some devices

my udev.permissions:

# audio devices
dsp*:root:audio:0660
audio*:root:audio:0660
midi*:root:audio:0660
mixer*:root:audio:0660
sequencer*:root:audio:0660
sound/*:root:audio:0660
snd/*:root:audio:0660
beep:root:audio:0660
admm*:root:audio:0660
adsp*:root:audio:0660
aload*:root:audio:0660
amidi*:root:audio:0660
dmfm*:root:audio:0660
dmmidi*:root:audio:0660
sndstat:root:audio:0660

the real permissions for /dev/sound/*

[makz@multivac makz]$ ls -l /dev/sound/
total 0
crw-rw----  1 root root 14, 4 2004-12-15 16:11 audio
crw-rw----  1 root root 14, 9 2004-12-15 16:11 dmmidi
crw-rw----  1 root root 14, 3 2004-12-15 16:11 dsp
crw-rw----  1 root root 14, 2 2004-12-15 16:11 midi
crw-rw----  1 root root 14, 0 2004-12-15 16:11 mixer

why is root the owner group for those files if udev.permissions says it's audio?

before you ask this is my udev.rules

# oss devices
KERNEL="audio*",     NAME="sound/%k", SYMLINK="%k"
KERNEL="dmmidi",     NAME="sound/%k", SYMLINK="%k"
KERNEL="dsp*",       NAME="sound/%k", SYMLINK="%k"
KERNEL="midi*",      NAME="sound/%k", SYMLINK="%k"
KERNEL="mixer*",     NAME="sound/%k", SYMLINK="%k"
KERNEL="sequencer*", NAME="sound/%k", SYMLINK="%k"

and the udev.conf:

# udev_root - where in the filesystem to place the device nodes
udev_root="/dev"

# udev_db - The name and location of the udev database.
udev_db="/dev/.udevdb"

# udev_rules - The name and location of the udev rules file
udev_rules="/etc/udev/rules.d/"

# udev_permissions - The name and location of the udev permission file
udev_permissions="/etc/udev/permissions.d/"

# default_mode - set the default mode for all nodes that have no
#                explicit match in the permissions file
default_mode="0600"

# default_owner - set the default owner for all nodes that have no
#                 explicit match in the permissions file
default_owner="root"

# default_group - set the default group for all nodes that have no
#                 explicit match in the permissions file
default_group="root"

# udev_log - set to "yes" if you want logging, else "no"
udev_log="yes"

As you can see those are the default configuration files when you install udev.

BTW where is the udev log file?

Offline

#2 2004-12-16 03:47:16

darose
Member
Registered: 2004-04-13
Posts: 120

Re: udev not setting correct user and group for some devices

Even though you have udev installed and configured, do you actually have your system set to use it when you boot?  (i.e., "devfs=nomount" on your vmlinuz line in lilo/grub).  If you don't have that, then you're still actually using devfs and so all your udev configuration updates are getting ignored.

Offline

#3 2004-12-16 04:45:04

makz
Member
Registered: 2004-12-07
Posts: 27

Re: udev not setting correct user and group for some devices

yes, i have the parameter devfs=nomount in my grub conf (menu.lst)

# (0) Arch Linux
title  Arch Linux  [/boot/vmlinuz26]
root   (hd0,1)
kernel /boot/vmlinuz26 root=/dev/discs/disc0/part2 ro devfs=nomount

Offline

#4 2004-12-16 15:56:53

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: udev not setting correct user and group for some devices

are these symlinks? if so the answer is here:
http://bbs.archlinux.org/viewtopic.php?t=8656
(the topic is almost the same as this thread....)

Offline

#5 2004-12-16 16:19:52

i3839
Member
Registered: 2004-02-04
Posts: 1,185

Re: udev not setting correct user and group for some devices

No, those are not symlinks, so make sure udev is creating the things and that devfs isn't enabled.

Offline

#6 2004-12-16 18:04:09

makz
Member
Registered: 2004-12-07
Posts: 27

Re: udev not setting correct user and group for some devices

I know udev is creating those things because if i rename my udev.rules to something without .rules so udev cannot find it, i get a message that says "cannot find /dev/discs/disc0/part2", there is where / is mounted and also many devices disappear.
Maybe it's because i'm using a 2.6.3 kernel, i'll try with 2.6.9.

Offline

#7 2004-12-16 21:20:36

Shofs
Member
From: Central Illinois
Registered: 2004-12-15
Posts: 184

Re: udev not setting correct user and group for some devices

Offline

#8 2004-12-16 21:22:48

makz
Member
Registered: 2004-12-07
Posts: 27

Re: udev not setting correct user and group for some devices

i solved it, udev didn't changed the group to audio because audio group didn't exist, i created the group with groupadd and now everithing is ok.
I was really sure audio group existed, but it don't.

Offline

Board footer

Powered by FluxBB