You are not logged in.

#26 2009-07-09 22:13:34

Pierre
Developer
From: Bonn
Registered: 2004-07-05
Posts: 1,950
Website

Re: LibJpeg and... errors with jpg images [ KDE 4.3 RC from kde-unstable]

Digikam from testing links to libjpeg-7 only. Are you sure kdemod-core is meant to be used with testing?

Offline

#27 2009-07-09 22:51:55

djgera
Developer
From: Buenos Aires - Argentina
Registered: 2008-12-24
Posts: 694
Website

Re: LibJpeg and... errors with jpg images [ KDE 4.3 RC from kde-unstable]

szym wrote:

Speaking of libjpeg, testing/digikam (0.10.0-3) has unreasonable requirements:

$ ldd `which digikam` | grep libjpeg
        libjpeg.so.62 => not found
        libjpeg.so.7 => /usr/lib/libjpeg.so.7 (0x00007f57013a8000)

Any ideas how to make it happy?

Also, some stuff in kdemod-core still needs libjpeg.so.62 to run (most notably gwenview, konqueror and desktop wallpaper). Sigh.

Run with  LD_DEBUG=files digikam and you can see what is the DSO that tries to load the old libjpeg wink

Offline

#28 2009-07-10 00:45:15

szym
Member
Registered: 2007-11-16
Posts: 14

Re: LibJpeg and... errors with jpg images [ KDE 4.3 RC from kde-unstable]

Thanks, so it was kdemod-core/kdemod-kdelibs 4.2.4-1 that wanted libjpeg.so.62.

I guess I can't have [testing] and [kdemod-core]. Incidentally kdemod-testing/kdemod-kdegraphics-gwenview still wanted libjpeg.so.62 and I had a bunch of other issues with it. Sigh, I guess I'll need to wait it out or bite the bullet and go to kdemod-testing.

Offline

#29 2009-07-10 08:40:04

flamelab
Member
From: Athens, Hellas (Greece)
Registered: 2007-12-26
Posts: 2,160

Re: LibJpeg and... errors with jpg images [ KDE 4.3 RC from kde-unstable]

Hmm, the KDE devs still haven't fixed that jpeg issue with Konqueror. Can we (somehow) forward it more ?

Offline

#30 2009-07-11 04:00:48

QuimaxW
Member
From: Waukesha, WI
Registered: 2006-12-03
Posts: 218

Re: LibJpeg and... errors with jpg images [ KDE 4.3 RC from kde-unstable]

This isn't the most glamourous approach....however, just soft linking libjpeg.so.62 to libjpeg.so.7 solved my issue starting kmymoney

 sudo ln -s /usr/lib/libjpeg.so.7 /usr/lib/libjpeg.so.62

Granted, I'm not running KDE (XFCE actually), just a KDE 3 application. Gwenview (KDE4) worked fine before linking the libjpeg libary.

Offline

#31 2009-07-11 13:46:32

flamelab
Member
From: Athens, Hellas (Greece)
Registered: 2007-12-26
Posts: 2,160

Re: LibJpeg and... errors with jpg images [ KDE 4.3 RC from kde-unstable]

That's a very "dirty" workaround, it shouldn't be used, but only in very extreme cases (for example: when even if a rebuild or with patch, the program won't work).

Offline

#32 2009-07-14 16:12:53

flamelab
Member
From: Athens, Hellas (Greece)
Registered: 2007-12-26
Posts: 2,160

Re: LibJpeg and... errors with jpg images [ KDE 4.3 RC from kde-unstable]

Hey, libjpeg 7 in extra ? What about the KDE users ? Has the Konqueror issue been solved ? I haven't checked what happens with Konqueror 4.2.4 yet.

Offline

#33 2009-07-14 16:16:08

Pierre
Developer
From: Bonn
Registered: 2004-07-05
Posts: 1,950
Website

Re: LibJpeg and... errors with jpg images [ KDE 4.3 RC from kde-unstable]

The konqueror issue was defined as not being a blocker (also by upstream). And there was no response by any KDE dev. Only very few sites are affected and look strange in worst case; also 99% don't use Konqueror anyway.

Offline

#34 2009-07-14 16:27:15

Skripka
Member
From: 2X1280X1024
Registered: 2009-02-19
Posts: 554

Re: LibJpeg and... errors with jpg images [ KDE 4.3 RC from kde-unstable]

Pierre wrote:

also 99% don't use Konqueror anyway.

They ought to understand that there are several (good) reasons for that.  roll

Offline

#35 2009-07-14 16:35:49

flamelab
Member
From: Athens, Hellas (Greece)
Registered: 2007-12-26
Posts: 2,160

Re: LibJpeg and... errors with jpg images [ KDE 4.3 RC from kde-unstable]

Well, that's bad news, since they all have to wait for months to that to be solved until 4.3.1 arrives. And Konqueror seems unusable like that, I have found many sites with jpeg images that went large.

Offline

#36 2009-07-14 16:41:37

Skripka
Member
From: 2X1280X1024
Registered: 2009-02-19
Posts: 554

Re: LibJpeg and... errors with jpg images [ KDE 4.3 RC from kde-unstable]

flamelab wrote:

Well, that's bad news, since they all have to wait for months to that to be solved until 4.3.1 arrives. And Konqueror seems unusable like that, I have found many sites with jpeg images that went large.

In all honesty-Konqueror is pretty much unusable anyway due to the severe issue with kio_http processes that multiply like bunny rabbits and don't go away, which last I had heard wasn't solved in 4.3RC2 either.

Offline

#37 2009-07-14 20:30:16

warlord
Member
Registered: 2007-07-04
Posts: 58

Re: LibJpeg and... errors with jpg images [ KDE 4.3 RC from kde-unstable]

Pierre wrote:

also 99% don't use Konqueror anyway.

To be honest, I was expecting a much more serious answer than this...

Offline

#38 2009-07-14 20:34:26

Pierre
Developer
From: Bonn
Registered: 2004-07-05
Posts: 1,950
Website

Re: LibJpeg and... errors with jpg images [ KDE 4.3 RC from kde-unstable]

This was a serious answer. We have to decide to if we need to block the whole repo because of a minor bug in a browser that has only a very low usage. Sure, its not nice to have this bug in extra, but we have to live with it until its fixed by KDE.

Offline

#39 2009-07-14 20:39:38

Skripka
Member
From: 2X1280X1024
Registered: 2009-02-19
Posts: 554

Re: LibJpeg and... errors with jpg images [ KDE 4.3 RC from kde-unstable]

Pierre wrote:

This was a serious answer. We have to decide to if we need to block the whole repo because of a minor bug in a browser that has only a very low usage. Sure, its not nice to have this bug in extra, but we have to live with it until its fixed by KDE.

Pierre,

It isn't just Konqueror or KDE apps that are having issues with libjpeg-7, folks are reporting problems with Thunar as well as other software just down the hall in Pacman/Packaging

Last edited by Skripka (2009-07-14 20:40:33)

Offline

#40 2009-07-14 20:59:44

Pierre
Developer
From: Bonn
Registered: 2004-07-05
Posts: 1,950
Website

Re: LibJpeg and... errors with jpg images [ KDE 4.3 RC from kde-unstable]

OK, there seems to be some strange moving error in thunar. Which pacakge fro mextra is broken, too? And its no surpise that there are problems with such big updates.

Offline

#41 2009-07-14 21:07:51

flamelab
Member
From: Athens, Hellas (Greece)
Registered: 2007-12-26
Posts: 2,160

Re: LibJpeg and... errors with jpg images [ KDE 4.3 RC from kde-unstable]

Pierre wrote:

OK, there seems to be some strange moving error in thunar. Which pacakge fro mextra is broken, too? And its no surpise that there are problems with such big updates.

JGC says that GTK is affected by the libjpeg update, too:

JGC wrote:

This affects more apps: eog, evolution. Looks like gtk is having problems with the new jpeg. This also affects the development version of gtk.

Offline

#42 2009-07-14 21:16:03

warlord
Member
Registered: 2007-07-04
Posts: 58

Re: LibJpeg and... errors with jpg images [ KDE 4.3 RC from kde-unstable]

Pierre wrote:

This was a serious answer. We have to decide to if we need to block the whole repo because of a minor bug in a browser that has only a very low usage. Sure, its not nice to have this bug in extra, but we have to live with it until its fixed by KDE.

For your information, the problem isn't with konqueror (so it isn't "a minor bug in a browser that has only a very low usage") but in KHTML.
So it affects every application that uses this kpart (due to KDE integration).
This includes akregator, ktorrent, amarok, kmail and almost every KDE app that opens a link.
I don't know about the usage of akregator and kmail, but I am sure that you cant say "also 99% don't use amarok anyway" wink

Skripka wrote:

It isn't just Konqueror or KDE apps that are having issues with libjpeg-7, folks are reporting problems with Thunar as well as other software just down the hall in Pacman/Packaging

Maybe 99% don't use thunar.  wink

Pierre wrote:

And its no surpise that there are problems with such big updates.

It is not surprise. But this is why we have a testing repo. To make the big updates as smooth as possible.
In this case we don't have problem with just an application, we have a whole desktop environment with "broken" network support.

Offline

#43 2009-07-14 21:45:03

Pierre
Developer
From: Bonn
Registered: 2004-07-05
Posts: 1,950
Website

Re: LibJpeg and... errors with jpg images [ KDE 4.3 RC from kde-unstable]

Maybe one shouldn't take my posts too serious but the message is still right. libjpeg-7 was in testing for a long time; so if three were that much bugs why didn't you report them? At the time of moving we only knew about the konqueror problem and openjdk.

Offline

#44 2009-07-14 22:02:03

flamelab
Member
From: Athens, Hellas (Greece)
Registered: 2007-12-26
Posts: 2,160

Re: LibJpeg and... errors with jpg images [ KDE 4.3 RC from kde-unstable]

In order to test a package in [testing], you have to upgrade to [testing]. Most of us don't have the time or can't sacrifice the stability of the system in order to check what's going on in [testing].

For example, I accidentally found out this problem, which seems that it is more deep than I expected, because I enabled [testing] in order to check what's happening in KDE 4.3 RC.

If I hadn't the time to check what's going on, I would expect KDE 4.3 stable, and, with this libjpeg issue, I wouldn't find a stable DE any more, but a broken one, since it's browser doesn't display jpeg images properly any more, or the kpart'ed apps that depend on the html engine (for example, Ktorrent which has browsing capabilities).

All the time I have been using Arch, I rarely faced problems that were caused by apps or libs installed from the official repos (when I faced a serious one, Xorg related and I made a bug report. It was an upstream issue.).

But now, all, all, KDE users, not only old ones, but even new ones (that install Arch for the first time), will face a *broken* DE, not the way it should be. Now, I have one choice less, since Konqueror (and the khtml dependant apps) is unusable.

Except for that, I have some questions, and I would like to have a proper answer: did we really need this libjpeg 7 upgrade ? Did libjpeg 6.x have any serious, unbearable problems that were solved in libjpeg 7 ? Why were we supposed to be (the first ones ?) to upgrade to libjpeg 7 ? Because if we hadn't upgraded to libjpeg 7 and waited for other distros first (Fedora Rawhide for example), we would have the appropriate patches or workarounds for all the possible problems caused by this upgrade.

I don't want to be mean. I really like this distro, but I'm suddenly very disappointed because libjpeg should have been in testing mode FAR more in the [testing] repo.

Last edited by flamelab (2009-07-14 22:05:06)

Offline

#45 2009-07-14 22:16:47

warlord
Member
Registered: 2007-07-04
Posts: 58

Re: LibJpeg and... errors with jpg images [ KDE 4.3 RC from kde-unstable]

I don't use testing and I didn't know about those bugs.

And if you don't use konqueror you don't have to find the KHTML bug.
But as a developer you should know that konqueror is (lets say) a frontend for KHTML.
It uses the khtml kpart. And because of KDEs nature, every application that has to open a web page will use the khtml kpart.
So, when you say  "only knew about the konqueror problem" you are wrong. It's a KDE problem and because KDE 4.4.0 has been tagged with this problem we will have to wait for (at least) two months.

I have nothing with you and sorry if my writing  seems mean.
I just cant understand why the hurry. Even if it was only a konqueror problem, was the update so essential, to leave this 1% you believe that uses konqueror, with a broken browser?

Offline

#46 2009-07-14 23:03:09

mechmg93
Member
From: Greece
Registered: 2007-05-23
Posts: 196

Re: LibJpeg and... errors with jpg images [ KDE 4.3 RC from kde-unstable]

Skripka wrote:

Pierre,

It isn't just Konqueror or KDE apps that are having issues with libjpeg-7.....

i have serious problems with amsn. All the images of my contacts have become really really huge and every time i talk to someone i have to resize his avatar. it seems that new libjpeg is a pain in the **s..

Last edited by mechmg93 (2009-07-14 23:04:06)


Mikes on AUR

Offline

#47 2009-07-14 23:13:57

Pierre
Developer
From: Bonn
Registered: 2004-07-05
Posts: 1,950
Website

Re: LibJpeg and... errors with jpg images [ KDE 4.3 RC from kde-unstable]

I don't remember the exact reasons for the libjpeg update; you have to ask Allan about that. But belive us: we wouldn't break a lot of packages while knowing about it.

So, about my descision to mark the konqueror issue as a non-blocker:
* I use KDE everyday and did not notice any big problems. So you cannot declare the whole DE as being broken
* Nobody complained about it while it was in testing
* I know that KHTML is used by other apps than konqueror. (some, e.g. use webkit though)
* Only jpegs with missing width and height attributes are affected
* Everythign is still usable; the affected images are just bigger
* the bug was detected after the rebuild was done and packages were waiting to be moved
* Until now we have no feedback about when or if at all this problem will be fixed by KDE
* We had to decide if we move the packages now with some minor issues or stall the whole distro for an unkown amount of time

I know its sad but khtml/konqueror has lots of other problems which might make it unsable for most users. But that was not the point here.

In the end I don't see why KDE should be broken as a whole and I have no idea what the future tagging of KDE 4.4 is about. However: Once there is a fix I'll be happy to include it into kdelibs. So, vote for the bug report, check the khtml code yourself or ask KDE devs for help. I fear there was no way back and I still don't see a really big issue here.

Offline

#48 2009-07-14 23:44:46

warlord
Member
Registered: 2007-07-04
Posts: 58

Re: LibJpeg and... errors with jpg images [ KDE 4.3 RC from kde-unstable]

Pierre wrote:

So, about my descision to mark the konqueror issue as a non-blocker:
* I use KDE everyday and did not notice any big problems. So you cannot declare the whole DE as being broken

If you use KDE but you use for example firefox, pidgin, thunderbird and azureus, it is normal not to notice it.

Pierre wrote:

* I know that KHTML is used by other apps than konqueror. (some, e.g. use webkit though)

webkit can be set as the default for KDE apps but it has a lot of problems and has major issues with flash (al least at x86_64)

Pierre wrote:

* Only jpegs with missing width and height attributes are affected

Believe me, after the update I found that at least half of the sites I tried had problems.

Pierre wrote:

* Everythign is still usable; the affected images are just bigger

Everything is still usable.
If you call "usable" a link covered by an image so that you cant click it unless you block the image with ad block (only for konqueror, ad block isn't integrated in ktorrent yet.).

Pierre wrote:

* the bug was detected after the rebuild was done and packages were waiting to be moved

and why the hurry?

Pierre wrote:

* We had to decide if we move the packages now with some minor issues or stall the whole distro for an unkown amount of time

OK, this is what I cant undestand.
You had to choose. Move the packages or wait.
Moving the packages had some issues (minor for you, major for us).
Not moving the packages, had any issues??
The distro had to wait months for the new Xorg. Why the hurry with  libjpeg?
I mean, we all see the problems (major for some of us, minor for others). But I cant see the great advantage of this update, to ignore all the above problems.


Pierre wrote:

In the end I don't see why KDE should be broken as a whole
...
I still don't see a really big issue here.

OK, maybe we are just illogical.

Offline

#49 2009-07-14 23:47:17

warlord
Member
Registered: 2007-07-04
Posts: 58

Re: LibJpeg and... errors with jpg images [ KDE 4.3 RC from kde-unstable]

mechmg93 wrote:
Skripka wrote:

Pierre,

It isn't just Konqueror or KDE apps that are having issues with libjpeg-7.....

i have serious problems with amsn. All the images of my contacts have become really really huge and every time i talk to someone i have to resize his avatar. it seems that new libjpeg is a pain in the **s..

Confirmed.

Had to rebuild amsn to start, but now has large images.

Offline

#50 2009-07-15 00:24:50

Allan
Developer
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,361
Website

Re: LibJpeg and... errors with jpg images [ KDE 4.3 RC from kde-unstable]

Why were no issues apart from konqueror reported while the packages were still in [testing]?  Not much we can do if no-one makes bug reports.  Also, note a bug report was never made about konqueror...  we only know about because we happened on a thread in the forums, which is far from guaranteed.

And why push libjpeg to [extra]?  Well, we only knew about two issues, konqueror and openjpg6.  They will not affect all usage of those programs and both have simple work-arounds (use another browser or jre/jdk).  No-one reported any further issues.  If we chose to leave libjpeg in [testing], then we would have two choices.  No longer update packages in [extra], or build everything twice.  Jan was nice with the firefox update and rebuilt everything for both [extra] and [testing].  Probably not just to be nice, but because we know how much complaining there would be if firefox-3.5 sat in [testing].  So the choice comes down to either moving libjpeg to [extra] and having what were reported as relatively minor annoyances or leaving libjpeg in [testing] and having [extra] stagnate (because we are not going to double our workload).

Arch is rolling release.  We get exposed to upstream bugs first.  If no-one reports them (both to us and upstream), then there is absolutely nothing we can do.

Offline

Board footer

Powered by FluxBB