You are not logged in.

#1 2009-03-25 14:43:49

mika91
Member
Registered: 2007-10-25
Posts: 19

Intel 4500MHd config [summary]

Hi,

I installed archlinux on Lenovo x301, with a G45 intel chipset (4500MHD graphics).
I read all the posts about intel driver, 2.6.29 kernel, kms and xorg...but couldn't find an answer to all of my questions.
So I think it will be usefull to summarize all these topics, to help the newbies (me wink) with intel chipset (most of the laptops !!!)

So let's go:

1) Is it a good idea to install 2.6.29 kernel ? I read some posts about network issues !

2) KMS:
       a) default enabled in 2.6.29 (testing) kernel ?
       b) compatible with UXA ? (issues with java ?)
       c) Performance improvement in compositing ? (kwin4, compiz..)
       d) How to configure xorg.conf ?

3) UXA or EXA ?

4) MPlayer issues (direct rendering...) ?


And I propose to post your configuration and share your experiences (running well ? issues ? improvements ?...)

Configuration Model:

Kernel version : xxx
xf86-video-intel: xxx
dri: xxx
drm: xxx
mesa: xxx
xorg: xxx

+ post your xorg.conf


Thanks for your participation and help

Last edited by mika91 (2009-03-25 14:44:19)

Offline

#2 2009-03-25 15:35:38

fijam
Member
Registered: 2009-02-03
Posts: 244
Website

Re: Intel 4500MHd config [summary]

2 a)

$ fgrep KMS /usr/src/linux-2.6.29-ARCH/.config 
# CONFIG_DRM_I915_KMS is not set

edit: disregard the above, the kernel IS KMS-enabled
additional info here: http://bbs.archlinux.org/viewtopic.php?pid=522269
2 b) KMS requires GEM so if you want to take advantage of it you need to use UXA
...
2 d)

    Option        "AccelMethod" "UXA"

should be enough

Last edited by fijam (2009-03-25 21:17:19)

Offline

#3 2009-03-25 16:06:05

mika91
Member
Registered: 2007-10-25
Posts: 19

Re: Intel 4500MHd config [summary]

OK, so today we need to recompile 2.6.29 kernel to add KMS support.
Thanks

Offline

#4 2009-03-25 17:06:36

Gonzakpo
Member
Registered: 2008-05-17
Posts: 45

Re: Intel 4500MHd config [summary]

This thread helps me soo much. Does somebody know why KMS isn't enabled in the "linux-2.6.29-ARCH" kernel? It's supposed to be stable.

Thanks.

Offline

#5 2009-03-25 17:15:20

peart
Member
From: Kanuckistan
Registered: 2003-07-28
Posts: 510

Re: Intel 4500MHd config [summary]

Gonzakpo wrote:

This thread helps me soo much. Does somebody know why KMS isn't enabled in the "linux-2.6.29-ARCH" kernel? It's supposed to be stable.

Thanks.

Read here: http://www.archlinux.org/pipermail/arch … 10863.html
Apparently, you just need to edit your modprobe.conf

Offline

#6 2009-03-25 17:43:52

fijam
Member
Registered: 2009-02-03
Posts: 244
Website

Re: Intel 4500MHd config [summary]

peart wrote:

Read here: http://www.archlinux.org/pipermail/arch … 10863.html
Apparently, you just need to edit your modprobe.conf

This does not work for me.

Passing i915.modeset=1 to the kernel command line gives "unknown boot option, ignoring" and the resolution changes only when X is started  (so the mode-setting part is not being handled by the kernel) and all I get is a blank, black screen at which point the only thing I can do is to power down the laptop the hard way (I do not have magic sysrq enabled). Editing modprobe.conf results in exactly the same symptoms, save for the "unknown boot option" message.

Last edited by fijam (2009-03-25 18:02:47)

Offline

#7 2009-03-25 18:33:07

peart
Member
From: Kanuckistan
Registered: 2003-07-28
Posts: 510

Re: Intel 4500MHd config [summary]

@fijam: I have set KMS=y in my kernel, so I have no personal experience with i915.modeset nor the modprobe.conf settings.  I'm just relaying what JGC said smile

The documentation on the CONFIG_DRM_I915_KMS option leads me to believe that it does not enable/disable KMS altogether.  It seems to just decide whether it is *automatically* enabled at boot:

make menuconfig wrote:

CONFIG_DRM_I915_KMS:                                                                   │ 
  │                                                                                        │ 
  │ Choose this option if you want kernel modesetting enabled by default,                  │ 
  │ and you have a new enough userspace to support this. Running old                       │ 
  │ userspaces with this enabled will cause pain.  Note that this causes                   │ 
  │ the driver to bind to PCI devices, which precludes loading things                      │ 
  │ like intelfb.

Offline

#8 2009-03-25 18:49:56

fijam
Member
Registered: 2009-02-03
Posts: 244
Website

Re: Intel 4500MHd config [summary]

This fixed the issue for me: http://bbs.archlinux.org/viewtopic.php? … 31#p520931

Sorry for misleading you with the "CONFIG_DRM_I915_KMS is not set", the kernel is perfectly KMS-capable without it, no recompilation required.

Last edited by fijam (2009-03-25 21:14:55)

Offline

#9 2009-03-26 10:01:38

mika91
Member
Registered: 2007-10-25
Posts: 19

Re: Intel 4500MHd config [summary]

I'm installing all the testing packages, but when I startX it freezes !
It seems I'm missing HAL daemon.
But with HAL hotplugin, if I remove xorg.conf, how can I force xserver to use intel driver ?

Last edited by mika91 (2009-03-26 10:23:56)

Offline

#10 2009-03-26 13:02:55

mika91
Member
Registered: 2007-10-25
Posts: 19

Re: Intel 4500MHd config [summary]

I try to enable KMS with 2.6.29 kernel, but "i915.modeset=1" boot option freezes my laptop when I startX (even with MODULES=(intel_agp drm i915) added).
sad

Offline

#11 2009-03-27 08:02:29

funkyou
Member
From: Berlin, DE
Registered: 2006-03-19
Posts: 848
Website

Re: Intel 4500MHd config [summary]

mika91 wrote:

I propose to post your configuration and share your experiences (running well ? issues ? improvements ?...

I have a G43 X4500, which should be almost the same.

The first driver versions were not working very nice (i bought this one when the former X3100 just got halfway stable driver support), but with the Xorg stuff in testing nearly everything is working fine now... The only problem is some screen garbage here and there when using compositing in KDE4, but that can be solved with a MigrationHeuristic setting in xorg.conf, at least for me...

Performance is fine, a great improvement over the last drivers. Nearly the same speed as my 7600GT in another machine. Haven't tried KMS yet, i am waiting for stability etc smile

Here is my config:

Section "ServerLayout"
    Identifier     "X.org Configured"
    Screen      0  "Screen0" 0 0
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "ServerFlags"
        Option      "AutoAddDevices"         "false"
EndSection

Section "Files"
    ModulePath   "/usr/lib/xorg/modules"
    FontPath     "/usr/share/fonts/misc"
    FontPath     "/usr/share/fonts/100dpi:unscaled"
    FontPath     "/usr/share/fonts/75dpi:unscaled"
    FontPath     "/usr/share/fonts/TTF"
    FontPath     "/usr/share/fonts/Type1"
EndSection

Section "Module"
    Load  "glx"
    Load  "dbe"
    Load  "dri"
    Load  "record"
    Load  "dri2"
    Load  "extmod"
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "keyboard"
        Option      "XkbRules"   "xorg"
        Option      "XkbModel"   "pc105"
        Option      "XkbLayout"  "de"
        Option      "XkbVariant" "nodeadkeys"
EndSection

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "auto"
        Option      "Device" "/dev/input/mice"
        Option      "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
        DisplaySize  360 270
        Identifier   "Monitor0"
        VendorName   "ENC"
        ModelName    "F730"
        HorizSync    30.0 - 115.0
        VertRefresh  50.0 - 160.0
        Option      "DPMS"
        Modeline     "1400x1050_85.00"  179.26  1400 1504 1656 1912  1050 1051 1054 1103  -HSync +Vsync
        Option       "PreferredMode" "1400x1050_85.00"    
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "NoAccel"                # [<bool>]
        #Option     "SWcursor"               # [<bool>]
        #Option     "ColorKey"               # <i>
        #Option     "CacheLines"             # <i>
        #Option     "Dac6Bit"                # [<bool>]
        #Option     "DRI"                    # [<bool>]
        #Option     "NoDDC"                  # [<bool>]
        #Option     "ShowCache"              # [<bool>]
        #Option     "XvMCSurfaces"           # <i>
        #Option     "PageFlip"               # [<bool>]
        Identifier  "Card0"
        Driver      "intel"
        VendorName  "Intel Corporation"
        BoardName   "4 Series Chipset Integrated Graphics Controller"
        BusID       "PCI:0:2:0"
        #Option     "AccelMethod" "uxa"
        # below are experimental options, working for me
        Option      "AccelMethod" "exa"
        Option      "MigrationHeuristic" "greedy"
        Option      "ExaNoComposite" "false"
EndSection

Section "Screen"
    Identifier "Screen0"
    Device     "Card0"
    Monitor    "Monitor0"
    SubSection "Display"
        Viewport   0 0
        Depth     1
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     4
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     8
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     15
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     16
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

Section "DRI"
        Group       "video"
        Mode        0666
EndSection

Section "Extensions"
        Option      "Composite"     "Enable"
        Option      "RENDER"        "Enable"
EndSection

want a modular and tweaked KDE for arch? try kdemod

Offline

#12 2009-03-27 08:05:07

mika91
Member
Registered: 2007-10-25
Posts: 19

Re: Intel 4500MHd config [summary]

Ok, so here are my configuration:

Packages:
     
     - testing/kernel 2.6.29
     - testing/xorg-server 1.6
     - testing/xf86-video-intel 2.6.99
     - testing/xf86-input-evdev     
     - testing/mesa 7.3-2
     - testing/intel-dri 7.3-1
     - testing/libgl 7.3-1
     - testing/libdrm 2.4.5-2
     - extra/dri2proto

I use HAL, so add it in rc.conf DAEMONS and delete/move xorg.conf.
The last step is enabling KMS: http://bbs.archlinux.org/viewtopic.php? … 65#p522665

So it should be ok now.
HAL and KMS will use UXA acceleration and compositing will work (tested with kwin4).

About performance, I haven't done benchmarks yet...but for example, Kwin4 Cube is about 35 fps (4500MHD and 1440x900 screen).
I'm waiting for your comments and reports.

Offline

#13 2009-04-10 07:06:47

KlavKalashj
Member
Registered: 2008-10-09
Posts: 362

Re: Intel 4500MHd config [summary]

mika91 wrote:

Ok, so here are my configuration:

Packages:
     
     - testing/kernel 2.6.29
     - testing/xorg-server 1.6
     - testing/xf86-video-intel 2.6.99
     - testing/xf86-input-evdev     
     - testing/mesa 7.3-2
     - testing/intel-dri 7.3-1
     - testing/libgl 7.3-1
     - testing/libdrm 2.4.5-2
     - extra/dri2proto

I use HAL, so add it in rc.conf DAEMONS and delete/move xorg.conf.
The last step is enabling KMS: http://bbs.archlinux.org/viewtopic.php? … 65#p522665

So it should be ok now.
HAL and KMS will use UXA acceleration and compositing will work (tested with kwin4).

About performance, I haven't done benchmarks yet...but for example, Kwin4 Cube is about 35 fps (4500MHD and 1440x900 screen).
I'm waiting for your comments and reports.

Your setup is very interesting. I am thinking of buying a Dell tudio 15 (with the Intel x4500MHD) and I have done some googling about that card. Most review are out of date, with old drivers and so on. Can you confirm that system works with your setup? I mean, proper compositing, resolution, video, KMS? I would be really glad if you posted any progress here, as new updates arrive smile

Offline

#14 2009-04-10 10:08:26

Bogart
Member
From: Madrid, Spain
Registered: 2005-06-22
Posts: 263

Re: Intel 4500MHd config [summary]

KlavKalashj wrote:

Your setup is very interesting. I am thinking of buying a Dell tudio 15 (with the Intel x4500MHD) and I have done some googling about that card. Most review are out of date, with old drivers and so on. Can you confirm that system works with your setup? I mean, proper compositing, resolution, video, KMS? I would be really glad if you posted any progress here, as new updates arrive smile

I have a Dell Studio desktop with G45 chipset (and using the integrated X4500HD). For me everything worked out of the box since I bought it 2 months ago. I don't use compositing, but it does work pretty well when I test it (I simply don't like compositing). No problems with video or resolutions either.

On my main installation I use the packages from core/extra, but I have another partition with testing enabled and there everything works good too with KMS, GEM, UXA, etc...

To be true, I'm very pleased with the Linux support for this desktop. Not just graphics, but everything else works out of the box (card reader, microphone, sound, suspend to RAM, hibernation,...). So I'm ok with recommending a Dell (though you want a Studio laptop, not a desktop, and laptops are always a bit more dodgy when it comes to Linux support - but then I don't think Dell uses very different components for both lines of their Studio computers).

Offline

#15 2009-04-11 09:03:24

davvil
Member
Registered: 2008-05-06
Posts: 165

Re: Intel 4500MHd config [summary]

mika91 wrote:

Ok, so here are my configuration:

Packages:
     
     - testing/kernel 2.6.29
     - testing/xorg-server 1.6
     - testing/xf86-video-intel 2.6.99
     - testing/xf86-input-evdev     
     - testing/mesa 7.3-2
     - testing/intel-dri 7.3-1
     - testing/libgl 7.3-1
     - testing/libdrm 2.4.5-2
     - extra/dri2proto

I use HAL, so add it in rc.conf DAEMONS and delete/move xorg.conf.
The last step is enabling KMS: http://bbs.archlinux.org/viewtopic.php? … 65#p522665

So it should be ok now.
HAL and KMS will use UXA acceleration and compositing will work (tested with kwin4).

About performance, I haven't done benchmarks yet...but for example, Kwin4 Cube is about 35 fps (4500MHD and 1440x900 screen).
I'm waiting for your comments and reports.

Yesterday I just tried this combination (some packages already with a newer version), and it all works. I cannot give any real numbers either, but KDE4 effects feel much smoother now. The only flaw I see is that Alt+Ctrl+Backspace doesn't work any more for killing X. Any ideas?

Offline

#16 2009-04-11 10:41:49

Nepherte
Member
From: Belgium
Registered: 2008-09-09
Posts: 427
Website

Re: Intel 4500MHd config [summary]

Add

Option "DontZap" "false"

to xorg.conf under the ServerFlags section.

Offline

#17 2009-04-13 17:23:21

KlavKalashj
Member
Registered: 2008-10-09
Posts: 362

Re: Intel 4500MHd config [summary]

Bogart wrote:
KlavKalashj wrote:

Your setup is very interesting. I am thinking of buying a Dell tudio 15 (with the Intel x4500MHD) and I have done some googling about that card. Most review are out of date, with old drivers and so on. Can you confirm that system works with your setup? I mean, proper compositing, resolution, video, KMS? I would be really glad if you posted any progress here, as new updates arrive smile

I have a Dell Studio desktop with G45 chipset (and using the integrated X4500HD). For me everything worked out of the box since I bought it 2 months ago. I don't use compositing, but it does work pretty well when I test it (I simply don't like compositing). No problems with video or resolutions either.

On my main installation I use the packages from core/extra, but I have another partition with testing enabled and there everything works good too with KMS, GEM, UXA, etc...

To be true, I'm very pleased with the Linux support for this desktop. Not just graphics, but everything else works out of the box (card reader, microphone, sound, suspend to RAM, hibernation,...). So I'm ok with recommending a Dell (though you want a Studio laptop, not a desktop, and laptops are always a bit more dodgy when it comes to Linux support - but then I don't think Dell uses very different components for both lines of their Studio computers).

Thank you for that answer, it really made me feel better about this laptop. If I buy it at the end of the month, I will come back and report the results for future references smile

Offline

#18 2009-04-17 12:07:27

mika91
Member
Registered: 2007-10-25
Posts: 19

Re: Intel 4500MHd config [summary]

Sorry for the late answers.

Yes, my configuration works, but I didn't test mplayer yet

Offline

#19 2009-07-16 16:06:25

mika91
Member
Registered: 2007-10-25
Posts: 19

Re: Intel 4500MHd config [summary]

Today, I tried the combination:

kernel 2.6.30-5
xf86-video-intel 2.7.99.901-1
xorg-server 1.6.1.901-3
intel-dri 7.4.4-1
kms

It still works, but fps is not improved -> glxgears: 386 fps

I saw some posts with results 1000fps or 1300fps !!!
What is your "score" and configuration ?

Offline

#20 2009-07-16 19:39:29

Square
Member
Registered: 2008-06-11
Posts: 429

Re: Intel 4500MHd config [summary]

mika91: I have around 1300 fps before updating to 2.7.99.901. After upgrading, it fell to around 800 FPS in glxgears, so I took the chance to enable KMS. glxgears performance went down once more, to around 400, but everything is still working well.
I also noticed that UrbanTerror fell down to about 20-30 FPS with this setup (previously 50+), but it's still playable and doesn't fall below that.

Other than the nitpicking, the card works very well and shouldn't be avoided. Intel has always been a bumpy ride, and since this is the newest a little more bumpy ride than usual should  be expected.


 

Offline

#21 2009-07-16 21:06:05

mika91
Member
Registered: 2007-10-25
Posts: 19

Re: Intel 4500MHd config [summary]

Thanks Square.
I will try tomorrow with stable xf86-video-intel

A strange thing I noticed is that the results are the same wit and without kms ! (around 400 fps)
I don't use any xorg.conf, and accel is UXA in both case.
I will investigate to see if kms is not activated in both settings (but my console is like "old way", with the poor resolution) and reachs at least your 800 fps !

Thanks for the help and comments

Offline

#22 2009-07-16 22:20:49

Square
Member
Registered: 2008-06-11
Posts: 429

Re: Intel 4500MHd config [summary]

mika91 wrote:

Thanks Square.
I will try tomorrow with stable xf86-video-intel

A strange thing I noticed is that the results are the same wit and without kms ! (around 400 fps)
I don't use any xorg.conf, and accel is UXA in both case.
I will investigate to see if kms is not activated in both settings (but my console is like "old way", with the poor resolution) and reachs at least your 800 fps !

Thanks for the help and comments

It depends quite a bit on your processor. I've got a Pentium Dual-Core T4200, and I've noticed that when I set the frequency to 1.2 Ghz (on both cores) my FPS is significantly lower in glxgears than when I've got it set to 2.0Ghz (on both cores).
The 800FPS reading was with 2.0Ghz clocked on both cores.

Good luck! Hopefully the next update improves performance once again. I'm loving KMS now that I've enabled it, however. The console switching is incredible, and the added benefit of a native resolution console is helpful as well.


 

Offline

Board footer

Powered by FluxBB