You are not logged in.

#1 2009-07-23 08:00:01

HashBox
Member
Registered: 2009-01-22
Posts: 271

Vim broken?

I've just noticed that today after an update that contained the vi package, possibly other related ones, that gvim gives me an error message upon start, saying:

Error detected while processing /usr/share/vim/vim72/menu.vim:
line  155:
E121: Undefined variable: paste#paste_cmd
E15: Invalid expression: 'vnoremenu <script> &Edit.&Paste<Tab>"+gP^I' . paste#paste_cmd['v']

Help! After some bug hunting on google it seems like the recommended fix is to basically remove and reinstall vim, but this hasn't helped.

Right now gvim starts but because of this error I'm missing syntax highlighting and probably many other features.

Offline

#2 2009-07-23 09:38:30

sand_man
Member
From: Australia
Registered: 2008-06-10
Posts: 2,164

Re: Vim broken?

I don't have that problem. I don't even have a vim72 directory in the /usr/share/vim/
Are you on i686?
Is there are .pacsave/.pacnew for that menu.vim file?


neutral

Offline

#3 2009-07-23 12:33:26

mutlu_inek
Member
From: all over the place
Registered: 2006-11-18
Posts: 676
Website

Re: Vim broken?

Some of the vim plugins are broken with the new vim in [testing]. Have a look at the dev mailing list.

Offline

#4 2009-07-23 19:57:01

HashBox
Member
Registered: 2009-01-22
Posts: 271

Re: Vim broken?

Thanks for the replies.

@sand_man, yup I'm on i686, and no .pacsave/.pacnew files anywhere in there

@mutlu_inek, thanks, I checked out the list, and will sit back and wait till it is fixed smile

Offline

#5 2009-07-23 20:04:05

brisbin33
Member
From: boston, ma
Registered: 2008-07-24
Posts: 1,796
Website

Re: Vim broken?

you probably saw this on the ML, but for the time being, i fixed the issue with this:

sudo ln -s /usr/share/vim/vim72/ /usr/share/vim/vimcurrent

Offline

#6 2009-07-23 20:50:33

Square
Member
Registered: 2008-06-11
Posts: 429

Re: Vim broken?

brisbin33 wrote:

you probably saw this on the ML, but for the time being, i fixed the issue with this:

sudo ln -s /usr/share/vim/vim72/ /usr/share/vim/vimcurrent

That works for now, but according to the buglist it seems they're removing the vimcurrent link for good.
Best bet is to add this to the top of your vimrc until they apply the fix to update the default runtimepath:

set runtimepath=~/.vim,/usr/share/vim,/usr/share/vim/vim72
syntax on

Last edited by Square (2009-07-23 20:50:58)


 

Offline

#7 2009-07-23 22:40:41

sand_man
Member
From: Australia
Registered: 2008-06-10
Posts: 2,164

Re: Vim broken?

I actually didn't realise this was the [testing] forum. I'm not running testing so my apologies.


neutral

Offline

#8 2009-07-25 20:47:26

djszapi
Member
From: Cambridge, United Kingdom
Registered: 2009-06-14
Posts: 1,439
Website

Re: Vim broken?

vimcurrent solution isn't a good one, and vim72 directory using isn't neccsary too, i think so. I've just built my vim-script packages with VIMRUNTIME using in /usr/share/vim only, it must work everywhere wink

Offline

#9 2009-07-25 22:40:17

HashBox
Member
Registered: 2009-01-22
Posts: 271

Re: Vim broken?

Thanks guys, that will help until it is sorted out smile

Offline

#10 2009-07-30 20:04:05

djszapi
Member
From: Cambridge, United Kingdom
Registered: 2009-06-14
Posts: 1,439
Website

Re: Vim broken?

No problem, feel free to ask us anyway:)

Offline

Board footer

Powered by FluxBB