You are not logged in.

#1 2005-01-01 16:44:20

ralvy
Member
From: Santa Monica, California
Registered: 2004-12-06
Posts: 275

No printing: SOLVED

Installed Arch 0.6 and upgraded successfully to 0.7. No problems so far, except for getting printing to work. I followed the instructions found in the Arch Wiki for setting up cups. Here's the present state of my system, relevant to printing:

# lsmod
parport_pc             29124  1
lp                     12296  0
parport                38600  2 parport_pc,lp

ls -l /usr/sbin/cupdsd
-rwxr-xr-x  1 root root 254976 2004-11-03 13:14 /usr/sbin/cupsd

And cupsd is running.

When I attempt to print, I'm told everything was sent to the printer okay, but no printing occurs. Here's some command line output:

# lp .bashrc
request id is Lexmark-16 (1 file(s))

When I boot to my Gentoo installation, printing works fine, so I know it's not a hardware problem. I obviously have missed something in the setup.

Offline

#2 2005-01-01 17:41:40

iBertus
Member
From: Greenville, NC
Registered: 2004-11-04
Posts: 2,228

Re: No printing: SOLVED

Which printing packages do you have installed?

Offline

#3 2005-01-01 17:44:17

ralvy
Member
From: Santa Monica, California
Registered: 2004-12-06
Posts: 275

Re: No printing: SOLVED

iBertus wrote:

Which printing packages do you have installed?

cups and nothing else, as far as I know. What else is there?

Offline

#4 2005-01-01 18:15:59

iBertus
Member
From: Greenville, NC
Registered: 2004-11-04
Posts: 2,228

Re: No printing: SOLVED

I should have phrased that differently. You many need ghostscript and foomatic or foomatic-filters installed before printing will work. Some printers  require these before printing will work.

Offline

#5 2005-01-01 18:50:34

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: No printing: SOLVED

Can you print as root?
Perhaps you need to add yourself to some group?
THere is something small you need to do that is automagically done in other distros. You just have to find out what.


AKA uknowme

I am not your friend

Offline

#6 2005-01-01 19:21:35

iBertus
Member
From: Greenville, NC
Registered: 2004-11-04
Posts: 2,228

Re: No printing: SOLVED

If you're using udev you have to add the user to the lp group to access the printer device. As sarah32 has already said, this could be the source of your troubles.

Offline

#7 2005-01-01 20:49:05

ralvy
Member
From: Santa Monica, California
Registered: 2004-12-06
Posts: 275

Re: No printing: SOLVED

sarah31 wrote:

Can you print as root?
Perhaps you need to add yourself to some group?
THere is something small you need to do that is automagically done in other distros. You just have to find out what.

Nope. Can't print as root either. i also placed myself in the lp group, as I'm using udev.

Offline

#8 2005-01-01 21:04:12

iBertus
Member
From: Greenville, NC
Registered: 2004-11-04
Posts: 2,228

Re: No printing: SOLVED

Have you tried looking your printer up over at linuxprinting.org? They have most everything covered when it comes to getting a printer working under linux.

Offline

#9 2005-01-01 21:43:24

ralvy
Member
From: Santa Monica, California
Registered: 2004-12-06
Posts: 275

Re: No printing: SOLVED

Here's what solved this for me. I browsed http://linuxprinting.org/cups-doc.html and noticed the following:

Download foomatic-rip and foomatic-gswrapper

Well, Arch only seems to supply foomatic-gswrapper, not foomatic-rip. When I attempted to install the Arch foomatic-filters package, it complained, saying foomatic-gswrapper is already contained in filesystem, with no mention at all of foomatic-rip. The foomatic package also failed to install foomatic-rip.

So I downloaded foomatic-rip from the above web site, copied it to /usr/bin, where foomatic-gswrapper lives. Then I followed the next set of instructions in the above mentioned document:

chmod 755 foomatic-rip foomatic-gswrapper
ln -s /usr/bin/foomatic-rip /usr/lib/cups/filter/foomatic-rip

Now I can print.

Offline

#10 2005-01-01 22:13:34

iBertus
Member
From: Greenville, NC
Registered: 2004-11-04
Posts: 2,228

Re: No printing: SOLVED

Maybe you should file a report with the foomatic package maintainer.

Offline

#11 2005-01-01 22:25:39

ralvy
Member
From: Santa Monica, California
Registered: 2004-12-06
Posts: 275

Re: No printing: SOLVED

iBertus wrote:

Maybe you should file a report with the foomatic package maintainer.

Done.

Later ... a few hours after notifying the packager of this problem, new packages are already in the repository that fix the problem. Impressive distro support.

Offline

#12 2015-08-15 15:14:00

stephen221
Member
Registered: 2015-08-15
Posts: 3

Re: No printing: SOLVED

I had the same problem with my printer but I managed to fix it thanks to your thread.

Offline

#13 2015-08-15 15:19:26

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 14,024
Website

Re: No printing: SOLVED

Please do not "necrobump" old threads - especially with an empty post.  This is over 10 years old! that may be a record.

Closed.


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

Board footer

Powered by FluxBB