You are not logged in.

#1 2009-07-31 02:50:03

Marnop
Member
From: Eden, Vermont
Registered: 2009-07-24
Posts: 11

[SOLVED]pacman -Syu sychronize failure

Following the Installation instructions I installed a cd iso on the 26th.
There are 3 other linux distros on the 80 G drive and arch booted up and everything seemed to be OK.
I uncommented 5 repo sites in the mirrorlist and tried to update pacman -Syu.
All I get is ( Transient resolver error )   failed to synchronize any databases.
15 messages in all, for all 3 types. I tried ftp and http as well.

More searching with only one thread marked SOLVED.
I rebooted again but still the same errors.
Where do I go from here?
Start all over with a new cd?

Last edited by Marnop (2009-08-01 18:31:09)

Offline

#2 2009-07-31 03:19:00

Allan
Pacman
From: Brisbane, AU
Registered: 2007-06-09
Posts: 11,435
Website

Re: [SOLVED]pacman -Syu sychronize failure

Looks like you network is not configured.  Have a look in the wiki as the is really good information on setting that up there.

Online

#3 2009-07-31 18:26:30

djszapi
Member
From: Cambridge, United Kingdom
Registered: 2009-06-14
Posts: 1,439
Website

Re: [SOLVED]pacman -Syu sychronize failure

Welcome to the forum Marnop!

Allan has right! ArchWiki will your best friend in the early days.

Btw, without deleting that mirrors, can it work? We must realize whether it's a network connection or mirror related issue.

Offline

#4 2009-07-31 21:28:48

Marnop
Member
From: Eden, Vermont
Registered: 2009-07-24
Posts: 11

Re: [SOLVED]pacman -Syu sychronize failure

I went to the Beginners Guide and could not find a solution.
I have a wired DSL modem connection which is online always.
I downloaded the iso image and burned my own cd.
I went to a repo site and installed what seems to be a good install.
Here is one of my uncommented sites in /etc/pacman.d/mirriorlist.
Server = http://mirrors.easynews.com/linux/archl … po/os/i686
Am I accessing the right server?
Shoul I check any other conf files?

Offline

#5 2009-07-31 23:10:05

arkham
Member
From: Stockholm
Registered: 2008-10-26
Posts: 516
Website

Re: [SOLVED]pacman -Syu sychronize failure

What the other people meant is if your network is already properly configured. You could help us by posting the contents of /etc/rc.conf and the output of the commands "ifconfig", "route" and "ping -c 5 www.google.com"


"I'm Winston Wolfe. I solve problems."

~ Need moar games? [arch-games] ~ [aurcheck] AUR haz updates? ~

Offline

#6 2009-08-01 01:50:19

Marnop
Member
From: Eden, Vermont
Registered: 2009-07-24
Posts: 11

Re: [SOLVED]pacman -Syu sychronize failure

Thanks for the help. I don't understand networking.
I have been using ubuntu which does most everything for you and opensuse with Yast.

ifconfig output:
eth0      Link encap:Ethernet  HWaddr 00:1C:C0:93:05:AF 
          inet addr:0.0.0.55  Bcast:255.255.255.255  Mask:0.0.0.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:290 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:18153 (17.7 Kb)  TX bytes:0 (0.0 b)
          Memory:d2300000-d2320000

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
ping output:
none

route output:
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface

# /etc/rc.conf - Main Configuration for Arch Linux
#
# -----------------------------------------------------------------------
# LOCALIZATION
# -----------------------------------------------------------------------
#
# LOCALE: available languages can be listed with the 'locale -a' command
# HARDWARECLOCK: set to "UTC" or "localtime"
# USEDIRECTISA: use direct I/O requests instead of /dev/rtc for hwclock
# TIMEZONE: timezones are found in /usr/share/zoneinfo
# KEYMAP: keymaps are found in /usr/share/kbd/keymaps
# CONSOLEFONT: found in /usr/share/kbd/consolefonts (only needed for non-US)
# CONSOLEMAP: found in /usr/share/kbd/consoletrans
# USECOLOR: use ANSI color sequences in startup messages
#
LOCALE="en_US.utf8"
HARDWARECLOCK="local"
USEDIRECTISA="no"
TIMEZONE="America/Kentucky/Louisville"
KEYMAP="us"
CONSOLEFONT=
CONSOLEMAP=
USECOLOR="yes"
# -----------------------------------------------------------------------
# HARDWARE
# -----------------------------------------------------------------------
#
# MOD_AUTOLOAD: Allow autoloading of modules at boot and when needed
# MOD_BLACKLIST: Prevent udev from loading these modules
# MODULES: Modules to load at boot-up. Prefix with a ! to blacklist.
#
# NOTE: Use of 'MOD_BLACKLIST' is deprecated. Please use ! in the MODULES array.
#
MOD_AUTOLOAD="yes"
#MOD_BLACKLIST=() #deprecated
MODULES=()

# Scan for LVM volume groups at startup, required if you use LVM
USELVM="no"

# -----------------------------------------------------------------------
# NETWORKING
# -----------------------------------------------------------------------
#
# HOSTNAME: Hostname of machine. Should also be put in /etc/hosts
#
HOSTNAME="myhost"
# Use 'ifconfig -a' or 'ls /sys/class/net/' to see all available interfaces.
#
# Interfaces to start at boot-up (in this order)
# Declare each interface then list in INTERFACES
#   - prefix an entry in INTERFACES with a ! to disable it
#   - no hyphens in your interface names - Bash doesn't like it
#
# DHCP:     Set your interface to "dhcp" (eth0="dhcp")
# Wireless: See network profiles below
#
eth0="eth0   netmask   broadcast  55"
INTERFACES=(eth0)
# Routes to start at boot-up (in this order)
# Declare each route then list in ROUTES
#   - prefix an entry in ROUTES with a ! to disable it
#
gateway="default gw 192.168.0.1"
ROUTES=(!gateway)
# Enable these network profiles at boot-up.  These are only useful
# if you happen to need multiple network configurations (ie, laptop users)
#   - set to 'menu' to present a menu during boot-up (dialog package required)
#   - prefix an entry with a ! to disable it
#
# Network profiles are found in /etc/network.d
#
# This now requires the netcfg package
#
#NETWORKS=(main)

# -----------------------------------------------------------------------
# DAEMONS
# -----------------------------------------------------------------------
#
# Daemons to start at boot-up (in this order)
#   - prefix a daemon with a ! to disable it
#   - prefix a daemon with a @ to start it up in the background
#
DAEMONS=(syslog-ng network netfs crond)

Offline

#7 2009-08-01 01:52:57

Allan
Pacman
From: Brisbane, AU
Registered: 2007-06-09
Posts: 11,435
Website

Re: [SOLVED]pacman -Syu sychronize failure

You probably want to use dhcp for your network connection:
http://wiki.archlinux.org/index.php/Beg … NG_Section

Online

#8 2009-08-01 02:58:58

Marnop
Member
From: Eden, Vermont
Registered: 2009-07-24
Posts: 11

Re: [SOLVED]pacman -Syu sychronize failure

I set etho="dhcp" in /etc/rc.conf.
pacman -Sy now synchronizes the 3 databases.
Tomorrow I can continue installing.
Thank you, Allan

Offline

Board footer

Powered by FluxBB