You are not logged in.

#1 2005-01-09 01:45:52

From: RIT
Registered: 2005-01-09
Posts: 11

Alsa Intel pcm_write no sound problem.

I'm trying to get Alsa working on my laptop.
I'm running a fairly fresh install of Arch w/ the 2.6.10 kernel

anyway following the ArchWiki Alsa Setup i've tried running both alsaconf and doing it by hand and always am left with no sound. The card is an:
Intel Corp. 82801DB AC'97 Audio (rev 03)
ALSA driver intel8x0

alscaconf dectects it and finishes through no problem.
modprobing the drivers in question works w/o error as well.
also the system bell works just fine (i know this is a different thing but i figured i'd include it anyway)

aplay /opt/gnome/share/sounds/phone.wav
Playing WAVE '/opt/gnome/share/sounds/phone.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo
aplay: pcm_write:1118: write error: Input/output error

and there is no audio.
i've gone through alsamixer and unmuted everything, tried remuting different things all to no avail.

also gnome-alsamixer displays the card as 'Realtek ALC250 rev 2' for some reason.

at this point i'm very stumped. any help would be appreciated as audio is one of the few things standing between me and declaring this arch install on my laptop a success.[/code][/url]


#2 2005-01-13 08:17:24

From: France
Registered: 2003-08-03
Posts: 46

Re: Alsa Intel pcm_write no sound problem.


...same problem sad with the same module, kernel and tests, with no success.... don't know what happen... I've tested a knoppix and it works but that's not a 2.6.10 kernel. oh ! and i'm using ALSA too...


#3 2005-01-14 14:57:51

Registered: 2004-03-16
Posts: 18

Re: Alsa Intel pcm_write no sound problem.

Hey had they same problem, i have just done a 0.7 install....
Somehow I missed the point about adding...devfs=nomount in grub...
As explained in this document..

I followed the rest of the document, rebooted and it still didnt work !!!!!

I then pushed the dark green dot over the PCM value in k-mixer, the light became lightgreen, and the sound came  !!!!

havent used kde for a long time.. wink


Board footer

Powered by FluxBB