You are not logged in.

#1 2009-08-24 15:14:25

ixar
Member
Registered: 2009-06-04
Posts: 25

Poulsbo aka Intel GMA500 drivers PKGBUILD

Hi !

I have cooked a few PKGBUILDs for myself, and I thought others might enjoy it as well wink
They contain poulsbo driver used in some netbooks. They are accelerated for 2d and 3d, but rely on a proprietary driver.

Please find the PKGBUILD here: http://julienetienne.free.fr/Arch/abs/
And you could test by adding the [ixar] repository in your pacman.conf:
[ixar]
Server = http://julienetienne.free.fr/Arch/repository

Just do "pacman -Sy xorg-x11-drv-psb" to get the driver and its dependencies.
After that you need to "modprobe psb" and edit "/etc/X11/xorg.conf" to use the "psb" drivers.

It works for me. I hope It will work for you as well wink
Do not hesitate to enhance the PKGBUILD as I am sure they are badly/quickly written.
I would be glad to get patches from you.

FYI the PKGBUILD were adapted from AdamW work for fedora packages that can be found here: http://www.happyassassin.net/2009/08/17 … 0-support/

Enjoy !

Edit: missing Xorg driver added.

Last edited by ixar (2009-08-25 09:46:34)

Offline

#2 2009-08-24 15:41:36

skottish
Forum Fellow
From: Here
Registered: 2006-06-16
Posts: 7,931

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

Welcome to the forums ixar. This is very cool. A couple of the directories on the site posted above are empty (libdrm-psb for instance). I'd like to use local copies of the build files if possible.

--EDIT--

It looks like the kernel module was built for the 2.6.28 kernel and compiled for i586.

Offline

#3 2009-08-25 06:30:54

ixar
Member
Registered: 2009-06-04
Posts: 25

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

skottish wrote:

Welcome to the forums ixar. This is very cool. A couple of the directories on the site posted above are empty (libdrm-psb for instance). I'd like to use local copies of the build files if possible.

--EDIT--

It looks like the kernel module was built for the 2.6.28 kernel and compiled for i586.

Indeed there is an issue with the source tree, I will reupload it.

Regarding the kernel module, I compiled it for 2.6.30-ARCH. However I think kernel module installation may need to be performed in a different way I did... because I just compiled it as any other package. I guess it is wrong as it will only work with the kernel version I used.
If you have a proper example of a kernel module package, I would be interested in reading it to do it the way it should be.

Offline

#4 2009-08-25 06:49:20

ixar
Member
Registered: 2009-06-04
Posts: 25

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

I fixed the upload now you have all the source in the abs directory.
If you know git, I even let my git repository in http://julienetienne.free.fr/Arch/abs/.git/
Do not hesitate to contribute with pull requests on this thread.

Offline

#5 2009-08-25 07:43:42

seeking
Member
Registered: 2009-08-25
Posts: 22

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

I downloaded 5 files from your site, libdrm-psb-2.3.0, libva-0.30.4, psb-firmware-0.30, psb-kernel-module-4.41.1, xpsb-glx-0.18, and installed all of them. but when I type "modprobe psb", it says there's no module psb.

What happened? Or don't I need anything like xf86-video-psb.pkg? Or build all packages for myselt from the PKGBUILDs?

Offline

#6 2009-08-25 08:03:10

ixar
Member
Registered: 2009-06-04
Posts: 25

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

seeking wrote:

I downloaded 5 files from your site, libdrm-psb-2.3.0, libva-0.30.4, psb-firmware-0.30, psb-kernel-module-4.41.1, xpsb-glx-0.18, and installed all of them. but when I type "modprobe psb", it says there's no module psb.

What happened? Or don't I need anything like xf86-video-psb.pkg? Or build all packages for myselt from the PKGBUILDs?

Using the binary packages should work, I tested it myself.
The packages you installed look fine to me.
Note that the only package needed is xorg-x11-drv-psb (was: xpsb-glx) as all other packages will be installed as dependencies.

In fact the module is only compiled for the kernel 2.6.30-ARCH , so check with `uname -a` what kernel version you are using.
Currently 2.6.30-ARCH is the default kernel used by Arch, so most users should be fine with that, you may need to update yours.
However I plan to do something to build the kernel module on the fly if it is possible to avoid such version issues.

If you know how to build from source, you can try using the abs tree.

Edit: package to install changed due to missing Xorg driver issue in the initial repository. Post corrected for futur readers not to be mistaken.

Last edited by ixar (2009-08-25 09:52:02)

Offline

#7 2009-08-25 08:50:03

seeking
Member
Registered: 2009-08-25
Posts: 22

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

Oh, I just found a problem. It seems that the modules that the system can detect all lie in /lib/modules/2.6.30-ARCH/kernel. The packages of psb put psb.ko in /lib/modules/2.6.30-ARCH/extra. That may be the reason why it cannot be found in my system. I link "extra" in "kernel", but it still doesn't work.

Offline

#8 2009-08-25 09:14:58

ixar
Member
Registered: 2009-06-04
Posts: 25

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

ok indeed I noticed a mistake in the psb-kernel-module package, it does not add the modprobe setting for psb...
I am fixing it at the moment. It should be ready in a few minutes.

And indeed xorg-x11-drv-psb is missing...

Ok give me some time to fix it, sorry for the inconvenience.

Last edited by ixar (2009-08-25 09:21:06)

Offline

#9 2009-08-25 09:34:23

seeking
Member
Registered: 2009-08-25
Posts: 22

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

I found something more just now. Maybe it would help.
In /lib/modules/2.6.30-ARCH/extra, type "modinfo psb.ko" and "modinfo drm.ko", I know that the module psb and drm depend on another two modules. I loaded in the two modules, and insmod drm.ko and psb.ko. Suddenly, the characters in the console turn quite small and clear. I thought the driver worked well at that moment, so I type "X -configure" to get xorg.conf, and startx. But X still does not work. It says psb module cannot be found and there is no driver.
This is what happened in my system. But your packages really show me great hope.

Offline

#10 2009-08-25 09:45:26

ixar
Member
Registered: 2009-06-04
Posts: 25

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

Great wink In fact you just loaded the kernel module, that provides a native framebuffer console wink
So I uploaded the missing xorg driver here: http://julienetienne.free.fr/Arch/repos … pkg.tar.gz
The source tree has been updated as well.

Just `pacman -U http://julienetienne.free.fr/Arch/repository/xorg-x11-drv-psb-0.31.0-1-i686.pkg.tar.gz` and you should be ok with Xorg.
I think I need to clean up the PKGBUILD... anyway it should work.

I am waiting for your feedback.

Offline

#11 2009-08-25 15:34:25

skottish
Forum Fellow
From: Here
Registered: 2006-06-16
Posts: 7,931

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

Thanks for this. I'll keep trying until it works.

As far as the PKGBUILDs go, there are some missing dependencies (at least makedepends) for xorg-x11-drv-psb: xf86driproto and glproto. All of the unused lines in the PKGBUILDs can be removed. 

These are the errors that I'm getting trying to get this started:

startx:

Error inserting psb (/lib/modules/2.6.30-ARCH/updates/char/drm/psb.ko): Invalid module format

dmesg:

drm: version magic '2.6.28-11=generic SMP mod_unload modversion 586 ' should be '2.6.20-ARCH SMP preemp mod_unload 686 '

insmod drm.ko:

insmod: error inserting '/lib/modules/2.6.30-SRCH/extra/drm.ko': -1 Unknown symbol in module

I don't know much about kernel modules, but it feels like that I'm really close...

Offline

#12 2009-08-25 16:11:24

seeking
Member
Registered: 2009-08-25
Posts: 22

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

After installing all the six packages, "startx" works!

But still I have some problems.

1. Every time when I start the computer, if I want to startx, I have to go to /lib/module/.../extra/,  modprobe three dependent modules and insmod drm.ko and psb.ko. How can I do it automatically?
2. "startx" to twm is ok. But xfce4 does not work, so doesn't openbox.
3. (EE) in /var/log/Xorg.0.log
Current Operating System: Linux arch 2.6.30-ARCH #1 SMP PREEMPT Mon Aug 17 18:04:53 CEST 2009 i686
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(II) Loading extension MIT-SCREEN-SAVER
(EE) PSB(0): the stolenBase is:0x3f800000
(EE) PSB(0): screnIndex is:0;fbPhys is:0x3f800000; fbsize is:0x007bf000
(EE) PSB(0): First SDVO output reported failure to sync or input is not trainded!!!
(EE) PSB(0): has_fbdev is true
4. As libdrm-psb conflicts with libdrm, it is troublesome when installing some important software that depends on libdrm

After so long time waiting, it finally works!

Offline

#13 2009-08-25 16:23:10

skottish
Forum Fellow
From: Here
Registered: 2006-06-16
Posts: 7,931

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

4 brings up an interesting question: Arch's mesa and libgl depend on libdrm>=2.4.12. Are these alright?

Offline

#14 2009-08-25 16:39:59

guguscat
Member
Registered: 2009-08-25
Posts: 2

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

Hello there !

I'm also trying to get these things working... And I get the same error messages as skottish when I try to load the psb module...

When I installed the driver from the depo, I had to delete libdrm using -Rd argument... I guess it is what I had to do ?

Offline

#15 2009-08-25 16:45:19

skottish
Forum Fellow
From: Here
Registered: 2006-06-16
Posts: 7,931

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

guguscat wrote:

Hello there !

I'm also trying to get these things working... And I get the same error messages as skottish when I try to load the psb module...

When I installed the driver from the depo, I had to delete libdrm using -Rd argument... I guess it is what I had to do ?

Welcome to the forums guguscat.

Yeah, that's what you have to do if you don't want to delete the whole dependency chain for libdrm. As I brought up above, this may cause problems with mesa and libgl.

Offline

#16 2009-08-25 17:04:54

skottish
Forum Fellow
From: Here
Registered: 2006-06-16
Posts: 7,931

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

Bump: I screwed up. I can in fact start X now. I wasn't thinking and I 'insmod *.ko' instead of doing things the proper way. So, what's left is to get all of the modules autoloading, and to find out if libgl and mesa are going to be a problem.

--EDIT--

The 2D performance is far worse than uvesafb with:

mode_option=1366x768-32@60 mtrr=3 scroll=ywrap

Any ideas on how to get 2D performance acceptable?

Offline

#17 2009-08-25 17:44:56

guguscat
Member
Registered: 2009-08-25
Posts: 2

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

my bad... I forgot to load a module big_smile

So I now have a wonderfull framebuffer and a xorg (even if my touchpad is not working :s)

Edit :

I have my gnome installed and every things seem to work fine smile

I just need to make a script. Or how could I get this two modules working "normally" ?

Thank you very much for the work you did smile

Edit 2 :
It works fine during few minutes and it freezes ! Only the mouse can be moved sad

I wish I forgot something :s

I had the modules in the rc.conf and add two lines in the rc.multi to get the two modules loaded.

insmod /lib/modul....

Last edited by guguscat (2009-08-25 20:56:27)

Offline

#18 2009-08-25 21:17:43

ixar
Member
Registered: 2009-06-04
Posts: 25

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

Regarding the module load you only need to add the psb module to rc.conf autoload.
This will automatically take dependency modules required.

I agree there is an issue with the way libdrm-psb package is built.
I should separate it from the existing libdrm as version does not match to avoid any conflict.
I will work on that.

Regarding the performances on my Acer 751 it works far better than uvesafb in 2d and 3d.
I am however still trying to make mplayer-vaapi work to use accelerated decoding.

Do not hesitate to post enhancements for the PKGBUILDs, I would be glad to merge them for the benefits
of all of us wink

If you have any issues with these packages, just remove them and reinstall libdrm.
Thank you for your feedback !

Offline

#19 2009-08-25 22:38:43

skottish
Forum Fellow
From: Here
Registered: 2006-06-16
Posts: 7,931

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

Again, thanks for doing this. I think that it's great that you've done the work.

About the performance, I read in one of AdamW's threads that there may be a conflict if the machine has 2GB of RAM. Mine does. How much RAM does your Acer have?

Offline

#20 2009-08-26 06:48:32

ixar
Member
Registered: 2009-06-04
Posts: 25

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

skottish wrote:

Again, thanks for doing this. I think that it's great that you've done the work.

About the performance, I read in one of AdamW's threads that there may be a conflict if the machine has 2GB of RAM. Mine does. How much RAM does your Acer have?

Mine also has 2GB. In fact I thought the issue was related to the Sony vaio P.
I will try with mem=1G just to confirm I see no performance change.

For libdrm-psb, I will probably change the library name to libdrm-psb.so* to allow both libdrm and libdrm-psb to coexist.
I have no idea if that would be possible to port the poulsbo patches to the latest libdrm to avoid conflict. At least it does not look straightforward. I'll check that as well.

Offline

#21 2009-08-26 18:49:13

Hailstorm
Member
Registered: 2009-08-26
Posts: 11

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

Hey
Thank you for working on this project, it helps a lot of people.
I am also trying to get my vga to work the way it should but i can't load the psb module.
I've installed xorg-x11-drv-psb from your repository but when i try to load the module i get the following error message:

[root@arch extra]# insmod psb.ko
insmod: error inserting 'psb.ko': -1 Unknown symbol in module

Could anyone help me with this please?

Offline

#22 2009-08-26 20:34:24

Hailstorm
Member
Registered: 2009-08-26
Posts: 11

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

nevermind, i loaded all the dep modules manually and it is working now

Offline

#23 2009-08-27 02:10:11

seeking
Member
Registered: 2009-08-25
Posts: 22

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

I added psb into rc.conf, but it still cannot be loaded automatically. Why?

Offline

#24 2009-08-27 06:13:36

seeking
Member
Registered: 2009-08-25
Posts: 22

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

I can just start twm. Gnome, xfce, openbox all failed. The error information:
Gnome -
#: gnome-session
#: **(gnome-session:1594):WARNING**: Cannot open display
openbox -
#: openbox-session
cannot find hsetroot or esetroot
#xsetroot: unable to open display ' '

Who can help me?

Offline

#25 2009-08-27 07:31:42

ixar
Member
Registered: 2009-06-04
Posts: 25

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

Hailstorm wrote:

nevermind, i loaded all the dep modules manually and it is working now

Using modprobe should load the dependencies automatically.
At least it works on my netbook.

Please tell me if it doesn't on your side.

Offline

Board footer

Powered by FluxBB