You are not logged in.

#1 2005-01-18 05:37:25

lilsirecho
Veteran
Registered: 2003-10-24
Posts: 5,000

/Sbin/lilo -v error message(new kernel ..problem moot)

The message:

     Setup length exceeds 31 maximum

     Kernel setup will override boot loader.

Please advise as to what "setup length" is and I may get the problem solved.


Sign of the times: Navajo blanket..made in China
Hard work does not kill people but why risk it: Charlie Mccarthy
A man is not complete until he is married..then..he is finished.
When ALL is lost, what can be found? Even bytes get lonely for a little bit!     X-ray confirms Iam spineless!

Offline

#2 2005-01-18 05:59:34

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: /Sbin/lilo -v error message(new kernel ..problem moot)

that would be the menu choices... you have too many...

31 bytes seems odd... I seem to recall a 66 byte block for partition tables... can't recall what the boot record size is....

you can either drop some choices from the menu, or install it to a bootable partition instead of the MBR of the disk


or just use grub, he he he

Offline

#3 2005-01-18 06:03:37

lilsirecho
Veteran
Registered: 2003-10-24
Posts: 5,000

Re: /Sbin/lilo -v error message(new kernel ..problem moot)

Thanks for the info...will try again!


Sign of the times: Navajo blanket..made in China
Hard work does not kill people but why risk it: Charlie Mccarthy
A man is not complete until he is married..then..he is finished.
When ALL is lost, what can be found? Even bytes get lonely for a little bit!     X-ray confirms Iam spineless!

Offline

#4 2005-01-18 06:14:58

lilsirecho
Veteran
Registered: 2003-10-24
Posts: 5,000

Re: /Sbin/lilo -v error message(new kernel ..problem moot)

This is the extent of the lilo entries which aren't that many.  I assume there is an error in the typing somewhere or my boot file is messed up.

--------------------------------------------------------------------------------------#
# /etc/lilo.conf
#

boot=/dev/discs/disc0/disc append="devfs=nomount"
# This line often fixes L40 errors on bootup
# disk=/dev/discs/disc0/disc bios=0x80

default= Linux-2.6.10-2
timeout=50
lba32
prompt


image=/boot/vmlinuz26
        label=Linux-2.6.10-2
        root=/dev/discs/disc0/part3
        read-only


image=/boot/vmlinuz26a
        label=Custom
        root=/dev/discs/disc0/part3
        read-only

image=/boot/vmlinuz
        label=arch
        root=/dev/discs/disc0/part3
        read-only

#other=/dev/discs/disc0/part1
#        label=dos

# End of file

This fails the /sbin/lilo -v run.


Sign of the times: Navajo blanket..made in China
Hard work does not kill people but why risk it: Charlie Mccarthy
A man is not complete until he is married..then..he is finished.
When ALL is lost, what can be found? Even bytes get lonely for a little bit!     X-ray confirms Iam spineless!

Offline

Board footer

Powered by FluxBB