You are not logged in.

#1 2005-01-19 06:47:29

mandato10
Member
Registered: 2004-08-29
Posts: 5

can't see winxp folders with chinese/korean folder names

hi...i recently used iTunes to organize my music (located on a winxp ntfs partition)...which created some folders with names that contain asian characters.  However,  those folders CANNOT be seen from the console or Konqueror.  It's as if they were never created at all...all the folders with english names can be found, so i think there is something related to the asian characters that my linux system can't recognize...is there a solution for this? 

Thanks.

Offline

#2 2005-01-19 14:27:17

scarecrow
Member
From: Greece
Registered: 2004-11-18
Posts: 714

Re: can't see winxp folders with chinese/korean folder names

Can you post your /etc/profile here?
AFAIK you must use some UTF-8 variation in your locales to access sc or big-5 characters properly. No idea about other asian languages, but unicode should normally treat them OK as well.


Microshaft delenda est

Offline

#3 2005-01-20 06:30:59

mandato10
Member
Registered: 2004-08-29
Posts: 5

Re: can't see winxp folders with chinese/korean folder names

#
# /etc/profile
#

export PATH="/bin:/usr/bin:/sbin:/usr/sbin:/usr/X11R6/bin:/opt/bin"

export MANPATH="/usr/man:/usr/X11R6/man"
export LESSCHARSET="latin1"
export INPUTRC="/etc/inputrc"
export LESS="-R"

# Locale settings (find your locale with 'locale -a')
export LANG="en_US"
export LC_COLLATE="C"

export COLUMNS LINES

export PS1='[u@h W]$ '
export PS2='> '

umask 022

if [ "$TERM" = "xterm" -o "$TERM" = "xterm-color" -o "$TERM" = "rxvt" ]; then
  PROMPT_COMMAND='echo -ne "33]0;${USER}@${HOSTNAME%%.*}:${PWD/$HOME/~}07"'
fi

# load profiles from /etc/profile.d
#  (to disable a profile, just remove execute permission on it)
for profile in /etc/profile.d/*.sh; do
  if [ -x $profile ]; then
    . $profile
  fi
done
unset profile

# End of file

Offline

#4 2005-01-21 08:25:59

scarecrow
Member
From: Greece
Registered: 2004-11-18
Posts: 714

Re: can't see winxp folders with chinese/korean folder names

Please try instead of
export LANG="en_US" to use export LANG="en_US.utf8" and reboot.
You might also have to change specfic locale values, but you should start changing just that.
After that change you might have to change your console font with another one which supports unicode.


Microshaft delenda est

Offline

#5 2005-01-21 11:02:16

zeppelin
Member
From: Athens, Greece
Registered: 2004-03-05
Posts: 807
Website

Re: can't see winxp folders with chinese/korean folder names

mandato10, if you succeed tell us what you did. Good Luck I had bad luck with modern greek filenames. Use CIFS and I remember now that reading the samba docs have a special section for japanese. {as if japanese is the only non-latin language..@!%!@} anyways

Offline

Board footer

Powered by FluxBB