You are not logged in.

#1 2009-10-02 14:34:16

drf
Member
From: Milano, Italy
Registered: 2008-01-13
Posts: 113

Plymouth is working! How to have a great splash in your box

(Note: this is cross-posted from http://chakra-project.org/bbs/viewtopic.php?pid=9135 , thought some people here could be interested smile )

Yes guys, I managed to get plymouth working - and I mean for real, with the graphics candy included. Here come some easy steps for installing it on your machine. This procedure could change from time to time as I will try to make things run even smoother and easier for the end user. Also, Chakra will include Plymouth by default soon.

Before we start:
Be aware that to get the graphical boot screen you need to have KMS in early start. At the moment the only driver doing it right with just a few modifications is the intel one, however this is going to change soon. Look in the arch forums or wiki for more details on that.

So, are you ready? First things first:

git clone git://git.chakra-project.org/chakra/plymouth

This will download our PKGBUILD for plymouth. The plymouth you'll build is branded for Chakra, but you can change this, if you know what you're doing wink Now:

cd plymouth
makepkg --skipinteg
sudo pacman -U <name of the package>

Then you can set your plymouth theme. Spinfinity looks great, so:

sudo plymouth-set-default-theme spinfinity

That's it. Now the tricky parts:

- Edit your mkinitcpio.conf. You have to add "plymouth" to your hooks. Put it the earlier you can, but NOT before base and udev, otherwise things won't work! A sane config is to put it after base udev and autodetect
- Rebuild your ramdisk (mkinitcpio -p kernel26)
- In your /boot/grub/menu.lst, you have to change the kernel line. Add "quiet" and "splash". If you're on KMS, remove any video= or vga= directive. If you're not on KMS, add a vga=whatfitsyou directive to visualize decently the text bar

Reboot, and enjoy it!

At the moment the only small caveat is that plymouthd does not get killed. Some people used a small workaround by making start a daemon that killed plymouthd. This is not a great solution (at least if you're using a login manager such as kdm or gdm). I will work on a patch to get kdm do a smooth transition from plymouth (gdm already has it). What will need to be done afterwards, is to add into /etc/rc.d/kdm (or gdm) start phase a call to "plymouthd quit --retain-splash" to make things work. Until this moment will come, just make it die somehow smile

Feedback welcome. Thanks to Jan and Heller for starting to work on this, the plymouth developers (halfline and brejc8 mainly) for their unvaluable help, and PirateJonno for the plymouth-git package, which I admit I stole some code from smile

Last edited by drf (2009-10-02 18:36:08)

Offline

#2 2009-10-02 15:11:34

KlavKalashj
Member
Registered: 2008-10-09
Posts: 362

Re: Plymouth is working! How to have a great splash in your box

I tried it now, hoping for a good result next reboot! big_smile I don't understand the last part though. Is it crucial? Where do I add this line? Will my computer boot now? big_smile In another guide, I was told to add the daemon "plymouth" to /etc/rc.conf. Do I need to do this now?

Offline

#3 2009-10-02 15:24:07

drf
Member
From: Milano, Italy
Registered: 2008-01-13
Posts: 113

Re: Plymouth is working! How to have a great splash in your box

There is no plymouth daemon in this package, as it's mostly needed for testing. You need to issue as root "killall plymouthd" when you log in

Offline

#4 2009-10-02 18:38:33

SpeedVin
Member
From: Poland
Registered: 2009-04-29
Posts: 955

Re: Plymouth is working! How to have a great splash in your box

drf wrote:

There is no plymouth daemon in this package, as it's mostly needed for testing. You need to issue as root "killall plymouthd" when you log in

Hello drf.
I think to kill plymounth quite we can add:
kill all plymounth
To rc.local locaded in /etc wink


Shell Scripter | C/C++/Python/Java Coder | ZSH

Offline

#5 2009-10-02 18:43:05

fijam
Member
Registered: 2009-02-03
Posts: 244
Website

Re: Plymouth is working! How to have a great splash in your box

Oooh, I have been waiting for this, hopelessly checking http://chakra-project.org/wiki/index.php/Plymouth from time to time.

Thanks for the update! Will try it in a moment (hope I will be back).

Offline

#6 2009-10-02 18:46:13

drf
Member
From: Milano, Italy
Registered: 2008-01-13
Posts: 113

Re: Plymouth is working! How to have a great splash in your box

SpeedVin wrote:
drf wrote:

There is no plymouth daemon in this package, as it's mostly needed for testing. You need to issue as root "killall plymouthd" when you log in

Hello drf.
I think to kill plymounth quite we can add:
kill all plymounth
To rc.local locaded in /etc wink

Also smile at the moment the change that makes more sense to me is putting it into /etc/rc.d/kdm, since it's right before the xserver kicks in. But for a complete integration, some patches to kdm, gdm or whatever are needed. A patch for gdm already exists, i'll look into doing something similar for kdm

Offline

#7 2009-10-02 19:45:26

schneida
Member
Registered: 2009-02-19
Posts: 74
Website

Re: Plymouth is working! How to have a great splash in your box

Hey! It's great seing plymouth working on archlinux. I just tried it (you can see a video here: http://qik.com/video/3076771), and it works quite good, except that there are two relative big delays at the beginning and I couldn't notice a smooth transition to gdm.

Thank you very much for working on that, archlinux is actually only the second distribution (after Fedora) with a working KMS + plymouth for me.

Offline

#8 2009-10-02 19:55:34

fijam
Member
Registered: 2009-02-03
Posts: 244
Website

Re: Plymouth is working! How to have a great splash in your box

Just tested, works great (including power off, does not break suspend nor resume) except for the pause before SLiM starts, but I believe this is to be expected right now. Rebranded it to Arch, too smile

Just a note, the PKGBUILD by default installs chakra's /etc/system-release.

Last edited by fijam (2009-10-02 19:56:01)

Offline

#9 2009-10-02 20:00:23

drf
Member
From: Milano, Italy
Registered: 2008-01-13
Posts: 113

Re: Plymouth is working! How to have a great splash in your box

Thank you guys for testing smile Yes, as you can see from the url, it's the PKGBUILD for chakra smile but rebranding it is just about changing the logo file and 2 lines in the scripts

Offline

#10 2009-10-02 20:13:30

KlavKalashj
Member
Registered: 2008-10-09
Posts: 362

Re: Plymouth is working! How to have a great splash in your box

It works very fine here. I also have these glitches, but other than that it's nice. I just don't like the loading bar in the bottom, is it possible to remove it? I mean, just see the picture and the little snake big_smile

Offline

#11 2009-10-02 20:14:51

PirateJonno
Forum Fellow
From: New Zealand
Registered: 2009-04-13
Posts: 372

Re: Plymouth is working! How to have a great splash in your box

Glad to hear its actually working. I'll do my best to get my package to work, with the right logos etc.


"You can watch for your administrator to install the latest kernel with watch uname -r" - From the watch man page

Offline

#12 2009-10-02 20:20:09

drf
Member
From: Milano, Italy
Registered: 2008-01-13
Posts: 113

Re: Plymouth is working! How to have a great splash in your box

Great big_smile Well, it is possible, you just have to change the theme smile and you can roll your own, of course. It would be great to have a real arch theme.

PirateJonno: you need very few modifications, check the source. Consider that now I'm also doing some additions for Chakra, so it would be great if you can get your pure Arch package to work.

Offline

#13 2009-10-02 21:37:22

Ashren
Member
From: Denmark
Registered: 2007-06-13
Posts: 1,221
Website

Re: Plymouth is working! How to have a great splash in your box

I just tried and I do not have a login manager. Interesting enough plymouth stalls and seems to be waiting for a login manager (I guess this was what it was build for) and the only way to get out it is to change to another tty.

drf: Thanks for making the PKGBUILD available.

Last edited by Ashren (2009-10-02 21:37:50)

Offline

#14 2009-10-02 21:39:17

drf
Member
From: Milano, Italy
Registered: 2008-01-13
Posts: 113

Re: Plymouth is working! How to have a great splash in your box

Ashren wrote:

I just tried and I do not have a login manager. Interesting enough plymouth stalls and seems to be waiting for a login manager (I guess this was what it was build for) and the only way to get out it is to change to another tty.

Exactly. You probably should kill it in your rc.local when you switch runlevel, or simply issue "plymouth quit" (better)

drf: Thanks for making the PKGBUILD available.

You're welcome smile

Offline

#15 2009-10-02 21:49:17

fijam
Member
Registered: 2009-02-03
Posts: 244
Website

Re: Plymouth is working! How to have a great splash in your box

Those using Gnome and looking for a smooth transition between plymouth and gdm might find this interesting: http://lists.freedesktop.org/archives/p … 00126.html

I guess I won't be seeing this in SLiM anytime soon hmm

Offline

#16 2009-10-02 22:39:07

PirateJonno
Forum Fellow
From: New Zealand
Registered: 2009-04-13
Posts: 372

Re: Plymouth is working! How to have a great splash in your box

Unfortunately I don't seem to be able to get it to work any better than previously. For one, the "message" command sent to the plymouth daemon seems to crash it on startup (though it works great on shutdown). Additionally, the progress stops updating once I enter runlevel 5, although at least the plymouthd process is actually still running this time. Can anyone confirm these issues or is it just something about my computer? I'm not using kernel modesetting btw, but once the runlevel issue is resolved it should be possible to show a graphical splash on the framebuffer (which works but hangs at runlevel 5 and GDM doesn't seem to be able to take over the display). I'll keep fiddling around for a bit but if no one else is having these problems i may as well update the arch package.


"You can watch for your administrator to install the latest kernel with watch uname -r" - From the watch man page

Offline

#17 2009-10-03 08:40:10

drf
Member
From: Milano, Italy
Registered: 2008-01-13
Posts: 113

Re: Plymouth is working! How to have a great splash in your box

The "message" command is still not working in Plymouth itself, from what the developers said. As soon as they will clean up the new DRM infrastructure they'll be on that.

Offline

#18 2009-10-03 08:42:20

jarryson
Member
Registered: 2007-02-18
Posts: 298

Re: Plymouth is working! How to have a great splash in your box

i think use --libexecdir=/usr/lib is better than move files handly in PKGBUILD.

Offline

#19 2009-10-03 08:46:21

jarryson
Member
Registered: 2007-02-18
Posts: 298

Re: Plymouth is working! How to have a great splash in your box

are the .a file necessary in the package? seems "!libtool" option didn't delete them

Offline

#20 2009-10-03 09:38:12

jarryson
Member
Registered: 2007-02-18
Posts: 298

Re: Plymouth is working! How to have a great splash in your box

seems it should be "plymouth quit --retain-splash" not "plymouthd quit --retain-splash"

Offline

#21 2009-10-03 13:37:56

jarryson
Member
Registered: 2007-02-18
Posts: 298

Re: Plymouth is working! How to have a great splash in your box

i think use this is the better way to start plymouth shutdown mode in plymouth.function:

if [ "$0" == "/etc/rc.shutdown" ]; then
    /sbin/plymouthd --mode=shutdown
    /bin/plymouth --show-splash
fi

so that we won't see default arch shutdown information.

Offline

#22 2009-10-03 20:24:09

fijam
Member
Registered: 2009-02-03
Posts: 244
Website

Re: Plymouth is working! How to have a great splash in your box

jarryson wrote:

i think use this is the better way to start plymouth shutdown mode in plymouth.function:

if [ "$0" == "/etc/rc.shutdown" ]; then
    /sbin/plymouthd --mode=shutdown
    /bin/plymouth --show-splash
fi

so that we won't see default arch shutdown information.

You mean use this under "Sending SIGTERM To Processes" case?

Offline

#23 2009-10-04 05:07:21

jarryson
Member
Registered: 2007-02-18
Posts: 298

Re: Plymouth is working! How to have a great splash in your box

no, at the end of plymouth.funtion file.

and delete "Sending SIGTERM To Processes" case

Offline

#24 2009-10-04 05:57:21

lonecat
Member
Registered: 2008-06-18
Posts: 32

Re: Plymouth is working! How to have a great splash in your box

Awesome! Thanks! It's super cool!

Offline

#25 2009-10-04 07:49:46

fijam
Member
Registered: 2009-02-03
Posts: 244
Website

Re: Plymouth is working! How to have a great splash in your box

jarryson wrote:

no, at the end of plymouth.funtion file.

and delete "Sending SIGTERM To Processes" case

Thanks!

Offline

Board footer

Powered by FluxBB