You are not logged in.

#1 2005-01-29 04:16:57

T-Dawg
Forum Fellow
From: Wilmington, NC
Registered: 2005-01-29
Posts: 2,734

Device Rights and SSH

I've been having trouble accessing my devices, all except the floppy. I must log in as root to use cdrom,dvd, and flash drive. I have added my user to audio,optical,disk,root, and sys. Udev rules say all these groups have access to the devices. I've tried changing the rights to the folders as well with no luck.
Also, I cannot ssh into my machine and I noticed the /etc/host.deny file is supposed to be modified to be able to use it but what should it look like? Could these two problems be related?
Please help, this is driving me nuts! :x
here is my fstab:(i've tried the default values too-/dev/cdroms/cdrom0~)
none                   /dev/pts      devpts    defaults            0      0
none                   /dev/shm      tmpfs     defaults            0      0
tmpfs                  /tmp          tmpfs     defaults            0      0
usbfs                  /proc/bus/usb usbfs  defaults               0      0

/dev/fd0              /mnt/fl        vfat        rw,users,noauto           0  0
/dev/hdc             /mnt/dvd       udf         rw,users,noauto,unhide   0 0
/dev/hdd             /mnt/cd        iso9660     rw,users,noauto,unhide    0 0
/dev/sda1                  /mnt/usbflash  vfat      rw,users,noauto,umask= 0 0 0

/dev/discs/disc0/part5     swap swap defaults 0 0
/dev/hda6         / reiserfs defaults 0 0

Offline

#2 2005-01-29 07:25:04

colnago
Member
From: Victoria, BC
Registered: 2004-03-25
Posts: 438

Re: Device Rights and SSH

I did not touch hosts.deny, I added this to hosts.allow for ssh:

sshd:ALL

Make sure you are starting the daemon in /etc/rc.conf

For the udev permissions.  Check that the device is okay:

ls -l /dev | grep hdc

Also, I think you need to log out and back in for changes to your group to take effect.  I have a file called /etc/udev/permissions.d/00.permissions that has this in it:

hdc:root:optical:0666

For my cd burner.

Offline

#3 2005-01-29 13:08:06

T-Dawg
Forum Fellow
From: Wilmington, NC
Registered: 2005-01-29
Posts: 2,734

Re: Device Rights and SSH

Thanks, Colnago ssh works now but still trouble with devices. I checked them at it returned:  [root@eLINUXe ~]# ls -l /dev | grep hdc
#lrwxrwxrwx  1 root root      13 2005-01-29 02:46 hdc -> cdroms/cdrom0
#[root@eLINUXe ~]# ls -l /dev | grep hdd
#lrwxrwxrwx  1 root root      13 2005-01-29 02:46 hdd -> cdroms/cdrom1
#[root@eLINUXe ~]# ls -l /dev | grep sda1
#brw-rw----  1 root disk   8,  1 2005-01-29 07:46 sda1

hdd is a cd writer that will open and hdc is a dvdwriter/cdwriter combo drive that will not - neither will sda1. Could these two devices be entered wrong?

Here is the error message that i get only when in user:
#mount: wrong fs type, bad option, bad superblock on /dev/hdc,
#or too many mounted file systems
#Please check that the disk is entered correctly.

Offline

#4 2005-01-29 14:00:35

lucke
Member
From: Poland
Registered: 2004-11-30
Posts: 4,018

Re: Device Rights and SSH

It seems you're using devfs - in that case check the permissions on /dev/cdroms/cdrom[01]. They should be 660 or 666.

I don't know if it has any impact, but you should change rw to ro next to the cd and dvd stuff. And I'm personally using user instead of users, but I guess it's a matter of taste.

Offline

#5 2005-01-29 14:09:12

T-Dawg
Forum Fellow
From: Wilmington, NC
Registered: 2005-01-29
Posts: 2,734

Re: Device Rights and SSH

no, im not using devfs i switched over to udev --bootup says starting udev

Offline

#6 2005-01-29 14:18:30

lucke
Member
From: Poland
Registered: 2004-11-30
Posts: 4,018

Re: Device Rights and SSH

Well, was my guess, as on my udev system /dev/cdroms/cdrom0 is a symlink to /dev/hdc, not the other way around, as it is on your system. Maybe that's the lead? O_o Anyway, change rw to ro. I don't like giving hints in cases like that, when I can't seek the error and experiment myself :-)

Good luck.

Offline

#7 2005-01-29 14:52:36

T-Dawg
Forum Fellow
From: Wilmington, NC
Registered: 2005-01-29
Posts: 2,734

Re: Device Rights and SSH

ok, I change the fstab to that, still no luck.

Offline

#8 2005-01-29 20:18:17

cactus
Taco Eater
From: t͈̫̹ͨa͖͕͎̱͈ͨ͆ć̥̖̝o̫̫̼s͈̭̱̞͍̃!̰
Registered: 2004-05-25
Posts: 4,615
Website

Re: Device Rights and SSH

are you passing the "devfs=nomount" to the kernel at boot?


"Be conservative in what you send; be liberal in what you accept." -- Postel's Law
"tacos" -- Cactus' Law
"t̥͍͎̪̪͗a̴̻̩͈͚ͨc̠o̩̙͈ͫͅs͙͎̙͊ ͔͇̫̜t͎̳̀a̜̞̗ͩc̗͍͚o̲̯̿s̖̣̤̙͌ ̖̜̈ț̰̫͓ạ̪͖̳c̲͎͕̰̯̃̈o͉ͅs̪ͪ ̜̻̖̜͕" -- -̖͚̫̙̓-̺̠͇ͤ̃ ̜̪̜ͯZ͔̗̭̞ͪA̝͈̙͖̩L͉̠̺͓G̙̞̦͖O̳̗͍

Offline

#9 2005-01-29 21:41:20

T-Dawg
Forum Fellow
From: Wilmington, NC
Registered: 2005-01-29
Posts: 2,734

Re: Device Rights and SSH

yes i did, it udev shows up in the boot.

Offline

#10 2005-01-30 01:06:34

T-Dawg
Forum Fellow
From: Wilmington, NC
Registered: 2005-01-29
Posts: 2,734

Re: Device Rights and SSH

I found the problem, it was in my fstab. For the flash drive, I had to remove the space between = and 0 (umask= 0 0 0 -->umask=0 0 0).  With the dvd, I had to replace UDF with iso9660. Every thing reads fine with the dvd drive, only i cant eject without being root. roll I have no clue how I was able to mount these devices as root.
   Thanks for everyone's help!

Offline

Board footer

Powered by FluxBB