You are not logged in.

#1 2009-10-19 06:56:10

lgolebio
Member
From: Poland / Wroclaw
Registered: 2008-07-28
Posts: 101

After Gnome update cpufreq-applet needs privilages all the time.

Hi
I have upgraded Gnome to the latest 2.28 version with pacman. Problem is that I can't change cpufreq with cpufreq-applet without typing the root password. That's ok, but why I have to do it all the time I wan't to change the cpu policy. It is really annoying. Is there a possibility that gnome will save that password "forever" and won't ask me again for root pasword in the future ?

Offline

#2 2009-10-19 09:09:29

sliponoga
Member
Registered: 2007-09-14
Posts: 38

Re: After Gnome update cpufreq-applet needs privilages all the time.

lgolebio wrote:

Is there a possibility that gnome will save that password "forever" and won't ask me again for root pasword in the future ?

Not exactly, but ... create /var/lib/polkit-1/localauthority/50-local.d/org.gnome.cpufreqselector.pkla file containing

[org.gnome.cpufreqselector]
Identity=unix-user:lgolebio
Action=org.gnome.cpufreqselector
ResultAny=no
ResultInactive=no
ResultActive=yes

For more information see man pklocalauthority.

Offline

#3 2009-10-19 09:11:35

stefanwilkens
Member
From: Enschede, the Netherlands
Registered: 2008-12-10
Posts: 624

Re: After Gnome update cpufreq-applet needs privilages all the time.

since you're using gnome, try configuring policykit through:
System -> Preferences -> Authorisations

It will be under hal - power-management - Configure CPU frequency scaling


Arch i686 on Phenom X4 | GTX760

Offline

#4 2009-10-19 09:32:29

sliponoga
Member
Registered: 2007-09-14
Posts: 38

Re: After Gnome update cpufreq-applet needs privilages all the time.

stefanwilkens wrote:

since you're using gnome, try configuring policykit through:
System -> Preferences -> Authorisations
It will be under hal - power-management - Configure CPU frequency scaling

It won't work, because cpu frequency applet does not use org.freedesktop.Hal.Device.SystemPowerManagement interface anymore. Instead it uses /org/gnome/cpufreq_selector/selector object implementing org.gnome.CPUFreqSelector which in turn is tied with polkit-1 authorization framework instead of old PolicyKit.

Last edited by sliponoga (2009-10-19 09:52:38)

Offline

#5 2009-10-19 11:16:45

arkham
Member
From: Stockholm
Registered: 2008-10-26
Posts: 516
Website

Re: After Gnome update cpufreq-applet needs privilages all the time.

This solution worked great for me: thank you very much sliponoga smile


"I'm Winston Wolfe. I solve problems."

~ Need moar games? [arch-games] ~ [aurcheck] AUR haz updates? ~

Offline

#6 2009-10-19 11:59:59

stefanwilkens
Member
From: Enschede, the Netherlands
Registered: 2008-12-10
Posts: 624

Re: After Gnome update cpufreq-applet needs privilages all the time.

sliponoga wrote:
stefanwilkens wrote:

since you're using gnome, try configuring policykit through:
System -> Preferences -> Authorisations
It will be under hal - power-management - Configure CPU frequency scaling

It won't work, because cpu frequency applet does not use org.freedesktop.Hal.Device.SystemPowerManagement interface anymore. Instead it uses /org/gnome/cpufreq_selector/selector object implementing org.gnome.CPUFreqSelector which in turn is tied with polkit-1 authorization framework instead of old PolicyKit.

things they are a-changin'


Arch i686 on Phenom X4 | GTX760

Offline

#7 2010-12-12 20:05:43

nickoe
Member
From: Denmark
Registered: 2009-06-30
Posts: 7

Re: After Gnome update cpufreq-applet needs privilages all the time.

Thanks sliponoga smile

Offline

#8 2010-12-12 21:18:09

graysky
Member
From: /run/user/1000
Registered: 2008-12-01
Posts: 8,511
Website

Re: After Gnome update cpufreq-applet needs privilages all the time.

Dude, don't necrobump a 1+ year old thread...

https://wiki.archlinux.org/index.php/Cp … nder_Gnome and https://wiki.archlinux.org/index.php/GN … nder_Gnome

Last edited by graysky (2010-12-12 21:27:03)


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

Board footer

Powered by FluxBB