You are not logged in.

#1 2005-01-31 14:52:34

LinuxNewbie
Member
Registered: 2004-06-03
Posts: 22

ATI Frustration [SOLVED]

With the new ATI drivers for Xorg out, I thought I would try to get Direct Rendering working on my system again.

I rolled back my Xorg to version 6.7 as most of the forums suggested.

I installed the drivers from the link repository:

ati-drivers-module-kernel26 (8.8.25-1)
ati-drivers (8.8.25-1)

These installed fine. I ran the fglrxconfig and placed the new xorg.conf in my /etc/X11 folder.

When I run startx I recieve this error message Xorg is killed.

Symbol fbGetWinPrivateIndex from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o is unresolved!
Symbol XAAGetPixmapIndex from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o is unresolved!
Symbol fbGetWinPrivateIndex from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o is unresolved!
Symbol XAAGetPixmapIndex from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o is unresolved!
Symbol XAAGetScreenIndex from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o is unresolved!
Symbol XAAGetScreenIndex from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o is unresolved!
Symbol XAAGetScreenIndex from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o is unresolved!
Symbol XAAGetScreenIndex from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o is unresolved!
Symbol XAAGetScreenIndex from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o is unresolved!
Symbol noCompositeExtension from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o is unresolved!
Symbol noCompositeExtension from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o is unresolved!

Please Help. This is the last thing I need to do to finally be rid of my Windows system forever.  big_smile

Offline

#2 2005-01-31 15:19:18

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,366
Website

Re: ATI Frustration [SOLVED]

fbGetWinPrivateIndex
noCompositeExtension
XAAGetPixmapIndex

are introduced in R6.8.1 i think (not really sure) so i would try to use the latest xorg and try to make the ati-driver pkgs yourself (maybe there are new versions out)


The impossible missions are the only ones which succeed.

Offline

#3 2005-01-31 16:02:05

LinuxNewbie
Member
Registered: 2004-06-03
Posts: 22

Re: ATI Frustration [SOLVED]

I upgraded to xorg 11R6.8.1-1 as you reccomended. No luck. sad

I built my ati-drivers from the link PKGBUILD. It compiles version 8.8.25-1 which is the latest from the ATI site.

Offline

#4 2005-01-31 21:15:09

zhitch
Member
Registered: 2004-10-31
Posts: 22

Re: ATI Frustration [SOLVED]

EDIT: make sure ya read this WHOLE POST before attempting..but it worked for me...I never used the PKGBUILD`s here so I can`t comment...but looks as if they don`t work for some folks so I thought I`d  share what worked for me..even though its a royal pain  roll
I have a Radeon 9700 Pro and the new drivers are a bit tricky to install..but if you take your default xorg.conf then run fglrxconfig..then goto the resulting XFree86-4.conf and cut the entire Graphics device section and past it into the xorg.conf..(replacing it...delete the section from xorg.conf first) and rename the device under Screen sections to this.. Device "ATI Graphics Adapter"
to use the RPM put it in your / dir and run the following

 
rpmunpack < fglrx"version number".i386.rpm | gzip -d | cpio -idmuv

replacing the version number with the actual filename.Also make sure you make the file make.sh in the build_mod dir and make_install.sh in the fglrx dir EXECUTABLE..or youll get the good ole "permission denied"
..then go to /lib/modules/fglrx/build_mod and execute make.sh then do as instructed and cd .. then ./make_install.sh sorry you should go the bit with the RPM FIRST...then do the cut and paste with xorg.conf..also if your running a 2.6.10 kernel theres a patch that needs to be applied..it can be found at Rage 3d

Offline

#5 2005-02-01 21:28:27

LinuxNewbie
Member
Registered: 2004-06-03
Posts: 22

Re: ATI Frustration [SOLVED]

Thank you so much! That worked. big_smile

12390 frames in 5.0 seconds = 2478.000 FPS

Arch Linux is the only distro I've ever been able to get my card working with. Arch rules!  8)

Offline

Board footer

Powered by FluxBB