You are not logged in.

#1 2003-09-04 12:40:42

yowwww
Member
Registered: 2003-09-04
Posts: 112

another usb mouse problem + sound

First off, let me just say I am not new to linux, but I am new to Arch linux. I can't believe I didn't try this a long time ago. So far it is fantastic! I installed it last night and everything went off without a single hitch. I even got kde up and running and installed a fair amount of packages as well as getting my internet to work. Anyway, on to my problem...

I have searched this forum for an answer regarding my usb mouse and tried several things suggested to other people and they did not work for me.

I have tried adding usbmouse, mousedev, hid and input to the /etc/rc.conf file and it only brought up errors for me on boot.

I can see my mouse pointer when I log into kde, but I can't move it all. I am using a logitech trackball plugged into a usb pci card. I have other linux distributions on the same box (quintuple boot now) and they all work but this one (yet) so I know it is possible. I even copied the settings from another linux install hoping it would work:

Identifier (left this alone in Arch, I think it said mouse1)
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"

also, with my sound card, I copied the same module name from another distro into my /etc/modules.conf file. I need to double check this though, cuz I am not sure if it is a permission problem or not. I will get in as root and try to do something that makes noise, lol. Maybe I can just add sound to my user somehow thru kuser.

The main concern right now is my mouse, so any help would be appreciated.

Offline

#2 2003-09-04 12:57:06

Toth
Member
Registered: 2002-12-04
Posts: 82

Re: another usb mouse problem + sound

Try removing those modules from /etc/rc.conf and reboot (not exactly necessary, but may make things easier).

Become root and try modprobe mousedev. It's been a while but I think that should automatically pull in the hid and input modules. I don't *think* usbmouse is needed. The errors on boot might be because some of the modules are already loaded. E.g., it loads mousedev which loads hid and input, and then errors when trying to load hid and input.

Then try starting X. Hopefully that will work. Also, from a terminal try cat /dev/input/mice and then move the trackball. You should see garbage characters on your screen (Ctrl-C to get the prompt back. Note this may garble your terminal and cause you to switch to another VT to continue using the system until that VT is killed). If you do, then the problem is with X and not the modules. Do you have GPM loading on startup?

Once you get it to work, add whatever modules you had to manually load to /etc/rc.conf

As for the sound, yes, you'll have to modify the permissions on /dev/sound/* in order to get sound as a normal user. Note that Arch uses DevFS though, so the permission changes must be done in /etc/devfsd.conf.

Good luck!

Offline

#3 2003-09-04 13:15:35

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,366
Website

Re: another usb mouse problem + sound

-> at boottime you dont need any module loaded with /etc/rc.conf
-> what "other distro" was that? what kernel? what xfree86?


this code works with a USB mouse with a wheel great on quite all distros with the newest kernel and newest stable xfree86 ... so also on archlinux:

Section "InputDevice"
  Driver       "mouse"
  Identifier   "Mouse[1]"
  Option       "Device" "/dev/input/mice"
  Option       "Name" "Autodetection"
  Option       "Protocol" "imps/2"
  Option       "Vendor" "Sysp"
  Option       "ZAxisMapping" "4 5"
EndSection

....... .......

Section "ServerLayout"
  Identifier   "Layout[all]"
  InputDevice  "Keyboard[0]" "CoreKeyboard"
  InputDevice  "Mouse[1]" "CorePointer"
 # InputDevice  "Mouse[3]" "SendCoreEvents"
  Option       "Clone" "off"
  Option       "Xinerama" "off"
  Screen       "Screen[0]"
 # Screen       "Screen[1]" relative "Screen[0]" 1 0
EndSection

what i'm not sure if it matters, but try to addapt:

-> your Option "Device" do not begin with a / ... try to add a / before the dev/input/mice

-> also i dont know if the protocol is named in caps only ... try "imps/2"

-> be sure that the Identifier you named in the "Imput device" section of your mouse is called in the "Server Layout" the same name and core pointer


The impossible missions are the only ones which succeed.

Offline

#4 2003-09-04 13:17:45

yowwww
Member
Registered: 2003-09-04
Posts: 112

Re: another usb mouse problem + sound

well, not working yet.

here is what I tried:

sound
edited /etc/devfsd.conf

by adding REGISTER sound /.* PERMISSIONS root.users 660

(I tried it with "sound/.*" also, in case I got the spacing wrong) This one actually showed that devfs failed on boot.
*Where exactly am I supposed to insert this line in that file?

mouse
well, i tried cat /dev/input/mice and got nothing on my screen at all
I tried modprobe mousedev and it said that one file was older than another and failed the modprobe anyway., I rebooted a few times for the hell of it (windass tribute, lol), but that didn't make any difference.

So, I am exactly where I was. Getting the mouse to work would be great. The sound does work in root but does not work as user, so it is definitely a permission problem.

Thanks.

Offline

#5 2003-09-04 13:20:55

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,366
Website

Re: another usb mouse problem + sound

for sound there is a really simple solution, that a lot of linux experts dont like, because its more or less a hack and a bad one, but it works great:

add in /etc/rc.local

chmod a+rw /dev/dsp

The impossible missions are the only ones which succeed.

Offline

#6 2003-09-04 13:42:13

Toth
Member
Registered: 2002-12-04
Posts: 82

Re: another usb mouse problem + sound

Honestly, I'm not all that familiar with using /etc/devfsd.conf (something which I should learn).

What I did is uncomment the section that saves and restores filesystem permissions. The lines following "Uncomment this if you want permissions to be saved and restored." Then reboot, and any permissions you change will persist. Then you can just use chmod on /dev/sound/*

As for the mouse, try running depmod -a before the modprobe? Not sure on that.

Offline

#7 2003-09-04 13:58:21

yowwww
Member
Registered: 2003-09-04
Posts: 112

Re: another usb mouse problem + sound

well, I dunno what to say at this point, it's frustrating cuz the system is right there, but practically useless without sound or my mouse.

I have tried tons of different combinations and suggestions and not sure where to go from there.

I did discover that using:

alias sound-slot-0 cmpci

will give me sound in root consistently, while nothing seems to work for sound in user mode. I haven't tried Toth's latest suggestion tho for chmod.

When I try to modprobe anything to do with the mouse I get a message saying /etc/modules.conf (I think) is newer than /usr/lib/kernel.... something. and then it just says modprobe whatever module failed.

The unfortunate thing is that I can't just swap out a mouse or anything cuz this box needs to use the usb mouse (long story).

I'll have to think about it more, for now, I need some rest. Thanks for the input, if you have anything to add, feel free.

* BTW, the omission of the / in "dev/input/mice" was merely a typo in my post.

Offline

#8 2003-09-04 14:36:27

Toth
Member
Registered: 2002-12-04
Posts: 82

Re: another usb mouse problem + sound

When you have sound working consistently as root you should be able to just do a # chmod a+rw /dev/sound/* and it should work fine for users. Once you get it working like that you can do something more fancy like creating a sound group, giving them permissions and then only adding users you want to have permission into that group. A little paranoid for a desktop machine though.

As far as modules.conf being newer than /lib/modules/(kernel version)/modules.dep whatever, you have to run depmod -a after editing modules.conf. That should fix that warning. Run depmod -a then modprobe mousedev and post what the errors are. That might help us determine the problem.

Also, you multiboot several Linux distros. Try an lsmod in one of them and look at what modules are loaded relevant to your mouse. That may also help.

Offline

#9 2003-09-04 18:07:12

yowwww
Member
Registered: 2003-09-04
Posts: 112

Re: another usb mouse problem + sound

alright, I did depmod -a and it got rid of that error message and did chmod a+rw /dev/sound/* but I haven't tested that as user yet.

I logged onto red hat 9 and did an /sbin/lsmod and got this list:

cmpci
soundcore
autofs
dmfe
keybdev
mousedev
hid
input
usb-ohci
usbcore
ext3
jbd

* I do realize that a lot of that stuff I probably don't need and red hat just bloats it up to ensure everything will work, here is what an lsmod gives me in Arch:

dmfe
rtc

* quite the difference. I'm not saying that is bad, in fact, I would rather have less as long as everything is working.

I did a modprobe for mousedev in Arch and it said it couldn't locate the module.

Any ideas?

I'd love to get this working. I am really impressed by this distro so far and will likely replace gentoo with it on my main box (triple boot).

Thanks in advance.

Offline

#10 2003-09-04 18:38:47

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,366
Website

Re: another usb mouse problem + sound

-> try to set

Option "Protocol" "Auto"

... some mice dont like the imps/2


The impossible missions are the only ones which succeed.

Offline

#11 2003-09-05 00:09:48

yowwww
Member
Registered: 2003-09-04
Posts: 112

Re: another usb mouse problem + sound

update: I was gone all day doing service calls, but when I came back, I decided to try to load all the modules that I listed as running in red hat while in Arch.

The magic one to get my mouse working was "modprobe usb-ohci". Now my mouse works - yayyyy!

As for the sound, as per a previous suggestion , after I logged in as user, I got root privs in the terminal and did "chmod a+rw /dev/sound/*" and now I have sound as a user.

The trick is to figure out how to make these things permanent/load at boot.

Thanks to those who helped steer me in the right direction. I will likely put this on my main box also.

Much appreciated!   big_smile

Offline

#12 2003-09-05 10:38:26

Toth
Member
Registered: 2002-12-04
Posts: 82

Re: another usb mouse problem + sound

I'm pretty surprised at that, as usb-ohci (or usb-uhci) is required for any USB device to work. I really hadn't thought about that at the time since I've been using a custom compiled kernel for the past 6 months with USB built in. I'm glad that's working though!

To get those modules to load at boot time, you can add them to the MODULES array in /etc/rc.conf. Just make sure that usb-ohci is listed before mousedev (and you may want to make sure that mousedev does indeed automatically pull in the hid and input modules, you may have to list them all).

As for sound, you can either use my suggestion with devfsd.conf to allow changes you make to the filesystem to persist (I find this to be the simplest solution), or determine the correct syntax for the line in devfsd.conf for setting permissions. If I get a chance I'll read over the man page since I've been meaning to do that anyway.

Offline

#13 2003-09-05 13:41:03

Toth
Member
Registered: 2002-12-04
Posts: 82

Re: another usb mouse problem + sound

After some googling, it appears the proper /etc/devfsd.conf entry would be:

REGISTER        sound/.*        PERMISSIONS root.root rw-rw-rw-

(Note that there is no space between the "/" and the ".")

If you want to use the octal representation, I believe you can, but you should use "0666" i.e. similar to how you specify permission masks to the mount command.

Of course you could also change the group ownership and remove the rw permissions for world to allow only a certain group to use sound. (probably a good idea)

Offline

#14 2003-09-05 15:35:23

Xentac
Forum Fellow
From: Victoria, BC
Registered: 2003-01-17
Posts: 1,797
Website

Re: another usb mouse problem + sound

Here we go, the actual answers to your problems.

To load usb-ohci on startup add it to the MODULES variable in /etc/rc.conf and reboot.  This will work because it's the official way to load modules.

To get the sound permissions right (in your case you want root.user and 660) add this line to your /etc/devfsd.conf file:

REGISTER ^sound/.* PERMISSIONS root.user 660

This will work as well, because I do it on my system.  Be sure to reboot after this change as well, because devfs doesn't always pick up all changes on a SIGHUP or SIGUSR1.


I have discovered that all of mans unhappiness derives from only one source, not being able to sit quietly in a room
- Blaise Pascal

Offline

#15 2003-09-05 17:35:10

apeiro
Daddy
From: Victoria, BC, Canada
Registered: 2002-08-12
Posts: 771
Website

Re: another usb mouse problem + sound

Xentac wrote:

REGISTER ^sound/.* PERMISSIONS root.user 660

To be pedantic, the ownership should be root.users

Offline

#16 2003-09-05 17:41:36

Xentac
Forum Fellow
From: Victoria, BC
Registered: 2003-01-17
Posts: 1,797
Website

Re: another usb mouse problem + sound

Hehehe, oops... Mine's actually root.audio, so it was good that I changed it from that ;o)


I have discovered that all of mans unhappiness derives from only one source, not being able to sit quietly in a room
- Blaise Pascal

Offline

#17 2003-09-06 17:08:15

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: another usb mouse problem + sound

i have drastically edited this thread as it broke the easy linux guides "rules":

Posts may edited or deleted if:

* There is excessive swearing or it is directed toward someone in a derogatory fashion.

* There is behavior that is in conflict of upholding each member's integrity and worth.

* There is information that may bring negative attention to this forum (warez and such).


Remember, if you have something to say that doesn't belong on the forum, there is always Private Messaging - however, please do not use that as a method of bashing anyone.

Follow these easy rules and enjoy your stay!

yowwww i point you to rule #2 in this quote. from the posts i deleted you had broken it several times. dp questioned your search skills and post something that was a bit rude but was quite on the mark. while you like to claim some sort of vast experience in linux the posts you made here showed that you had not RTFM nor did you have enough experience---at least with arch and search abilities. to solve your problems. RTFM is not a big thing on my list but for your sound issues and how hard you tried to tackle them:

here is what I tried:

sound
edited /etc/devfsd.conf

by adding REGISTER sound /.* PERMISSIONS root.users 660

(I tried it with "sound/.*" also, in case I got the spacing wrong) This one actually showed that devfs failed on boot.
*Where exactly am I supposed to insert this line in that file?

if your reading skills were as good as mine then you would have realized that even in your example here that some key terminology was left out of your devfs.d conf line. you should have also known that you could have done this:

sarah@ArchLinux:~/Arch/unfinished/openoffice> cat /etc/rc.local
#!/bin/sh
#
# /etc/rc.local: Local multi-user startup script.
#
modprobe usb scanner
modprobe usb printer

modprobe snd-cmipci
modprobe snd-pcm-oss
chown -R sarah.users /dev/sound/*
chown -R sarah.users /dev/snd/*

modprobe ide-scsi
modprobe sr_mod
modprobe sg

hdparm -d 1 -X34 -k 1 /dev/cdroms/cdrom0

# End of file

yes i load some stuff in a very non arch way. but it works very well.

anyway enough of this. this will be my last post for awhile you and many other have annoyed me enough on forums. you don't even bother following the rules of your own forum here but feel the need to be insulting and engage in name calling. for the record i did not call you eliteist i accuse you of being high and mighy meaning that you seem to think you know the right thing to do all the time. which include insulting members here and accusing the arch community of being unwelcoming...if we were unwelcoming we would have told you to take your questions elsewhere or not responded at all.

you have no concept of how nice or welcoming i can be beacuse you chose to be rude, demanding, and accuasatory. alot of the package that will be added to arch are a result of hours of work by dp. he has contributed alot of packages in the last month or so. me well if you use unofficial you can thank me for the large part of that i added the majority of those package back in late December and had to maintain the majority of it for several months on my own. but regardless i still managed to find a week to build open office this spring and that PKGBUILD was use by apeiro to build successive ones (with some minor changes here and there).

so call me what you like i really could not give a care i know that i am infinitely more helpful to the arch community than you try and give me credit for.

did you even know that i would help you despite the fact that you chose to trash me?

anyway. like i said before i am taking time away from this forum. good bye

PS. if you think that my behavior was the worst you have seen by a mod thats really funny because i think your behavior is about the worst i have seen from a newbie to arch linux.


AKA uknowme

I am not your friend

Offline

Board footer

Powered by FluxBB