You are not logged in.

#1 2009-10-18 10:08:00

scorp
Member
Registered: 2009-03-01
Posts: 24

Kernel 2.6.31 + RT2500 problem

Hello,

after update to kernel 2.6.31, my RT2500 based wireless network card does not work anymore. The only error I could find is following repeating crap in the dmesg:

...
phy0 -> rt2500pci_set_device_state: Error - Device failed to enter state 3 (-16).
phy0 -> rt2500pci_set_device_state: Error - Device failed to enter state 4 (-5).
phy0 -> rt2500pci_set_device_state: Error - Device failed to enter state 3 (-16).
phy0 -> rt2500pci_set_device_state: Error - Device failed to enter state 4 (-5).
phy0 -> rt2500pci_set_device_state: Error - Device failed to enter state 3 (-16).
phy0 -> rt2500pci_set_device_state: Error - Device failed to enter state 4 (-5).
...

Here some additional information:

$ lspci -nn
00:00.0 Host bridge [0600]: ATI Technologies Inc RS480 Host Bridge [1002:5950] (rev 10)
00:01.0 PCI bridge [0604]: ATI Technologies Inc RS480 PCI Bridge [1002:5a3f]
00:06.0 PCI bridge [0604]: ATI Technologies Inc RS480 PCI Bridge [1002:5a38]
00:07.0 PCI bridge [0604]: ATI Technologies Inc RS480 PCI Bridge [1002:5a39]
00:12.0 IDE interface [0101]: ATI Technologies Inc IXP SB400 Serial ATA Controller [1002:4379] (rev 80)
00:13.0 USB Controller [0c03]: ATI Technologies Inc IXP SB400 USB Host Controller [1002:4374] (rev 80)
00:13.1 USB Controller [0c03]: ATI Technologies Inc IXP SB400 USB Host Controller [1002:4375] (rev 80)
00:13.2 USB Controller [0c03]: ATI Technologies Inc IXP SB400 USB2 Host Controller [1002:4373] (rev 80)
00:14.0 SMBus [0c05]: ATI Technologies Inc IXP SB400 SMBus Controller [1002:4372] (rev 83)
00:14.1 IDE interface [0101]: ATI Technologies Inc IXP SB400 IDE Controller [1002:4376] (rev 80)
00:14.2 Audio device [0403]: ATI Technologies Inc IXP SB4x0 High Definition Audio Controller [1002:437b] (rev 01)
00:14.3 ISA bridge [0601]: ATI Technologies Inc IXP SB400 PCI-ISA Bridge [1002:4377] (rev 80)
00:14.4 PCI bridge [0604]: ATI Technologies Inc IXP SB400 PCI-PCI Bridge [1002:4371] (rev 80)
00:18.0 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration [1022:1100]
00:18.1 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map [1022:1101]
00:18.2 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller [1022:1102]
00:18.3 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control [1022:1103]
01:05.0 VGA compatible controller [0300]: ATI Technologies Inc RS482 [Radeon Xpress 200M] [1002:5975]
04:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 01)
05:04.0 FireWire (IEEE 1394) [0c00]: O2 Micro, Inc. Firewire (IEEE 1394) [1217:00f7] (rev 02)
05:04.2 SD Host controller [0805]: O2 Micro, Inc. Integrated MMC/SD Controller [1217:7120] (rev 01)
05:04.3 Mass storage controller [0180]: O2 Micro, Inc. Integrated MS/xD Controller [1217:7130] (rev 01)
05:09.0 Network controller [0280]: RaLink RT2500 802.11g Cardbus/mini-PCI [1814:0201] (rev 01)
$ iwconfig wlan0
wlan0     IEEE 802.11bg  ESSID:""  
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated   
          Tx-Power=27 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
$ ifconfig wlan0
wlan0     Link encap:Ethernet  HWaddr 0E:FA:7C:AF:82:C8  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
$ iwlist wlan0 scan
wlan0     No scan results

I had to fallback to kernel 2.6.30. I hope s.o. can help.
thx

Offline

#2 2009-10-18 20:00:17

scorp
Member
Registered: 2009-03-01
Posts: 24

Re: Kernel 2.6.31 + RT2500 problem

Am I really the only one with this hardware/problem?

Offline

#3 2009-10-21 09:08:50

xbalto
Member
Registered: 2009-03-05
Posts: 5

Re: Kernel 2.6.31 + RT2500 problem

I just upgraded and am having the same problem, although with a card that uses the rt2870 driver.  Similar errors in the dmesg.

Offline

#4 2009-10-25 19:38:42

biengo
Member
Registered: 2009-10-22
Posts: 2

Re: Kernel 2.6.31 + RT2500 problem

I'm having random disconnect problems with my ralink pcmcia card since the upgrade to 2.6.31. The circumstances are yet unclear, sometimes it reconnects automatically, sometimes not. Dmesg gives a generic disconnect message (reason 7, whatever it means).
I'm unsure if this problem is connected, but it seems there is some sorting out to do in the RT2561/RT61 modules.
See also this thread on the matter.

Offline

#5 2009-10-29 19:43:54

bds
Member
Registered: 2004-02-27
Posts: 47

Re: Kernel 2.6.31 + RT2500 problem

I just upgraded a laptop (wireless driver rt2500pci) to kernel 2.6.31 and ran into the same problem reported by the OP.

I found a workaround here: http://article.gmane.org/gmane.linux.kernel/889800
Just disable powersavng.

# iwconfig wlan0 power off

I use netcfg, and modified my wireless config file as follows:

IWCONFIG="rate 54M mode managed power off"

Works for me!

Offline

#6 2009-10-30 19:01:27

q0tsa
Member
Registered: 2009-07-20
Posts: 39

Re: Kernel 2.6.31 + RT2500 problem

My rt2870-based WLAN-Card also stopped working after upgrading to Kernel 2.6.31. I found a solution in the german ubuntuusers-forum. You have to blacklist 3 modules that seem to conflict with rt2870sta. (add !rt2800usb !rt2x00usb !rt2x00lib to MODULES-Array in rc.conf)

http://forum.ubuntuusers.de/topic/einen … st-2188945

Offline

#7 2009-10-30 21:22:19

.:B:.
Forum Fellow
Registered: 2006-11-26
Posts: 5,819

Re: Kernel 2.6.31 + RT2500 problem

I have an rt2500-usb stick here (two actually, both Asus WL-167G) and they work fine on both systems that have Arch running with the official 2.6.31.x kernel package. I do get stuff like this though (but not anything like the topic starter's messages), if it's worth anything:

phy0 -> rt2x00usb_vendor_request: Error - Vendor Request 0x07 failed for offset 0x0444 with error -19.
phy0 -> rt2x00usb_vendor_request: Error - Vendor Request 0x06 failed for offset 0x0444 with error -19.
phy0 -> rt2x00usb_vendor_request: Error - Vendor Request 0x06 failed for offset 0x041a with error -19.
phy0 -> rt2x00usb_vendor_request: Error - Vendor Request 0x06 failed for offset 0x041c with error -19.
phy0 -> rt2x00usb_vendor_request: Error - Vendor Request 0x06 failed for offset 0x0466 with error -19.
phy0 -> rt2x00usb_vendor_request: Error - Vendor Request 0x0c failed for offset 0x0000 with error -19.
phy0 -> rt2x00usb_vendor_request: Error - Vendor Request 0x07 failed for offset 0x0428 with error -19.
phy0 -> rt2x00usb_vendor_request: Error - Vendor Request 0x06 failed for offset 0x0428 with error -19.
phy0 -> rt2x00usb_vendor_request: Error - Vendor Request 0x07 failed for offset 0x0428 with error -19.
phy0 -> rt2x00usb_vendor_request: Error - Vendor Request 0x06 failed for offset 0x0428 with error -19.
phy0 -> rt2x00usb_vendor_request: Error - Vendor Request 0x07 failed for offset 0x0428 with error -19.
phy0 -> rt2x00usb_vendor_request: Error - Vendor Request 0x06 failed for offset 0x0428 with error -19.
phy0 -> rt2x00usb_vendor_request: Error - Vendor Request 0x07 failed for offset 0x0428 with error -19.
phy0 -> rt2x00usb_vendor_request: Error - Vendor Request 0x06 failed for offset 0x0428 with error -19.

Got Leenucks? :: Arch: Power in simplicity :: Get Counted! Registered Linux User #392717 :: Blog thingy

Offline

#8 2009-11-02 06:57:03

sxtynnmach1
Member
From: Cali
Registered: 2009-10-31
Posts: 12

Re: Kernel 2.6.31 + RT2500 problem

q0tsa wrote:

My rt2870-based WLAN-Card also stopped working after upgrading to Kernel 2.6.31. I found a solution in the german ubuntuusers-forum. You have to blacklist 3 modules that seem to conflict with rt2870sta. (add !rt2800usb !rt2x00usb !rt2x00lib to MODULES-Array in rc.conf)

This fixed it for me. I have a Linksys Wireless N (WUSB600N) with the rt2870 chipset for everyone's reference.


Hello Darkness, my old friend. I've come to speak with you again.

Offline

#9 2009-11-02 11:51:19

moljac024
Member
From: Serbia
Registered: 2008-01-29
Posts: 2,676

Re: Kernel 2.6.31 + RT2500 problem

My ralink wireless card also doesn't work with the new kernel and I'm still using 2.6.30 at the moment.
But my problems seem to be different, ifconfig doesn't even show the wlan0 interface. It seems someone messed something up in the kernel...


The day Microsoft makes a product that doesn't suck, is the day they make a vacuum cleaner.
--------------------------------------------------------------------------------------------------------------
But if they tell you that I've lost my mind, maybe it's not gone just a little hard to find...

Offline

Board footer

Powered by FluxBB