You are not logged in.

#1 2005-02-02 00:21:43

Gullible Jones
Member
Registered: 2004-12-29
Posts: 4,863

GRUB unable to find file, fails to install

(FTP install via floppies, GRUB 0.96-1, installation via arch/setup utility)

GRUB fails to install, giving the error message "Error: unable to find file" after checking for a file in /boot/grub (grub.menu IIRC), and quitting without further action. Menu.1st is there, but GRUB seems to want something else.

Offline

#2 2005-02-02 02:37:14

cactus
Taco Eater
From: t͈̫̹ͨa͖͕͎̱͈ͨ͆ć̥̖̝o̫̫̼s͈̭̱̞͍̃!̰
Registered: 2004-05-25
Posts: 4,615
Website

Re: GRUB unable to find file, fails to install

if I recall correctly, I always had to edit the grub file..not change anything, just select it for editing, and then do a :qw (using vi). Likely it just required touching the file or something.


"Be conservative in what you send; be liberal in what you accept." -- Postel's Law
"tacos" -- Cactus' Law
"t̥͍͎̪̪͗a̴̻̩͈͚ͨc̠o̩̙͈ͫͅs͙͎̙͊ ͔͇̫̜t͎̳̀a̜̞̗ͩc̗͍͚o̲̯̿s̖̣̤̙͌ ̖̜̈ț̰̫͓ạ̪͖̳c̲͎͕̰̯̃̈o͉ͅs̪ͪ ̜̻̖̜͕" -- -̖͚̫̙̓-̺̠͇ͤ̃ ̜̪̜ͯZ͔̗̭̞ͪA̝͈̙͖̩L͉̠̺͓G̙̞̦͖O̳̗͍

Offline

#3 2005-02-02 07:24:17

apeiro
Daddy
From: Victoria, BC, Canada
Registered: 2002-08-12
Posts: 771
Website

Re: GRUB unable to find file, fails to install

Sorry, the GRUB data files had changed location.  I've added symlinks that should work with the 0.7 ftp installer.

Offline

#4 2005-02-02 13:42:32

Moo-Crumpus
Member
From: Hessen / Germany
Registered: 2003-12-01
Posts: 1,444

Re: GRUB unable to find file, fails to install

There might be an issue relative to the used fs. I allways had problems if I tried to install grub into xfs or jfs partitions, and had to install lilo first during installation procedure. After first boot, I usually removed lilo and installed grub without any problems.


Frumpus addict
[mu'.krum.pus], [frum.pus]

Offline

#5 2005-02-02 20:10:57

Gullible Jones
Member
Registered: 2004-12-29
Posts: 4,863

Re: GRUB unable to find file, fails to install

I was using reiserfs 3.6, and installing it to the MBR.

Well, I guess I'll have to see if it works now...

Offline

Board footer

Powered by FluxBB