You are not logged in.

#1 2005-01-30 19:57:50

Hippuh
Member
Registered: 2005-01-30
Posts: 22

xfce 4.2

I just installed XFCE 4.2 and i must say its what i was looking for except for the fact that i cant select shutdown or reboot when i click on the exit button. Does anybody know how to enable this to normal users?

Offline

#2 2005-01-30 20:06:56

stonecrest
Member
From: Boulder
Registered: 2005-01-22
Posts: 1,190

Re: xfce 4.2

Read the XFCE documentation.


I am a gated community.

Offline

#3 2005-01-30 20:09:15

droog
Member
Registered: 2004-11-18
Posts: 877

Re: xfce 4.2

You have to install sudo and edit /etc/sudoers to allow shutdown for normal users. I've seen this answered a few times around here so i did a quick search and found this . http://bbs.archlinux.org/viewtopic.php? … 4+shutdown

Offline

#4 2005-01-31 13:48:05

Hippuh
Member
Registered: 2005-01-30
Posts: 22

Re: xfce 4.2

Yeah i tried that, added it all but still cant select shutdown/reboot it just keeps unselectable. Well ill go on trying stuff.
First i have to reinstall arch because i installed some user repo things wich f00ked my system up big time.

Offline

#5 2005-01-31 21:56:32

shadowhand
Member
From: MN, USA
Registered: 2004-02-19
Posts: 1,142
Website

Re: xfce 4.2

You have to log out and log back in to reset the sudo settings. Make sure you not only add your user to the sudoers, but edit the configuration as well to allow the shutdown. RTM, it will help.


·¬»· i am shadowhand, powered by webfaction

Offline

#6 2005-01-31 22:15:16

scarecrow
Member
From: Greece
Registered: 2004-11-18
Posts: 714

Re: xfce 4.2

May I guess that your initial login level is 3 (multiuser CLI)?
You must login at runlevel 5 to have "shutdown" and "reboot" available.
Just edit your /etc/inittab accordingly.


Microshaft delenda est

Offline

#7 2005-01-31 22:33:49

stonecrest
Member
From: Boulder
Registered: 2005-01-22
Posts: 1,190

Re: xfce 4.2

scarecrow wrote:

May I guess that your initial login level is 3 (multiuser CLI)?
You must login at runlevel 5 to have "shutdown" and "reboot" available.
Just edit your /etc/inittab accordingly.

THat's not true, I login at level 3 and it works fine for me.


I am a gated community.

Offline

#8 2005-01-31 23:18:51

scarecrow
Member
From: Greece
Registered: 2004-11-18
Posts: 714

Re: xfce 4.2

I guess you mean the suggested "sudo /opt/xfce4/libexec/xfsm-shutdown-helper" thing, and not changing permissions to xfsm-shutdown-helper which is risky (a remote user can shutdown the system). Well, it doesn't work here when I login to both KDE and XFCE4 from init 3.
Maybe you also need to allow "halt" to be executed by the user as well?


Microshaft delenda est

Offline

#9 2005-02-02 15:02:30

Hippuh
Member
Registered: 2005-01-30
Posts: 22

Re: xfce 4.2

i dont know why but it seems its something with KDM i switched to using GDM and it works all of a sudden.

Offline

#10 2005-02-03 03:31:07

aCoder
Member
From: Medina, OH
Registered: 2004-03-07
Posts: 359
Website

Re: xfce 4.2

For the shutdown menu with the logo to appear in KDE, use of KDM is required, (to the best of my knowledge).  However XFCE 4.2 should display a menu as long as sudo is setup properly.  I have a line like this in sudoers:

<username>  ALL=(ALL)   NOPASSWD: ALL

For kicks, this can be done in GNOME by setting /sbin/halt to run as root, making a directory called /var/run(or lock may work as well)/console, entering that directory, as root, and using 'touch <username>' to create an empty file named after the user, (What an honor! wink ).

EDIT:  Also, I don't have any of the KDE/GNOME stuff setup right now, so just setting up sudo is working fine for me.  I boot into runlevel 3 and use startx to exec startxfce4.


If you develop an ear for sounds that are musical it is like developing an ego. You begin to refuse sounds that are not musical and that way cut yourself off from a good deal of experience.
  - John Cage

Offline

#11 2005-02-03 16:10:35

skoal
Member
From: Frequent Flyer Underworld
Registered: 2004-03-23
Posts: 612
Website

Re: xfce 4.2

Yeah, I had that same problem Hippuh.  Do what acoder says.  The XFCE documentation isn't correct, or at least only partially right.

The thing that fixed it for me was adding the "NOPASSWD" option, using "visudo" add the following:

<user> <host> = NOPASSWD: /opt/xfce4/libexec/xfsm-shutdown-helper

That's the only thing I had to add to get it working properly.  I don't know much about "sudo", but this line only affects the XFCE problem you are having.

Offline

Board footer

Powered by FluxBB