You are not logged in.

#1 2009-11-09 08:22:45

kaivalagi
Member
From: Norwich, UK
Registered: 2009-11-05
Posts: 145

[SOLVED] conky-lua build fails due to toluapp package issues

I am trying to install conky-lua from AUR on 64 bit Arch and failing miserably.

When running the following:

yaourt -Sy conky-lua

I get the following error:

/usr/bin/ld: /usr/lib/gcc/x86_64-unknown-linux-gnu/4.4.2/../../../../lib/libtolua++.a(tolua_is.o): relocation R_X86_64_32S against `.rodata.str1.1' can not be used when making a shared object; recompile with -fPIC
/usr/lib/gcc/x86_64-unknown-linux-gnu/4.4.2/../../../../lib/libtolua++.a: could not read symbols: Bad value
collect2: ld returned 1 exit status
make[1]: *** [libcairo.la] Error 1
make[1]: Leaving directory `/tmp/yaourt-tmp-mark/aur-conky-lua/conky-lua/src/conky-1.7.2/lua'
make: *** [all-recursive] Error 1
==> ERROR: Build Failed.
    Aborting...
Error: Makepkg was unable to build conky-lua package.

I have read through what search results I can find on the topic (both here and via google) and have attempted to remedy the situation by adding build options to the toluapp build to provide for the conky-lua build. I have tried this by adding CCFLAGS = '-fPIC' to the scons call in the PKGBUILD file, I have also tried editing the config_linux.py file, which sits along side the main build file, to include the -fPIC switch also, which doesn't work either. i.e. I have this in the config_linux.py now:

CCFLAGS = ['-O2', '-ansi', '-Wall', '-fPIC']

Which doesn't work, it results in:

==> Validating source files with md5sums...
    tolua++-1.0.93.tar.bz2 ... Passed
    config_linux.py ... FAILED
==> ERROR: One or more files did not pass the validity check!
Error: Makepkg was unable to build toluapp package.

Can someone help me through a build as I have never come across scons before and maybe I am providing directives to the toluapp build incorrectly? I am still thinking in "make" terms...

I NEED lua in conky smile

Thanks in advance

Regards,
Kaivalagi

Last edited by kaivalagi (2009-11-11 07:32:04)


Running Arch 64 (Made the switch to Arch 10/2009)
AUR | BZR

Offline

#2 2009-11-10 08:31:52

kaivalagi
Member
From: Norwich, UK
Registered: 2009-11-05
Posts: 145

Re: [SOLVED] conky-lua build fails due to toluapp package issues

Can anyone shed any light on this?


Running Arch 64 (Made the switch to Arch 10/2009)
AUR | BZR

Offline

#3 2009-11-10 21:41:14

kaivalagi
Member
From: Norwich, UK
Registered: 2009-11-05
Posts: 145

Re: [SOLVED] conky-lua build fails due to toluapp package issues

I went on a wild goose chase, the issue (if I had read the errors properly!!!) was that I also needed to change the md5 checksum value in the PKGBUILD file to allow the build with -fPIC options...I just successfully built tolua++ and conky with lua based on changes to the config_linux.py as described elsewhere. I thought I was going crazy there - I am always learning with Arch...sometimes too bloody slowly

I wont make that mistake again, just a different one...


Running Arch 64 (Made the switch to Arch 10/2009)
AUR | BZR

Offline

#4 2009-11-10 22:12:01

kaivalagi
Member
From: Norwich, UK
Registered: 2009-11-05
Posts: 145

Re: [SOLVED] conky-lua build fails due to toluapp package issues

How the heck do I mark a topic as solved???


Running Arch 64 (Made the switch to Arch 10/2009)
AUR | BZR

Offline

#5 2009-11-11 00:01:08

skottish
Forum Fellow
From: Here
Registered: 2006-06-16
Posts: 7,931

Re: [SOLVED] conky-lua build fails due to toluapp package issues

kaivalagi wrote:

How the heck do I mark a topic as solved???

You can append [SOLVED] on the end of the title by editing the opening post. And please use the edit function instead of bumping your own posts. The first bump was fine because it was a day later. The last few could have been kept in the same post.

Offline

#6 2009-11-28 09:44:51

kaivalagi
Member
From: Norwich, UK
Registered: 2009-11-05
Posts: 145

Re: [SOLVED] conky-lua build fails due to toluapp package issues

I was asked by email on what exactly I did to get conky-lua installed and working on 64bit Arch, so I thought I would post my reply below in case it is of help to anyone else. Cheers

-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Run "yaourt -S conky-lua". Amongst other things this will try to install a dependancy which you need to mess about with, the package you need to edit is "toluapp".
When the "toluapp" package is downloaded by yaourt answer y to the edit question and provide something like gedit or kate as the editor to use
You'll now see the PKGBUILD file in the editor, this doesn't need editing just yet. But if you open file from the editor you'll see the directory thie PKGBUILD is in, and you want to edit the config_linux.py file you'll see there.

You should see this line in the config_linux.py file:

    CCFLAGS = ['-O2', '-ansi', '-Wall']

Change it so it is like this:

    CCFLAGS = ['-O2', '-ansi', '-Wall', '-fPIC']

Now, back to the PKGBUILD file, you'll see this line:

    md5sums=('100aa6907b8108582080b37d79c0afd7' 'bab107cdd2d18d3453a2344341b77c45')

These checksums line up with tarball and config_linux.py files, and this will stop you're edit from working if not amended because the .py file isn't what it should be, we changed it. So run md5sum against the .py file and update the second checksum in the line appropriately.

Carry on with the package installation and conky should have lua support smile

Last edited by kaivalagi (2010-01-14 08:50:55)


Running Arch 64 (Made the switch to Arch 10/2009)
AUR | BZR

Offline

#7 2009-12-12 13:38:40

na12
Member
From: /home/serbia
Registered: 2008-12-23
Posts: 749

Re: [SOLVED] conky-lua build fails due to toluapp package issues

Thank you very much

Offline

#8 2009-12-12 15:48:24

kaivalagi
Member
From: Norwich, UK
Registered: 2009-11-05
Posts: 145

Re: [SOLVED] conky-lua build fails due to toluapp package issues

na12 wrote:

Thank you very much

As always, glad to be of help smile


Running Arch 64 (Made the switch to Arch 10/2009)
AUR | BZR

Offline

#9 2010-01-14 06:19:01

I.M.O.G.
Member
Registered: 2009-10-16
Posts: 16

Re: [SOLVED] conky-lua build fails due to toluapp package issues

Thanks again, your post is still coming in useful, glad you updated with the email details. smile

Offline

#10 2010-01-14 08:51:36

kaivalagi
Member
From: Norwich, UK
Registered: 2009-11-05
Posts: 145

Re: [SOLVED] conky-lua build fails due to toluapp package issues

I.M.O.G. wrote:

Thanks again, your post is still coming in useful, glad you updated with the email details. smile

The package still isn't fixed for 64 bit after a release, I think I need to raise the issue with the author maybe...


Running Arch 64 (Made the switch to Arch 10/2009)
AUR | BZR

Offline

#11 2012-07-26 13:31:22

DoubleU
Member
Registered: 2012-07-26
Posts: 3

Re: [SOLVED] conky-lua build fails due to toluapp package issues

Ok I changed the PKGBUILD and the config_linux.py as above. But the following failure appears at the compilation:

/usr/bin/ld: cannot find -llua50
/usr/bin/ld: cannot find -llualib50
collect2: error: ld returned 1 exit status
scons: *** [bin/tolua++_bootstrap] Error 1
scons: building terminated because of errors.

Regards DoubleU

Offline

#12 2012-07-26 14:14:46

DoubleU
Member
Registered: 2012-07-26
Posts: 3

Re: [SOLVED] conky-lua build fails due to toluapp package issues

Hello I have retried and it worked.

Offline

#13 2012-07-26 15:28:59

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 13,432

Re: [SOLVED] conky-lua build fails due to toluapp package issues

DoubleU wrote:

Hello I have retried and it worked.

I checked the AUR, there are no comments since May.  You might consider posting your updated PKGBUILD, and what you did to allow it to compile.


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
You assume people are rational and influenced by evidence.  You must not work with the public much. -- Trilby
----
How to Ask Questions the Smart Way

Offline

#14 2016-01-06 10:12:52

hypothetical
Member
Registered: 2015-12-20
Posts: 6

Re: [SOLVED] conky-lua build fails due to toluapp package issues

kaivalagi wrote:

...You should see this line in the config_linux.py file...

Hi, I know this is a bit too late, but I have the same problem installing conky-lua, except I have no clue where to find the config_linux.py file. I would appreciate it if you could shed some light on this..
TIA,
Regards

Offline

#15 2016-01-06 20:55:05

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 5,550

Re: [SOLVED] conky-lua build fails due to toluapp package issues

Please open a new topic about your issue, and link back to this one if you feel it is still relevant.

https://wiki.archlinux.org/index.php/Fo … bumping.22

Closing.


Sakura:-
Mobo: ASUS P8Z77-V PRO // Processor: Intel Core i7-3770K 3.4GHz // GFX: nVidia GeForce GTX 970 Ti // RAM: 32GB (4x 8GB) Corsair DDR3 (@ 2133MHz) // Storage: 1x 3TB Seagate SATAII 5x 1TB Samsung SATAII, 2x 120GB Corsair SSD

Offline

Board footer

Powered by FluxBB