You are not logged in.

#1 2009-08-22 05:20:58

MartinZ
Member
From: Chiloé, Chile
Registered: 2005-06-10
Posts: 374

Compiz slow startup

First of all, sorry if asked before. I've found many threads about this, but none of them gave a successful solution.

I configured Gnome with compiz as suggested in the wiki (the "without icon" option) and it works pretty good, but the interface has a delay of about 10 seconds without visual activity (I mean, the HD led stays off) which doesn't happen without compiz. If I take the "with icon" option, Gnome loads faster but then it takes some time to load compiz over metacity, ending in a similar time.

This is what I got from de X log:

X.Org X Server 1.6.3
Release Date: 2009-7-31
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.30-ARCH x86_64 
Current Operating System: Linux cerdo 2.6.30-ice #1 SMP Sat Aug 1 11:02:25 CLT 2009 x86_64
Build Date: 01 August 2009  07:32:01PM
 
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Aug  3 01:52:12 2009
(==) Using config file: "/etc/X11/xorg.conf"
gnome-session[14474]: EggSMClient-WARNING: Invalid Version string '0.9.4' in /home/martin/.config/autostart/Daemons.desktop
gnome-session[14474]: EggSMClient-WARNING: Invalid Version string '0.9.4' in /home/martin/.config/autostart/Blueman.desktop
gnome-session[14474]: EggSMClient-WARNING: Invalid Version string '0.9.4' in /home/martin/.config/autostart/Guake.desktop

(gtk-window-decorator:14507): GLib-WARNING **: GError set over the top of a previous GError or uninitialized memory.
This indicates a bug in someone's code. You must ensure an error is NULL before it's set.
The overwriting error message was: Line 68 character 64: Could not parse "shade/gtk:bg[NORMAL]/0.84" as an integer

(gtk-window-decorator:14507): GLib-WARNING **: GError set over the top of a previous GError or uninitialized memory.
This indicates a bug in someone's code. You must ensure an error is NULL before it's set.
The overwriting error message was: Line 69 character 66: Could not parse "shade/gtk:bg[NORMAL]/0.80" as an integer

(gtk-window-decorator:14507): GLib-WARNING **: GError set over the top of a previous GError or uninitialized memory.
This indicates a bug in someone's code. You must ensure an error is NULL before it's set.
The overwriting error message was: Line 70 character 67: Could not parse "shade/gtk:bg[NORMAL]/0.78" as an integer

(gtk-window-decorator:14507): GLib-WARNING **: GError set over the top of a previous GError or uninitialized memory.
This indicates a bug in someone's code. You must ensure an error is NULL before it's set.
The overwriting error message was: Line 71 character 60: Could not parse "shade/gtk:bg[NORMAL]/0.88" as an integer

(gtk-window-decorator:14507): GLib-WARNING **: GError set over the top of a previous GError or uninitialized memory.
This indicates a bug in someone's code. You must ensure an error is NULL before it's set.
The overwriting error message was: Line 72 character 63: Could not parse "shade/gtk:bg[NORMAL]/1.12" as an integer

(gtk-window-decorator:14507): GLib-WARNING **: GError set over the top of a previous GError or uninitialized memory.
This indicates a bug in someone's code. You must ensure an error is NULL before it's set.
The overwriting error message was: Line 73 character 60: Could not parse "shade/gtk:bg[NORMAL]/0.56" as an integer

(gtk-window-decorator:14507): GLib-WARNING **: GError set over the top of a previous GError or uninitialized memory.
This indicates a bug in someone's code. You must ensure an error is NULL before it's set.
The overwriting error message was: Line 75 character 66: Could not parse "shade/gtk:bg[NORMAL]/0.76" as an integer

(gtk-window-decorator:14507): GLib-WARNING **: GError set over the top of a previous GError or uninitialized memory.
This indicates a bug in someone's code. You must ensure an error is NULL before it's set.
The overwriting error message was: Line 76 character 64: Could not parse "shade/gtk:bg[NORMAL]/0.81" as an integer
gnome-session[14474]: WARNING: Application 'compiz.desktop' failed to register before timeout
Unable to open desktop file evolution.desktop for panel launcher
** Message: Initializing gksu extension...

(Do:14971): Wnck-CRITICAL **: wnck_set_client_type got called multiple times.


(Do:14971): Gdk-CRITICAL **: gdk_x11_atom_to_xatom_for_display: assertion `atom != GDK_NONE' failed

** (nautilus:14952): WARNING **: Unable to add monitor: Not supported

** (nautilus:14952): WARNING **: Unable to add monitor: Not supported
Conky: forked to background, pid is 15302

Conky: desktop window (1400073) is subwindow of root window (13c)
Conky: window type - override
Conky: drawing to created window (0x3800001)
Conky: drawing to double buffer
Conky: MPD error: host "cerdo" not found: Name or service not known

Conky: MPD error: host "cerdo" not found: Name or service not known

Conky: MPD error: host "cerdo" not found: Name or service not known

/bin/stty: standard input: Inappropriate ioctl for device
/bin/stty: standard input: Inappropriate ioctl for device
/bin/stty: standard input: Inappropriate ioctl for device
/bin/stty: standard input: Inappropriate ioctl for device
/etc/rc.d/mpd: line 6: 15553 Aborted                 /usr/bin/mpd /etc/mpd.conf &>/dev/null
/bin/stty: standard input: Inappropriate ioctl for device
/bin/stty: standard input: Inappropriate ioctl for device
/bin/stty: standard input: Inappropriate ioctl for device
/bin/stty: standard input: Inappropriate ioctl for device
ERROR: ld.so: object 'libjvm.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libawt.so' from LD_PRELOAD cannot be preloaded: ignored.

(nautilus:14952): Eel-WARNING **: "nautilus-metafile.c: metafiles" hash table still has 2 elements at quit time (keys above)

(nautilus:14952): Eel-WARNING **: "nautilus-directory.c: directories" hash table still has 2 elements at quit time
X Error of failed request:  BadDamage (invalid Damage parameter)
  Major opcode of failed request:  156 (DAMAGE)
  Minor opcode of failed request:  3 (XDamageSubtract)
  Serial number of failed request:  50995
  Current serial number in output stream:  50996
Exception in Gtk# callback delegate
  Note: Applications can use GLib.ExceptionManager.UnhandledException to handle the exception.
System.NullReferenceException: Object reference not set to an instance of an object
  at Docky.Interface.AbstractDockItem..ctor () [0x00000] 
  at Docky.Interface.WnckDockItem..ctor () [0x00000] 
  at Docky.Interface.ApplicationDockItem..ctor (IEnumerable`1 windows) [0x00000] 
  at Docky.Core.Default.ItemsService.CreateApplicationDockItem (IEnumerable`1 windows, IEnumerable`1 lastSet) [0x00000] 
  at Docky.Core.Default.ItemsService+<UpdateTaskItems>c__AnonStorey9.<>m__16 (IGrouping`2 ws) [0x00000] 
  at System.Linq.Enumerable+<CreateSelectIterator>c__Iterator10`2[System.Linq.IGrouping`2[System.String,Wnck.Window],Docky.Interface.ApplicationDockItem].MoveNext () [0x00000] 
  at System.Linq.EnumerableExtensions.ForEach[ApplicationDockItem] (IEnumerable`1 self, System.Action`1 action) [0x00000] 
  at Docky.Core.Default.ItemsService.UpdateTaskItems () [0x00000] 
  at Docky.Core.Default.ItemsService.UpdateItems () [0x00000] 
  at Docky.Core.Default.ItemsService.<DelayUpdateItems>m__6 () [0x00000] 
  at GLib.Timeout+TimeoutProxy.Handler () [0x00000] 
   at GLib.ExceptionManager.RaiseUnhandledException(System.Exception e, Boolean is_terminal)
   at GLib.Timeout+TimeoutProxy.Handler()
   at Gtk.Application.gtk_main()
   at Gtk.Application.Run()
   at Do.Do.Main(System.String[] args)

waiting for X server to shut down ** Message: Got disconnected from the session message bus; retrying to reconnect every 10 seconds
blueman-applet: Fatal IO error 104 (Connection reset by peer) on X server :0.0.
gtk-window-decorator: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
gnome-screensaver: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
gnome-settings-daemon: Fatal IO error 104 (Connection reset by peer) on X server :0.0.
.

I'm stuck with this and would really appreciate some help. I own a MSI MS-1651 laptop with a Nvidia 9600M GT graphic card and tried both stable and beta nvidia drivers with similar results.

Thanks in advance.


All your base are belong to us

Offline

#2 2009-08-26 02:03:38

MartinZ
Member
From: Chiloé, Chile
Registered: 2005-06-10
Posts: 374

Re: Compiz slow startup

Bump


All your base are belong to us

Offline

#3 2009-08-29 10:18:39

keizer
Member
Registered: 2009-08-29
Posts: 10

Re: Compiz slow startup

I have observed the same problem (gdm+gnome+compiz). There is approximately a 10 sec inactivity after the GDM login screen before compiz loads. Any help would be appreciated.

Last edited by keizer (2009-08-29 10:19:09)

Offline

#4 2009-08-29 11:24:46

ngoonee
Forum Fellow
From: Between Thailand and Singapore
Registered: 2009-03-17
Posts: 6,772

Re: Compiz slow startup

I believe this to be the case with Ubuntu as well?

Try SLIM, its in the wiki, to see if its a gdm problem. 10 seconds sounds like an enforced sleep to me, though...


Allan-Volunteer on the (topic being discussed) mailn lists. You never get the people who matters attention on the forums.
jasonwryan-Installing Arch is a measure of your literacy. Maintaining Arch is a measure of your diligence. Contributing to Arch is a measure of your competence.
Griemak-Bleeding edge, not bleeding flat. Edge denotes falls will occur from time to time. Bring your own parachute.

Offline

#5 2009-08-29 13:52:41

anstmich
Member
Registered: 2009-06-20
Posts: 29

Re: Compiz slow startup

Are you using gnome-do?  I have found that, for some reason, when both gnome-do and compiz are set to load at startup, logging in takes forever.  Try disabling it and see if that helps.

Offline

#6 2009-08-29 15:05:22

keizer
Member
Registered: 2009-08-29
Posts: 10

Re: Compiz slow startup

I'm not using gnome-do. You are right ngoonee, the same problem occurs on Ubuntu as well. There is a bug report at:
https://bugs.launchpad.net/ubuntu/+sour … bug/284366
Unfortunately I could not find a solution on the web? Any ideas?

Offline

#7 2009-08-29 17:08:41

MartinZ
Member
From: Chiloé, Chile
Registered: 2005-06-10
Posts: 374

Re: Compiz slow startup

It happens both when logging through gdm and directly with startx. I do use gnome-do, but it loads later (I created a script with a sleep command to invoke the apps which I dont need early at startup).

I've found that loading metacity first and the fusion-icon later is faster than running compiz directly. There are many threads about this in many distributions, but none of them (at least the ones I've found) show a solution.

This is really annoying, do everyone running gnome + compiz have the same problem? Maybe is it related to nvidia driver?


All your base are belong to us

Offline

#8 2009-08-29 20:51:32

hash
Member
From: Poland
Registered: 2008-07-31
Posts: 109

Re: Compiz slow startup

I've noticed the same thing in KDM + KDE 4.3 + compiz

Last edited by hash (2009-08-29 21:03:55)

Offline

#9 2009-08-30 06:00:37

MartinZ
Member
From: Chiloé, Chile
Registered: 2005-06-10
Posts: 374

Re: Compiz slow startup

I used Xfce before and never minded about load time because... well, Xfce loads too fast. But I 'think' it had the same issue. So, it must be an isolated compiz bug? I'm not sure about this, because I remember someone who told he didn't get that delay using compiz as stand alone window manager; I just dont remember where.

@ hash: Why do you use compiz with KDE4? It comes by default with a very good compiz-like window manager, doesn't it?


All your base are belong to us

Offline

#10 2009-08-30 07:33:56

hash
Member
From: Poland
Registered: 2008-07-31
Posts: 109

Re: Compiz slow startup

For me KWin in KDE is still choppy and laggy compared to compiz.

Offline

#11 2009-08-30 12:49:36

eldragon
Member
From: Buenos Aires
Registered: 2008-11-18
Posts: 1,026

Re: Compiz slow startup

hmmm, im using intel gma 945, compiz + gdm + gnome and i have this issue..

removing gnome-do does not fix it.

ive noticed this too and never tried to fix it since i usually suspend the laptop when not in use.

Offline

#12 2009-09-01 00:22:36

MartinZ
Member
From: Chiloé, Chile
Registered: 2005-06-10
Posts: 374

Re: Compiz slow startup

Since this seems more like a compiz problem I posted it in compiz forum:

http://forum.compiz-fusion.org/showthre … #post75062


All your base are belong to us

Offline

#13 2009-09-03 20:35:14

Sander Hoksbergen
Member
Registered: 2009-01-06
Posts: 32

Re: Compiz slow startup

I've got the same problem. Will post something as soon as I've fixed it...I'll resort to jumping into the sourcecode if I have to.

Offline

#14 2009-09-06 13:05:28

markg85
Member
Registered: 2009-06-27
Posts: 126

Re: Compiz slow startup

And i'm having the same issue here.
Guess time to profile some things since the bug report on ubuntu isn't helpful and the report on compiz did't even got one reply.

I will post here if i find anything.

Results so far:

No.1
when looking in /var/log/messages i see:

Sep  6 15:07:07 Mark-Arch gnome-session[2808]: WARNING: Application 'compiz.desktop' failed to register before timeout

No.2
In gnome-session there is a hard timeout happening when the error of No.1 occurs. You can find those in the source of gnome-session in the file gsm-manager.c then just search. I tried disabling the timeout completely and compiled and tested it but sadly it doesn't work that easy. Gnome seems to go nuts when that's being done so i had to revert my changes.

So, first it wasn't clear what caused the timeout, now that's found out. the timeout is caused by gnome-session (actually the define: GSM_MANAGER_PHASE_TIMEOUT is setting 10 (SECONDS)) so every timeout error like in No.1 will add 10 seconds to gnome's startup. The actual "bug" is probably somewhere in compiz..?..?

Last edited by markg85 (2009-09-06 14:03:55)

Offline

#15 2009-09-07 02:10:17

Slack
Member
From: Chile
Registered: 2008-10-27
Posts: 52

Re: Compiz slow startup

I had a similar problem with my intel video card, but, when KMS is enabled, the problem is gone.


Excuse my poor english

Offline

#16 2009-09-07 16:10:08

markg85
Member
Registered: 2009-06-27
Posts: 126

Re: Compiz slow startup

Slack wrote:

I had a similar problem with my intel video card, but, when KMS is enabled, the problem is gone.

That won't help others that either don't want to use kms or don't have a intel gpu or both.
The issue __seems__ to be in compiz although it's Gnome that's causing a forces 10 second delay.

Offline

#17 2009-09-07 16:19:26

eldragon
Member
From: Buenos Aires
Registered: 2008-11-18
Posts: 1,026

Re: Compiz slow startup

actually, thats not my case, i use KMS under intel gma945 and the problem is there...i just focused on making suspend a bit more reliable wink

Offline

#18 2009-10-08 09:36:36

Stunts
Member
From: Portugal
Registered: 2009-03-28
Posts: 294
Website

Re: Compiz slow startup

This seems to have been solved on Ubuntu Karmic.
(https://bugs.launchpad.net/ubuntu/+sour … bug/284366)
Does anyone know how?
Nobody in the compiz forums seems to have replied, despite the two bumps.

Offline

#19 2009-10-08 20:32:46

shae
Member
Registered: 2009-06-20
Posts: 2
Website

Re: Compiz slow startup

Stunts wrote:

This seems to have been solved on Ubuntu Karmic.
(https://bugs.launchpad.net/ubuntu/+sour … bug/284366)
Does anyone know how?
Nobody in the compiz forums seems to have replied, despite the two bumps.

Maybe it was fixed by the changes to Gnome Session and GDM in Gnome 2.28?  They did not seem to do anything to actually "fix" it so this is what I suspect.  Is anyone who has this problem using Gnome testing or is everyone using Gnome 2.26?

Offline

#20 2009-10-15 01:00:45

MartinZ
Member
From: Chiloé, Chile
Registered: 2005-06-10
Posts: 374

Re: Compiz slow startup

The problem doesn't seem fixed here with 2.28


All your base are belong to us

Offline

#21 2009-10-15 07:59:20

Stunts
Member
From: Portugal
Registered: 2009-03-28
Posts: 294
Website

Re: Compiz slow startup

It also seems not to have been fixed here.
How do you start compiz in your config?
In here I have in gconf /desktop/gnome/session/required_components/windowsmanager = (empty field)
I start compiz by inserting fusion-icon in the startup applications.
I will try to mess with these options and see if I can get anywhere.

Offline

#22 2009-10-24 07:39:25

knopper92
Member
From: British Columbia, Canada
Registered: 2009-05-14
Posts: 40

Re: Compiz slow startup

If anyone is interested in a workaround:

Switch the gconf windowmanager key back to metacity
Add "compiz --replace" to your list of startup applications

Pretty much solves the entire problem.

Offline

#23 2009-10-26 23:06:29

MartinZ
Member
From: Chiloé, Chile
Registered: 2005-06-10
Posts: 374

Re: Compiz slow startup

Not the best solution, but it does, indeed, speedup gnome's load. Thanks.


All your base are belong to us

Offline

#24 2009-10-27 11:29:27

Stunts
Member
From: Portugal
Registered: 2009-03-28
Posts: 294
Website

Re: Compiz slow startup

Hardly any effect here...
I had tried that before, but the difference it makes on my system is of about 1 sec. I must say that I am using the fantastic "Readahead" for speeding up boot, and the the times both were counted after reprofiling readahead.

Offline

#25 2009-11-13 13:01:47

Tes--
Member
Registered: 2009-11-13
Posts: 42

Re: Compiz slow startup

For some reason compiz does not register with the session-manager if you don't explicitly pass is the session id.

To solve that, use a wrapper, or in /usr/share/applications/compiz.desktop change the exec line to

Exec=bash -c 'compiz ccp decoration --sm-client-id $DESKTOP_AUTOSTART_ID'

Offline

Board footer

Powered by FluxBB