You are not logged in.

#1 2009-11-20 06:29:41

Murray_B
Member
From: Germany
Registered: 2008-07-29
Posts: 130

Wrong keyboard layout used by autotype of synergy and keepassx

Hi there!

I have a real strange problem. I am a german user with german keyboard layout and everything works fine - except of autotyping apps like keepassx and synergy. Both are applications which type for you and behave like they are typing on a us-international keyboard since xorg 1.7.
Example: I want to login with keepass into this forum (it's a passwordmanager) and tell it to autotype my loginname and password. As you see I have "Murray_B" as a login. "Murray_B" is stored in the database and worked perfectly for months. Since xorg 1.7 it types "Murraz/B", that's the thing I would get if I would type wit us-international-layout, which is surely the default keyboard-layout somewhere.

First I thought it is a keepassx-problem, but then I had the same with synergy, if I type on a "remote" computer, I am typing like I have an us-keyboard... Both computers have a current archlinux installed.

I changed from a statix xorg.conf to autoconfiguration but nothing changed. That's my xorg.conf at the moment:

    Section "Device"
        Identifier    "nvidiacard"
        Driver    "nvidia"
    EndSection
    Section "Screen"
        Identifier    "screen0"
        Device    "nvidiacard"
    EndSection
    Section "ServerLayout"
        Identifier    "Builtin Default Layout"
        Screen    "screen0"
    EndSection

And that's my /etc/hal/fdi/policy/10-keymap.fdi:

<?xml version="1.0" encoding="ISO-8859-1"?> <!-- -*- SGML -*- -->
<deviceinfo version="0.2">
  <device>
    <match key="info.capabilities" contains="input.keymap">
      <append key="info.callouts.add" type="strlist">hal-setup-keymap</append>
    </match>

    <match key="info.capabilities" contains="input.keys">
      <merge key="input.xkb.rules" type="string">base</merge>

      <!-- If we're using Linux, we use evdev by default (falling back to
           keyboard otherwise). -->
      <merge key="input.xkb.model" type="string">keyboard</merge>
      <match key="/org/freedesktop/Hal/devices/computer:system.kernel.name"
             string="Linux">
        <merge key="input.xkb.model" type="string">evdev</merge>
      </match>

      <merge key="input.xkb.layout" type="string">de</merge>
      <merge key="input.xkb.variant" type="string">nodeadkeys</merge>
    </match>
  </device>
</deviceinfo>

Anyone an idea, where I can correct that?

Thanks in advance,

Thomas

Offline

#2 2009-11-21 07:57:40

Murray_B
Member
From: Germany
Registered: 2008-07-29
Posts: 130

Re: Wrong keyboard layout used by autotype of synergy and keepassx

Okay, problem ist partially solved, I need an extra "setxkbmap de" after login to make it work. It seems like the normal x11-setup doesn't set the layout completely. I don't know why, maybe it's an xorg-bug? Comments are welcome...

Offline

#3 2009-11-21 09:04:01

kevku
Member
From: Estonia
Registered: 2009-11-21
Posts: 67

Re: Wrong keyboard layout used by autotype of synergy and keepassx

I have the same problem as you, I use hal to set the keyboard layout for xorg but when i use XTestFakeKeyEvent to generate key events it uses the us keyboard layout. and extra setxkbmap ee fixes it, but it sure is annoying. so it must be a bug in xorg.

Offline

#4 2009-11-21 14:11:20

.:B:.
Forum Fellow
Registered: 2006-11-26
Posts: 5,819
Website

Re: Wrong keyboard layout used by autotype of synergy and keepassx

I have a similar problem during login - my bluetooth keyboard will do QWERTY while the built-in laptop keyboard does AZERTY as it's supposed to do. Once I log into X though, the bluetooth keyboard switches to AZERTY...  Not' sure what's going on.

Note: not plugging my topic, merely pointing out I have something fishy going on too smile.


Got Leenucks? :: Arch: Power in simplicity :: Get Counted! Registered Linux User #392717 :: Blog thingy

Offline

#5 2009-11-23 14:21:15

Tapi
Member
From: France
Registered: 2007-02-12
Posts: 5

Re: Wrong keyboard layout used by autotype of synergy and keepassx

Same problem here with keepassx 0.4.1-1, xorg-server 1.7.1.901-2 and hal 0.5.13-3. Calling setxkbmap solves the problem too.

Offline

Board footer

Powered by FluxBB