You are not logged in.

#1 2005-02-07 20:08:41

syamajala
Member
From: here, there, everywhere
Registered: 2005-01-25
Posts: 604
Website

Xorg + nvidia = 640x480

When I use the nvidia driver I only get 640x480, but when i use the nv driver i get 1024x768. Here is my xorg.conf

Section "ServerLayout"
        Identifier     "X.org Configured"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
        RgbPath      "/usr/X11R6/lib/X11/rgb"
        ModulePath   "/usr/X11R6/lib/modules"
        FontPath     "/usr/X11R6/lib/X11/fonts/misc/"
        FontPath     "/usr/X11R6/lib/X11/fonts/TTF/"
        FontPath     "/usr/X11R6/lib/X11/fonts/Type1/"
        FontPath     "/usr/X11R6/lib/X11/fonts/CID/"
        FontPath     "/usr/X11R6/lib/X11/fonts/75dpi/"
        FontPath     "/usr/X11R6/lib/X11/fonts/100dpi/"
EndSection

Section "Module"
        Load  "extmod"
        Load  "glx"
        Load  "dri"
        Load  "dbe"
        Load  "record"
        Load  "xtrap"
        Load  "type1"
        Load  "freetype"
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
EndSection

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "auto"
        Option      "Device" "/dev/input/mouse0"
EndSection

Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "SWcursor"                  # [<bool>]
        #Option     "HWcursor"                  # [<bool>]
        #Option     "NoAccel"                   # [<bool>]
        #Option     "ShadowFB"                  # [<bool>]
        #Option     "UseFBDev"                  # [<bool>]
        #Option     "Rotate"                    # [<str>]
        #Option     "VideoKey"                  # <i>
        #Option     "FlatPanel"                 # [<bool>]
        #Option     "FPDither"                  # [<bool>]
        #Option     "CrtcNumber"                # <i>
        Identifier  "Card0"
        Driver      "nv"
        VendorName  "nVidia Corporation"
        BoardName   "NV31 [GeForce FX 5600]"
        BusID       "PCI:1:0:0"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "Monitor0"
        DefaultDepth 24
        SubSection "Display"
                Viewport   0 0
                Depth     16
                Modes "1024x768" "800x600"
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     24
                Modes "1024x768" "800x600"
        EndSubSection
EndSection

Offline

#2 2005-02-07 20:38:34

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,261

Re: Xorg + nvidia = 640x480

for nvidia driver please disable dri!
and you could also try to disable your BUSID line and
perhpas try using 16bit

Offline

#3 2005-02-07 21:12:35

syamajala
Member
From: here, there, everywhere
Registered: 2005-01-25
Posts: 604
Website

Re: Xorg + nvidia = 640x480

Just tried that stuff, still doesn't work. I was wondering if I am using the right driver. I have an amd64.

Offline

#4 2005-02-07 23:50:19

SleepyDog
Member
Registered: 2004-10-15
Posts: 114

Re: Xorg + nvidia = 640x480

Make sure your hsync and vertrefresh are accurate. That fixed it for me.

Also, run xorgcfg, the one that sets variables automatically, and see if it gives you a higher resolution. Then you can start pulling stuff from the config it creates.

Offline

#5 2005-02-08 00:12:19

syamajala
Member
From: here, there, everywhere
Registered: 2005-01-25
Posts: 604
Website

Re: Xorg + nvidia = 640x480

SleepyDog thanks! that fixed it for me too. I just used the config i already had but set the horizsync and vertrefresh stuff. Now on to twinview!

Offline

#6 2005-02-08 14:57:45

xerverius
Member
From: ~
Registered: 2004-11-02
Posts: 230
Website

Re: Xorg + nvidia = 640x480

maybe the driver was wrong, it thought is must be: Driver "nvidia", but well it works now big_smile

Offline

#7 2005-02-08 20:45:48

syamajala
Member
From: here, there, everywhere
Registered: 2005-01-25
Posts: 604
Website

Re: Xorg + nvidia = 640x480

xerverius: The problem was when i was using nvidia it the resolution would be 640x480 but when i was using nv it would give me 1024x768 but now i got it to work with the nvidia driver, so i get 1024x768

Offline

#8 2005-02-10 01:56:29

xjedi
Member
From: root
Registered: 2005-02-01
Posts: 17

Re: Xorg + nvidia = 640x480

how did you get it to work ? im having the same problem. Thanx

Offline

#9 2005-02-10 02:07:41

syamajala
Member
From: here, there, everywhere
Registered: 2005-01-25
Posts: 604
Website

Re: Xorg + nvidia = 640x480

set the sync rates for ur monitor.

    HorizSync    30-64         # multisync
#    HorizSync    31.5, 35.2    # multiple fixed sync frequencies
#    HorizSync    15-25, 30-50  # multiple ranges of sync frequencies
    VertRefresh 50-70

be sure to replace the 30-64 and the 50-70 with whatever your monitor's rates are. Look them up online.

Offline

#10 2005-02-10 02:32:59

xjedi
Member
From: root
Registered: 2005-02-01
Posts: 17

Re: Xorg + nvidia = 640x480

Im able to get it to work fine on my pc, but im on a laptop and i  havent had any luck in finding the sync rates. When i do xorgcfg -textmode im able to see my card listed ( Geforce 420 go) and i was able to get the nvidia driver to work, but when i start x the resolution is 800x600. The laptop i have is a toshiba satelite 1415-S173. I used hdw program to create and xorg.cong file and  i was able to get resolutions 1024x768 and above but when i switch to the nvidia driver, following all the instructions, the resolution still goes to 800x600 and i cant change it at all. If anyone can help .. Thanx in advanced... sad

Offline

#11 2005-02-10 02:39:21

syamajala
Member
From: here, there, everywhere
Registered: 2005-01-25
Posts: 604
Website

Re: Xorg + nvidia = 640x480

Not sure, i've never used linux on a laptop before. if u have xfce4 u can try changing it in the display thingy. tongue

Offline

#12 2005-02-10 06:21:51

xjedi
Member
From: root
Registered: 2005-02-01
Posts: 17

Re: Xorg + nvidia = 640x480

I read on a site somewhere that i could use the IgnoreEDID option in my xorg.config file and it would work. So i tryed it and it froze X. It was just a blank screen. 

I also read that i can use nvidia module option but ive read again that  it doesnt work with older nvidia drivers. SO my questions are:

1. What does IgnoreEDID do , and how can i get it to work without making X freeze?

2. where can i download a pacman pkg of an older version of the nvidia drivers?

Offline

#13 2005-02-10 07:42:59

InfernalH
Member
From: Lithuania/Klaipeda-Vilnius
Registered: 2005-02-08
Posts: 101
Website

Re: Xorg + nvidia = 640x480

There's my xorg.con, I have Nvidia card and nvidia drivers installed, everything works just fine:

Section "Module"

# This loads the DBE extension module.
Load        "dbe"   # Double buffer extension

SubSection  "extmod"
  Option    "omit xfree86-dga"   # don't initialise the DGA extension
EndSubSection

Load        "type1"
#    Load        "speedo"
Load        "freetype"
#    Load        "xtt"

# This loads the GLX module
Load       "glx"
# This loads the DRI module
#Load       "DRI"
#Group "users"
#Mode 0660
EndSection

Section "Files"

RgbPath     "/usr/X11R6/lib/X11/rgb"
    FontPath   "/usr/X11R6/lib/X11/fonts/misc/"
    FontPath   "/usr/X11R6/lib/X11/fonts/"
    FontPath   "/usr/X11R6/lib/X11/fonts/TTF/"
    FontPath   "/usr/X11R6/lib/X11/fonts/Type1/"
    FontPath   "/usr/X11R6/lib/X11/fonts/CID/"
    FontPath   "/usr/X11R6/lib/X11/fonts/75dpi/"
    FontPath   "/usr/X11R6/lib/X11/fonts/100dpi/"
    FontPath   "/usr/X11R6/lib/X11/fonts/local/"
EndSection

Section "InputDevice"

    Identifier  "Keyboard1"
    Driver      "kbd"
    Option "AutoRepeat" "500 30"
    Option "XkbRules"   "xorg"
    Option "XkbModel"   "pc101"
    Option "XkbLayout"  "us,lt"
    Option "XkbOptions" "grp:alt_shift_toggle"

EndSection

Section "InputDevice"

# Identifier and driver
    Identifier "Mouse1"
    Driver "mouse"
    Option "Protocol" "ExplorerPS/2"
    Option "Device" "/dev/input/mice"
    Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
    Identifier  "ADI MicroScan"
    HorizSync   60-70
    VertRefresh 80-85
EndSection

# Standard VGA Device:

Section "Device"
    Identifier  "Standard VGA"
    VendorName  "Unknown"
    BoardName   "Unknown"
    Driver     "vga"
EndSection

# Device configured by xorgconfig:

Section "Device"
    Identifier  "NVIDIA card"
    Driver      "nvidia"
    # unsupported card
    #VideoRam    32768
EndSection

Section "Screen"
    Identifier  "Screen 1"
    Device      "NVIDIA card"
    Monitor     "ADI MicroScan"
    DefaultDepth 24
Subsection "Display"
        Depth       8
        Modes       "1280x1024" "1024x768" "800x600" "640x480"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth       16
        Modes       "1280x1024" "1024x768" "800x600" "640x480"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth       24
        Modes       "1280x1024" "1024x768" "800x600" "640x480"
        ViewPort    0 0
    EndSubsection
EndSection
Section "ServerLayout"

   Screen "Screen 1"
   InputDevice "Mouse1" "CorePointer"
   InputDevice "Keyboard1" "CoreKeyboard"

EndSection
    Screen "Screen 1"
    InputDevice "Mouse1" "CorePointer"
    InputDevice "Keyboard1" "CoreKeyboard"
EndSection

# Section "DRI"
#    Mode 0666
# EndSection

Offline

Board footer

Powered by FluxBB