You are not logged in.

#1 2005-02-16 00:57:54

T-Dawg
Forum Fellow
From: Wilmington, NC
Registered: 2005-01-29
Posts: 2,734

automatic mounting [solved]

I was wondering how i can get media devices especially usb flashdrives to mount and pop up a window automatically after ive inserted the media. Also, is there any way to umount and eject a cd from its drive by pushing the button on that drive rather than manually umounting and ejecting from the filemanager?
Thanks for your responses.

Offline

#2 2005-02-16 04:09:57

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: automatic mounting [solved]

pacman -S gnome-volume-manager

I don't how to configure/use it, though.

Offline

#3 2005-02-16 07:15:27

lucke
Member
From: Poland
Registered: 2004-11-30
Posts: 4,018

Re: automatic mounting [solved]

ivman (allows to configure actions upon inserting, I don't know how unmounting works there):

http://bbs.archlinux.org/viewtopic.php?t=9828&start=0

Things like autofs/submount/supermount should allow such unmounting, but they stopped working properly or didn't work at all on my box (because of udev? custom kernel? something else?).

Offline

#4 2005-02-16 07:54:02

bangkok_manouel
Member
From: indicates a starting point
Registered: 2005-02-07
Posts: 1,554

Re: automatic mounting [solved]

Hi,

You can try the duo DBUS+HAL, works perfectly w/Gnome (don't know if only Gnome related but don't think so...), you'll get the win*ows behaviour (kind of automount and so on)...

Cheers,

M


All design goals must be phrased in such a way that it is hard to use them as slogans to justify stupidity.

Offline

#5 2005-02-16 08:14:39

STiAT
Member
From: Vienna, Austria
Registered: 2004-12-23
Posts: 603

Re: automatic mounting [solved]

lucke wrote:

Things like autofs/submount/supermount should allow such unmounting, but they stopped working properly or didn't work at all on my box (because of udev? custom kernel? something else?).

I dont use a custom kernel, nor udev or anything else. Unmounting doesn't work properly here as well. It never worked, to be true.

I'd also suggest a change to ivman, it's a really great application. I didn't dare to change to ivman yet, but i'll take fist steps when i've read more about how to use it. I'll stick at devfs for some more month as well, for personal reasons (well, for libraw1394).

// STi


Ability is nothing without opportunity.

Offline

#6 2005-02-16 14:41:43

Pajaro
Member
Registered: 2004-04-21
Posts: 878

Re: automatic mounting [solved]

You can try the duo DBUS+HAL, works perfectly w/Gnome (don't know if only Gnome related but don't think so...), you'll get the win*ows behaviour (kind of automount and so on)...

It is using gnome-volume-manager (it is gnome-related)

ivman lets you eject the CDs though being mounted, and can be configured to open your favourite window manager when you insert a data cd/dvd or to play it with your favourite cd player when you insert an audio cd.

Personally, I've configured ivman to ask me if I want to play the audio CD when I insert it (as it is done in the example in the ivman's page) but I've adapted it tu use kscd and to open it as my normal user (pajaro). It was difficult because of scape chars, so I post here the code I added to /etc/ivman/IvmConfigActions.xml:

        <ivm:Match name="hal.volume.disc.has_audio" value="true">
                    <ivm:Option name="exec" value="su -l -c '/opt/kde/bin/kdialog --yesno Play Audio CD? && /opt/kde/bin/kscd -s' pajaro" />
        </ivm:Match>

Offline

#7 2005-02-16 18:23:48

dinkydarko
Member
From: Glasgow, Scotland
Registered: 2005-01-28
Posts: 35
Website

Re: automatic mounting [solved]

I reall like the sound of ivman,  i've been having CD/DVD/Digi Camera trouble with KDE on arch (i liked gnome but was too messy with arch) Problem with ivman is i really have no idea what to do with it. This is the newbie corner and the link to the pervious posts are a little above me.
I tried the

./configure --prefix=/usr --sysconfdir=/etc

then make, then make install.
i then started dbus and hal (also tried this from start up)
but have no idea how to start ivman from startup.
then i try to run it now (from user)

[david@archbox rc.d]$ ivman start
Ikke's Volume Manager, http://ivman.sf.net
13111: arguments to dbus_message_new_method_call() were incorrect, assertion "path != NULL" failed in file dbus-message.c line 1723.
This is normally a bug in some application using the D-BUS library.
libhal.c 1856 : Couldn't allocate D-BUS message

any obvious errors? any good wiki help files about?

thanks for any help,
david

Offline

#8 2005-02-16 18:40:12

Pajaro
Member
Registered: 2004-04-21
Posts: 878

Re: automatic mounting [solved]

ok, didn't realized this is the newbie corner

step by step:

1 - enter in console
2 - create the dir /var/abs.local
3 - create the dir /var/abs.local/ivman
4 - place in that dir the two files that ivman needs for autocompilation: PKGBUILD and ivman that you can find in that post
5 - enter that dir and run makepkg -cis

edit your rc.conf to have ivman in DAEMONS array

Offline

#9 2005-02-16 19:00:16

dinkydarko
Member
From: Glasgow, Scotland
Registered: 2005-01-28
Posts: 35
Website

Re: automatic mounting [solved]

thanks,  feel better knowing i'm on the right track. i dont mind messing about learning but when i am no where near i tend to give up easy.
anyways,  tried the above:
[root@archbox ivman]# makepkg -cis

and get the errors:

./PKGBUILD: line 6: unexpected EOF while looking for matching `"'
./PKGBUILD: line 26: syntax error: unexpected end of file
==> Making package:   (Wed Feb 16 18:50:38 GMT 2005)
==> Checking Runtime Dependencies...
==> Checking Buildtime Dependencies...
==> Retrieving Sources...
==> Validating source files with MD5sums
==> Extracting Sources...
==> Removing existing pkg/ directory...
==> Starting build()...
/usr/bin/makepkg: line 557: build: command not found
==> ERROR: Build Failed.  Aborting...


i copied the ivman and PKGBUILD files exactly and created them using vim

Offline

#10 2005-02-16 19:18:57

lucke
Member
From: Poland
Registered: 2004-11-30
Posts: 4,018

Re: automatic mounting [solved]

You must've copied the PKGBUILD wrong somehow. Maybe some lines got wrapped, but it shouldn't happen in vim, I presume. Anyway, try to paste it into the file again or check the indicated lines for any breaks.

Offline

#11 2005-02-16 19:25:43

dinkydarko
Member
From: Glasgow, Scotland
Registered: 2005-01-28
Posts: 35
Website

Re: automatic mounting [solved]

tried again,  work a bit more.  problem now is a 404 when it tried to download but i recon that shouldnt be too hard for me to work out wink  thanks,   i'll post again if i get it working.

ps: this all works ok with hotplug yeah?

Offline

#12 2005-02-16 19:30:33

lucke
Member
From: Poland
Registered: 2004-11-30
Posts: 4,018

Re: automatic mounting [solved]

Hotplug is a totally different thing, so there shouldn't be any problems with those two working together :-)

If you have problems downloading, just access the address manually and download it to the designed location (probably /var/abs/local/ivman).

Offline

#13 2005-02-16 19:35:49

dinkydarko
Member
From: Glasgow, Scotland
Registered: 2005-01-28
Posts: 35
Website

Re: automatic mounting [solved]

/var/abs/local/?
not /var/abs.local/?

oh dear..

Offline

#14 2005-02-16 19:40:37

lucke
Member
From: Poland
Registered: 2004-11-30
Posts: 4,018

Re: automatic mounting [solved]

If you created abs.local, use abs.local :-) It's just a naming scheme, nothing more.

Offline

#15 2005-02-16 19:47:59

dinkydarko
Member
From: Glasgow, Scotland
Registered: 2005-01-28
Posts: 35
Website

Re: automatic mounting [solved]

smile  still error riddent tho.
Here's what happens:

[root@archbox ivman]# makepkg -cis
==> Making package:   (Wed Feb 16 19:27:52 GMT 2005)
==> Checking Runtime Dependencies...
==> Checking Buildtime Dependencies...
==> Retrieving Sources...
==>     Downloading ivman-0.5_pre2.tar.bz2
--19:27:53--  http://prdownloads.sourceforge.net/ivma … e2.tar.bz2
           => `ivman-0.5_pre2.tar.bz2'
Resolving prdownloads.sourceforge.net... 66.35.250.217
Connecting to prdownloads.sourceforge.net[66.35.250.217]:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: unspecified [text/html]

    [   <=>                                          ] 15,991        37.53K/s

19:27:54 (37.40 KB/s) - `ivman-0.5_pre2.tar.bz2' saved [15991]

==>     Found ivman in build dir
==> Validating source files with MD5sums
    ivman-0.5_pre2.tar.bz2 ... FAILED
    ivman ... FAILED
==> ERROR: One or more files did not pass the validity check!

bugger,  #'d out the md5 part of PKGBUILD:

[root@archbox ivman]# makepkg -cis
==> Making package:   (Wed Feb 16 19:28:49 GMT 2005)
==> Checking Runtime Dependencies...
==> Checking Buildtime Dependencies...
==> Retrieving Sources...
==>     Using local copy of ivman-0.5_pre2.tar.bz2
==>     Found ivman in build dir
==> WARNING: MD5sums are missing or incomplete.  Cannot verify source integrity.
==> Extracting Sources...
==>     tar --use-compress-program=bzip2 -xf ivman-0.5_pre2.tar.bz2
bzip2: (stdin) is not a bzip2 file.
tar: Child returned status 2
tar: Error exit delayed from previous errors
==> ERROR: Failed to extract ivman-0.5_pre2.tar.bz2
==> Aborting...

bugger again!

i have no idea whats goin on now...

Offline

#16 2005-02-16 19:53:35

lucke
Member
From: Poland
Registered: 2004-11-30
Posts: 4,018

Re: automatic mounting [solved]

Seems it didn't download properly/completely. Try again, maybe from a different mirror :-)

We're making a chat out of this, PM me, if you still have any problems with the build process.

Offline

#17 2005-02-16 20:48:29

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Offline

#18 2005-02-16 21:19:25

Pajaro
Member
Registered: 2004-04-21
Posts: 878

Re: automatic mounting [solved]

/var/abs/local/?
not /var/abs.local/?

oh dear..

/var/abs/local may become a mess if you use srcpac, as srcpac builds the first dir coincindence of a find.


about the link, it must be like it appears in the PKGBUILD that's posted in the topic linked above:

http://dl.sourceforge.net/sourceforge/$ … er.tar.bz2

I don't know how can have messed copy-pasting...

Offline

#19 2005-02-16 21:20:49

Pajaro
Member
Registered: 2004-04-21
Posts: 878

Re: automatic mounting [solved]

maybe you'll have to:

rm /var/cache/pacman/src/ivman-0.5_pre2.tar.bz2

Offline

#20 2005-02-16 22:14:22

dinkydarko
Member
From: Glasgow, Scotland
Registered: 2005-01-28
Posts: 35
Website

Re: automatic mounting [solved]

almost, so close:   makepkg works but with the error at the end:

==> Finished making: ivman  (Wed Feb 16 22:12:22 GMT 2005)
==> Running pacman --upgrade...
loading package data... done.
checking for file conflicts...
error: the following file conflicts were found:
  ivman: /etc/ivman/IvmConfigActions.xml: exists in filesystem
  ivman: /etc/ivman/IvmConfigBase.xml: exists in filesystem
  ivman: /etc/ivman/IvmConfigMappings.xml: exists in filesystem
  ivman: /etc/ivman/IvmConfigProperties.xml: exists in filesystem
  ivman: /etc/rc.d/ivman: exists in filesystem
  ivman: /usr/bin/ivman: exists in filesystem
  ivman: /usr/lib/libIvmConfig.a: exists in filesystem
  ivman: /usr/lib/libIvmConfig.la: exists in filesystem
  ivman: /usr/lib/libIvmConfig.so: exists in filesystem
  ivman: /usr/lib/libIvmConfig.so.0: exists in filesystem
  ivman: /usr/lib/libIvmConfig.so.0.0.0: exists in filesystem

anything i can do to remove all the old ones?

Offline

#21 2005-02-16 22:28:52

lanrat
Member
From: Poland
Registered: 2003-10-28
Posts: 1,274

Re: automatic mounting [solved]

I haven't read the whole thread in detail but looks like you previously installed files directly to the system.

You can check it to be sure by running pacman -Qo /path/to/conflicting/file to find out if it belongs to any other package.

If not you can run pacman -Uf package_file_name (f is force - it also works with -S option).

Offline

#22 2005-02-17 13:36:35

dinkydarko
Member
From: Glasgow, Scotland
Registered: 2005-01-28
Posts: 35
Website

Re: automatic mounting [solved]

big_smile  with the additon of ivman to pacman i just used the pacman -Sf ivman  to sort it all out.  still not got it working but there is another thread already started about configuring so i'll keep an eye on that,
thanks for all the help,
david

Offline

Board footer

Powered by FluxBB