You are not logged in.

#1 2005-02-17 07:22:25

rjs
Member
Registered: 2004-04-20
Posts: 23

d-link de-530+ and kernel 2.6.8.1 from arch 0.7 iso

I just did a fresh install of Arch 0.7 on a friends computer and after the initial reboot, the system freezes when initializing the network card.

Completely frozen.  If I disable loading the network in rc.conf the system boots fine, then once activating, it freezes again.  The module is the de4x5, and there is the de2104x module loaded as well.

The card is setup to use staticip, and has the correct gateway. I also noticed that there is a sit0 in ifconfig -a, and whether it is there or not the system still freezes, however if I boot with the 2.4.27 kernel the network is fully fuinctional.

I tried the AM-Lug live CD 0.5.1 and I suffer the same consequences.  However the Suse, Slax and Clusterix Live CD's all work fine. They all use the 2.6.x kernels.

Any ideas as to why the 2.6 kernel does not work in Arch 0.7

Offline

#2 2005-02-17 07:30:25

rjs
Member
Registered: 2004-04-20
Posts: 23

Re: d-link de-530+ and kernel 2.6.8.1 from arch 0.7 iso

I just upograded to the newest linux 2.4.29 as well as 2.6.10 and I am getting the same results.

The 2.4.x kernel functions properly, and the 2.6.x freezes the system.

Offline

#3 2005-02-17 11:16:44

Pajaro
Member
Registered: 2004-04-21
Posts: 875

Re: d-link de-530+ and kernel 2.6.8.1 from arch 0.7 iso

As arch provided the kernel as it is (well, now it provides it with the -as patch). That must be a kernel bug that other distros have fixed.

You can look for a patch or check if this module has some requeriment that in arch is missing, but what I'll propably do is to buy another ethcard... what are 10-20 euros compared to hours and hours of working?

Offline

Board footer

Powered by FluxBB