You are not logged in.

#1 2004-12-21 10:37:02

From: France / Montpellier
Registered: 2004-05-30
Posts: 74

Problem ripping DVD with Arch

hi all !

I have a big problem ripping DVD.

I try with K3B ---> when I select the tack to ripp and click right to select copy, I got a lot of message in the console where I lanch K3B and that's all. The memory stay stable, no swap, hard disk stay empty but dvd drive was working. I didn't wait a lot (few minutes) then I stop. Is this think normal ? Do I have to wait or there's a problem ?

This dvdrip --> I have this problem :

An internal exception was thrown!
The error message was:

Error executing command identify -ping /home/nc/dvdrip/unnamed/tmp/unnamed-003-preview-clip1.jpg:
identify: unable to open image `/home/nc/dvdrip/unnamed/tmp/unnamed-003-preview-clip1.jpg': Aucun fichier ou répertoire de ce type.
identify: missing an image filename `/home/nc/dvdrip/unnamed/tmp/unnamed-003-preview-clip1.jpg'.
 at /usr/lib/perl5/site_perl/5.8.6/Video/DVDRip/GUI/Project/ line 910

and this message

can't read '/home/nc/dvdrip/unnamed/tmp/unnamed-003-preview-orig.raw' at /usr/lib/perl5/site_perl/5.8.6/Video/DVDRip/ line 2440.

What can I do ?

with gmencoder ---> Nothing append. When I say nothing that's mean when I click on encode, nothing append...

So I took scripts I made some time ago (and was working) but console sended  me this error:

DVD successfully opened.
success: format: 0  data: 0x0 - 0xB895B000
Selected DVD audio channel: 128 language: en
Selected DVD subtitle channel: 1 language: en
MPEG-PS file format detected.
VIDEO:  MPEG2  720x576  (aspect 3)  25,000 fps  6150,0 kbps (768,8 kbyte/s)
[V] filefmt:2  fourcc:0x10000002  size:720x576  fps:25,00  ftime:=0,0400
Writing AVI header...
ODML: Aspect information not (yet?) available or unspecified, not writing vprp header.
Pos:   6,7s    168f ( 0%) 107fps Trem:   0min   0mb  A-V:0,000 [0:0]
1 duplicate frame(s)!
Pos:   6,8s    169f ( 0%) 108fps Trem:   0min   0mb  A-V:0,000 [0:0]
Writing AVI index...
Fixing AVI header...
ODML: Aspect information not (yet?) available or unspecified, not writing vprp header.

Video stream:    0,795 kbit/s  (99 bps)  size: 676 bytes  6,800 secs  169 frames

hmm... help !?



#2 2005-01-11 13:48:49

Registered: 2004-05-06
Posts: 96

Re: Problem ripping DVD with Arch

I have no idea what your problems might be.

I might suggest that you use dvdbackup instead, since it always worked quite well for me.


#3 2005-01-14 09:39:01

Registered: 2004-08-06
Posts: 71

Re: Problem ripping DVD with Arch

What are you trying to do... rip a DVD and convert it?
I believe the best tool for this is dvd::rip. Have you had a look at the wiki page about DVD-Ripping?

If you tried this, please post your steps and errors with dvdrip again... but I don't understand any French words.


#4 2005-02-19 02:31:11

Registered: 2004-05-04
Posts: 150

Re: Problem ripping DVD with Arch

chmod u+s /usr/sbin/fping

I think that error is because fping is not suid.  My /bin/ping is also suid, but dvdrip uses fping and you get a message like that if fping is not suid


will probably guide you to whatever is causing the error message.

Do not use divx codec if you have a p4, there is a bug and another error message.  Xvid is better and it works but divx is set by default.

dvdrip, allows cluster ripping, if you want to rip on in the world, use that.




#5 2005-02-19 04:26:34

From: Frequent Flyer Underworld
Registered: 2004-03-23
Posts: 612

Re: Problem ripping DVD with Arch

When I ripped using dvd::rip, I sure don't remember having to set suid for anything.  Maybe the pacman "post_install" did it without me knowing...


Board footer

Powered by FluxBB