You are not logged in.

#1 2005-02-21 20:04:25

lmellen
Member
From: Fairport, NY
Registered: 2004-06-11
Posts: 120

hwd -s says there is no usb -- I have 2 ports????????????

:? I trying to set up a hp 3650 printer on a IBM t-23. The printer uses a usb connection.
I checked hwd -s first for the modules to put in rc.conf. hwd reported that there were no
usb ports present. There are 2!  I'm sure theyr'e usb 1 & I know the modules needed. Should I put the modules in rc.conf, change dev in fstab, & possibly create a mess? Could use input from the community. -- Thanks -- Larry  smile

   These lines are in dmesg: usbcore: registered new driver usbfs
                                          usbcore: registered new driver hub
                                 
                                 and: usbcore: registered new driver hiddev
                                         usbcore: registered new driver usbhid
                                         drivers/usb/input/hid-core.c: v2.0:USB HID core driver

Offline

#2 2005-02-21 21:36:28

Pajaro
Member
Registered: 2004-04-21
Posts: 878

Re: hwd -s says there is no usb -- I have 2 ports????????????

try with hotplug (etc/rc.d/hotplug start). It will autoload necessary modules. Then lsmod and there you will have all modules hytat it loaded.

Offline

#3 2005-02-21 22:10:51

lmellen
Member
From: Fairport, NY
Registered: 2004-06-11
Posts: 120

Re: hwd -s says there is no usb -- I have 2 ports????????????

smile  Thanks Pajaro, with lsmod I got:

Module                  Size         Used by
ohci_hcd               22660        0
ehci_hcd               31748        0
uhci_hcd               33680        0

I assume these 3 are the modules for usb? Thanks again -- Larry smile

Offline

#4 2005-02-21 22:22:15

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: hwd -s says there is no usb -- I have 2 ports????????????

lmellen wrote:

smile  Thanks Pajaro, with lsmod I got:

Module                  Size         Used by
ohci_hcd               22660        0
ehci_hcd               31748        0
uhci_hcd               33680        0

I assume these 3 are the modules for usb? Thanks again -- Larry smile

yup, ehci is for usb 2.0 and ohci/uhci are for usb 1.0 (there's 2 different architectures, hence 2 modules)

Offline

#5 2005-02-22 02:21:50

lmellen
Member
From: Fairport, NY
Registered: 2004-06-11
Posts: 120

Re: hwd -s says there is no usb -- I have 2 ports????????????

big_smile Thanks everybody everything is working -- I have a printer! -- Larry big_smile  big_smile  big_smile  big_smile

Offline

Board footer

Powered by FluxBB