You are not logged in.

#1 2005-02-23 14:35:22

kirkl_uk
Member
Registered: 2003-11-22
Posts: 41

Mouse Only Works When Unplugged

Hi,

When running gnome under xorg, my mouse only works if I unplug it and then plug it back in whilst in the x environment. I am not using the hotplug daemon, and have the ohci_hcd module loaded. Can anyone please help me with this problem?

Thanks,
kirkl

Offline

#2 2005-02-23 15:19:43

i3839
Member
Registered: 2004-02-04
Posts: 1,185

Re: Mouse Only Works When Unplugged

Do a lsmod before and after the replugging to see which modules are loaded by hotplug, so you know which modules you need to load to get it working. That, or a broken /dev or xorg config. Otherwise really no idea.

Offline

#3 2005-02-23 15:37:15

Xentac
Forum Fellow
From: Victoria, BC
Registered: 2003-01-17
Posts: 1,797
Website

Re: Mouse Only Works When Unplugged

i3839 wrote:

Do a lsmod before and after the replugging to see which modules are loaded by hotplug, so you know which modules you need to load to get it working. That, or a broken /dev or xorg config. Otherwise really no idea.

Or.... run the hotplug daemon ;P  The hotplug daemon will detect that you have a usb mouse plugged in that wasn't loaded, so will load the driver.


I have discovered that all of mans unhappiness derives from only one source, not being able to sit quietly in a room
- Blaise Pascal

Offline

#4 2005-02-23 15:37:25

lucke
Member
From: Poland
Registered: 2004-11-30
Posts: 4,017

Re: Mouse Only Works When Unplugged

I just wanted to add that aside of ohci_hcd I need usbhid for my mouse properly. And recently my mouse started to disappear in X after I locked my screen and unlocked it after 0,5-1h, but I didn't look deeper into it, as it's somewhat time consuming to reproduce :-)

Offline

#5 2005-02-23 19:36:58

i3839
Member
Registered: 2004-02-04
Posts: 1,185

Re: Mouse Only Works When Unplugged

Xentac wrote:

Or.... run the hotplug daemon ;P  The hotplug daemon will detect that you have a usb mouse plugged in that wasn't loaded, so will load the driver.

He said he doesn't use the hotplug daemon, so I assumed he doesn't want to run it, or otherwise he would just have done that and have no problems...

Offline

#6 2005-02-24 01:03:42

kirkl_uk
Member
Registered: 2003-11-22
Posts: 41

Re: Mouse Only Works When Unplugged

Yeah, that's right, I am not using the hotplug daemon. I tried with it on, and no extra modules are loaded when the mouse is plugged in. Thanks anyway.

Offline

Board footer

Powered by FluxBB