You are not logged in.

#26 2009-12-08 07:19:46

Pank
Member
From: IT
Registered: 2009-06-13
Posts: 370

Re: [testing] netcfg v2.5.0rc1 - note: auto-wireless configuration changed

> sudo cat /tmp/wpa.wlan0/wpa.conf
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel
network={ 
ssid="BibNet" 
key_mgmt=NONE 
id_str="njl" 
}

I had an extra profile which required SECURITY="none" so now netcfg-wpa_actiond wlan0 works. However, it does not scan correctly. At least it does not connect to my home-network. Why would that be?
edit: it is also true for the network of my university, i.e. it does not see the wifi and just connect to the njl profile

Thanks,
Rasmus

Last edited by Pank (2009-12-08 08:59:09)


Arch x64 on Thinkpad X200s/W530

Offline

#27 2009-12-13 10:58:02

faelar
Member
From: Amiens (FR)
Registered: 2007-12-18
Posts: 232
Website

Re: [testing] netcfg v2.5.0rc1 - note: auto-wireless configuration changed

It works (as always) at home, WPA2 AES, static IP, eeepc 701 on a WRT54GL AP.

I spotted a small mistake in netcfg manpage, in OPTIONS :

r, reconnect profile

should be

-r, reconnect profile

EDIT : It doesn't work so well in fact...
If I have more than one file in /etc/netword.d/ net-auto-wireless fails after trying to connect to all networks :

[13:29 root /etc/network.d] /etc/rc.d/net-auto-wireless start
:: Starting netcfg auto-wireless mode for interface wlan0                  [BUSY]
DEBUG: Loading profile a
DEBUG: Configuring interface wlan0
DEBUG: Loading profile b
DEBUG: Configuring interface wlan0
DEBUG: Loading profile c
DEBUG: Configuring interface wlan0
                                                                           [FAIL]

If I launch netcfg X it connects.
If I have only one profile, /etc/rc.d/net-auto-wireless start works as well.

Any idea ?

Last edited by faelar (2009-12-13 12:40:40)

Offline

#28 2009-12-13 12:30:20

Zariel
Member
Registered: 2008-10-07
Posts: 446

Re: [testing] netcfg v2.5.0rc1 - note: auto-wireless configuration changed

For some reason it takes a few attempts to connect to my wpa2 network at uni.

Offline

#29 2009-12-29 19:39:59

Spewns
Member
Registered: 2008-08-19
Posts: 11

Re: [testing] netcfg v2.5.0rc1 - note: auto-wireless configuration changed

I just tried updating to 2.5.0rc1 on my netbook, and the profile I've always used doesn't connect anymore.

CONNECTION="wireless"
DESCRIPTION="A simple WPA encrypted wireless connection"
INTERFACE="wlan0"
SECURITY="wpa"
ESSID="typicalessid"
KEY="blahblahkey"
IP="dhcp"
QUIRKS=(preessid)

All I receive now is...

~ $ sudo /etc/rc.d/net-profiles start
:: homewifi up                                  [BUSY]
 > WPA Authentication/Association Failed        [FAIL]

 > No profile started.

My wifi network is just WPA2 Personal using TKIP+AES. I'm using an ath5k wifi card. I also tried the above profile without using QUIRKS and it didn't make a difference. (I do need that quirk to connect with the previous version though.)

Downgraded back to 2.2.1 and I can connect again. I honestly know nothing about wireless, so let me know if there's any other info I can give or things I can try.

Offline

#30 2009-12-31 11:46:54

iphitus
Forum Fellow
From: Melbourne, Australia
Registered: 2004-10-09
Posts: 4,927

Re: [testing] netcfg v2.5.0rc1 - note: auto-wireless configuration changed

Sorry I dropped the ball on this guys. I've tried to respond to everyone below, sorry if I missed anything. Also 2.5.0rc2 has been released to [testing].

Pank: wpa-config profiles are presently not supported by the roaming, try using wpa-configsection instead. The first post has been edited to reflect this and it will be added to the wiki.

Spewns: I removed many quirks in this release - they really shouldn't be required by any driver. Try setting PRE_UP="iwconfig wlan0 essid typicalessid" or PRE_UP="ifconfig wlan0 down; iwconfig wlan0 essid typicalessid; ifconfig wlan0 up". Off the top of my head, that should have the same effect as preessid.

djszapi: dbus has been dropped because it doesn't fit in well with netcfg and the same capabilities can be acheived without it. The wpa_supplicant interface isn't pleasant and the author has lofty intentions to replace it.

Runiq: The scanning/finding networks is effectively moved to wpa_supplicant, which is much better at this task and a great deal more intelligent about how it chooses networks. It also means that it will automatically roam, you do not need to re-issue the automatic script.

Finkregh: I've looked at that. It duplicates a _lot_ of code. There's a few other ways it could be implemented.
* Like connections/wireless, which does the wireless work and then calls ethernet. The vlan code could do it's business then call ethernet.
* A small patch to ethernet itself, the vlan work doesn't seem too intrusive.

mcover: No, that's probably a bug, I'll have a look.

faelar: Odd, I've got heaps of profiles including some pretty horrible ones but it's not choked here. Would you be able to send them? Could one have a syntax error of some sort?

Happy New Year,
James

Last edited by iphitus (2009-12-31 11:48:54)

Offline

#31 2009-12-31 15:43:15

faelar
Member
From: Amiens (FR)
Registered: 2007-12-18
Posts: 232
Website

Re: [testing] netcfg v2.5.0rc1 - note: auto-wireless configuration changed

http://pastebin.com/m2fef46b9

Tell me if you need anything else...

Offline

#32 2009-12-31 19:59:45

Spewns
Member
Registered: 2008-08-19
Posts: 11

Re: [testing] netcfg v2.5.0rc1 - note: auto-wireless configuration changed

iphitus wrote:

Spewns: I removed many quirks in this release - they really shouldn't be required by any driver. Try setting PRE_UP="iwconfig wlan0 essid typicalessid" or PRE_UP="ifconfig wlan0 down; iwconfig wlan0 essid typicalessid; ifconfig wlan0 up". Off the top of my head, that should have the same effect as preessid.

Thanks, both of those worked. But I have to say, now that QUIRKS are mostly gone, you might want to spit out a warning message to people who are trying to connect with profiles using deprecated quirks so they aren't left scratching their head when they can't connect. And your new wiki page for 2.5 still lists quirks such as preessid even though you say they're removed.

Right now it's very easy for me to claim how much easier and simpler it was to just use a quirk than to use the PRE_UP information you gave to me, but that's mostly because there's nothing on the wiki page suggesting that information to me. There should probably be a "Migrating Your Profile From QUIRKS" section that explains how to get the same effects from deprecated QUIRKS by using the new PRE_UP, POST_UP, etc., options for less savvy folks like me who apparently have odd drivers.

But anyway, like I said, I'm successfully connecting to the net now at least. However, I now get this on starting and stopping the net-profiles daemon::

~ $ sudo /etc/rc.d/net-profiles start
:: homewifi up                                                                                [BUSY]
find: `/var/run/network//suspend/': No such file or directory
                                                                                              [DONE]
~ $ sudo /etc/rc.d/net-profiles stop
/bin/stty: standard input: Invalid argument
:: homewifi down 9G   [BUSY] /bin/stty: standard input: Invalid argument
/bin/stty: standard input: Invalid argument
9G   [DONE]

Yeah, all jumbled like that. ;[

Thanks.

Offline

#33 2010-01-01 16:02:29

eldragon
Member
From: Buenos Aires
Registered: 2008-11-18
Posts: 1,026

Re: [testing] netcfg v2.5.0rc1 - note: auto-wireless configuration changed

iphitus wrote:

Sorry I dropped the ball on this guys. I've tried to respond to everyone below, sorry if I missed anything. Also 2.5.0rc2 has been released to [testing].

hmm, this update broke rfkill for me.

$  cat /etc/network.d/interfaces/wlan0 
RFKILL=hard
RFKILL_NAME='phy0'
$  cat /sys/class/rfkill/rfkill0/name 
phy0

and finally, issuing a netcfg <profile> reports radio switch is off.


commening out the wlan0 file fixes it.

Offline

#34 2010-01-02 06:31:47

iphitus
Forum Fellow
From: Melbourne, Australia
Registered: 2004-10-09
Posts: 4,927

Re: [testing] netcfg v2.5.0rc1 - note: auto-wireless configuration changed

How did it break it? what is it not doing?

Offline

#35 2010-01-02 14:04:38

PieterO
Member
From: Belgium
Registered: 2004-03-03
Posts: 27

Re: [testing] netcfg v2.5.0rc1 - note: auto-wireless configuration changed

Hello,

does someone have an example of the configsection file?
Because with the standard wireless-wpa-config file I can't get my wireless internet working

Offline

#36 2010-01-02 14:10:31

eldragon
Member
From: Buenos Aires
Registered: 2008-11-18
Posts: 1,026

Re: [testing] netcfg v2.5.0rc1 - note: auto-wireless configuration changed

iphitus wrote:

How did it break it? what is it not doing?

starting net-auto-wireless reports a [fail]

and as i said before, starting my profile manually (netcfg <profile>) reports the radio switch is off.

removing the rfkill settings in the interfaces file fixes it (logical)

and yes, ive checked the rfkill switch is actually ON, when its off, scanning fails.

hardware: rt73usb

Offline

#37 2010-01-02 22:29:17

iphitus
Forum Fellow
From: Melbourne, Australia
Registered: 2004-10-09
Posts: 4,927

Re: [testing] netcfg v2.5.0rc1 - note: auto-wireless configuration changed

I'll have a look. As it is, the rfkill implementation is kinda broken as it uses a deprecated sysfs file. It needs to be rewritten using the 'rfkill' tool from the AUR.

PieterO: Sorry, I thought one was included, apparently not. I'll add to the next release. In the meantime...

CONNECTION="wireless"
INTERFACE=ra0
SECURITY="wpa-configsection"
ESSID="SOMEUNI"
IP="dhcp"
CONFIGSECTION='
    ssid="SOMEUNI"
    key_mgmt=WPA-EAP
    eap=TTLS
    group=TKIP
    pairwise=TKIP CCMP
    anonymous_identity="anonymous"
    identity="myidentity"
    password="blah"
    priority=1
    phase2="auth=PAP"'

please note that the CONFIGSECTION option _WILL VARY_ depending on your network configuration. I have only left mine included above to demonstrate how it can be used.

Offline

#38 2010-01-03 12:43:17

Pank
Member
From: IT
Registered: 2009-06-13
Posts: 370

Re: [testing] netcfg v2.5.0rc1 - note: auto-wireless configuration changed

Hello,
I still can't get wpa_actioned to work. I moved  /etc/network.d and  reinstalled testing/netcfg (rc2).
The only profile present is the following:

CONNECTION="wireless"
SECURITY="wpa-configsection"
ESSID="scjiskoven5GHz"
DESCRIPTION="Test network"
INTERFACE="wlan0"
IP="dhcp" 
TIMEOUT="45"
CONFIGSECTION='
    ssid="scjiskoven5GHz"
    psk=psk
'

For testing purpose I run

> sudo netcfg-wpa_actiond wlan0
testprofile
> ping google.com
ping: unknown host google.com

If I connect manually it works fine.

BTW, wpa-configsection is a nice idea. I like having it all in a single file.

Cheers,
Rasmus

PS: Can I somehow provide more than one SSID in netcfg/wpa_supplicant lingo? My school uses two SSIDs; they are equally good and I would like to have a single profile.


Arch x64 on Thinkpad X200s/W530

Offline

#39 2010-01-07 12:37:03

iphitus
Forum Fellow
From: Melbourne, Australia
Registered: 2004-10-09
Posts: 4,927

Re: [testing] netcfg v2.5.0rc1 - note: auto-wireless configuration changed

Pank: netcfg-wpa_actiond is not instantaneous. When it returns, it will have not connected, it forks. Give it a while to associate and then gain an IP before you attempt to ping. You can check the status with "wpa_cli status"

Last edited by iphitus (2010-01-07 12:38:08)

Offline

#40 2010-01-07 14:33:30

eldragon
Member
From: Buenos Aires
Registered: 2008-11-18
Posts: 1,026

Re: [testing] netcfg v2.5.0rc1 - note: auto-wireless configuration changed

you can make it go faster by issuing a 'iwlist wlan0 scan' which will trigger wpa-actiond

Offline

#41 2010-01-12 19:48:13

gandro
Member
From: Switzerland
Registered: 2007-12-22
Posts: 4

Re: [testing] netcfg v2.5.0rc1 - note: auto-wireless configuration changed

Hope this is the right place, because I have a last minute feature request:

I didn't test it, but looked in the source code: The new net-auto-wired (which is a great improvement btw) first tries to load all dhcp-based profiles, then the static ones. Apart from that, the profiles aren't in any specific order. This prevents having a fall back dhcp-profile, since I do have some profiles which check with the help of the POST_UP command weather their're in the right environment or not.

So, would it be possible to have the profiles tested in a certain order? For example to let list_profiles() return a alphabetically sorted list of the profiles.

Last edited by gandro (2010-01-12 19:52:21)

Offline

#42 2010-01-17 02:10:24

jeremdow
Member
Registered: 2010-01-17
Posts: 1

Re: [testing] netcfg v2.5.0rc1 - note: auto-wireless configuration changed

iphitus: Thanks for posting the wpa-configsection example.

Now that I have that setup properly, wpa_actiond is working great for me, and no more time out / disconnect issues that I was sometimes having before.

Offline

#43 2010-01-18 21:41:41

mezcal
Member
From: Czech Republic
Registered: 2006-01-31
Posts: 64
Website

Re: [testing] netcfg v2.5.0rc1 - note: auto-wireless configuration changed

Hi,
I have Intel Corporation PRO/Wireless 2200BG.
netcfg <profile> works fine.
/etc/rc.d/net-profiles start also works fine.

/etc/rc.d/net-auto-wirelles start always fails.

CONNECTION="wireless"
DESCRIPTION="A simple opened wireless connection"
INTERFACE="eth0"
ESSID="truhlikw"
IP="dhcp"
CONNECTION="wireless"
DESCRIPTION="A simple WPA encrypted wireless connection"
INTERFACE="eth0"
SECURITY="wpa"
ESSID="WLAN-C"
KEY="mykey"
IP="dhcp"
DHCLIENT="yes"
NETCFG_DEBUG="yes" /etc/rc.d/net-auto-wireless start
:: Starting netcfg auto-wireless mode for interface eth0                     [BUSY]
DEBUG: Loading profile wlan-c
DEBUG: Configuring interface eth0
DEBUG: Loading profile truhlikw
DEBUG: Configuring interface eth0
                                                                             [FAIL]

Last edited by mezcal (2010-01-18 22:04:10)

Offline

#44 2010-01-19 21:20:17

mezcal
Member
From: Czech Republic
Registered: 2006-01-31
Posts: 64
Website

Re: [testing] netcfg v2.5.0rc1 - note: auto-wireless configuration changed

adding SECURITY="none" solves the problem.
it connects to wireless.

Now I have only small issue. 
/etc/rc.d/net-auto-wireless start doesn`t set up a IP.

Offline

#45 2010-01-30 23:36:04

iphitus
Forum Fellow
From: Melbourne, Australia
Registered: 2004-10-09
Posts: 4,927

Re: [testing] netcfg v2.5.0rc1 - note: auto-wireless configuration changed

netcfg 2.5.0 is in testing, I'll move it in a day or two if nobody yells and once I get signoffs on arch-dev-public.

mezcal: one fix in 2.5.0 which might help, otherwise keep in mind that net-auto-wireless won't ever have an IP once it returns [DONE]. That just means it has been started -- not that it has been connected, it does the connection in background.

edit: I forgot to add the wpa-configsection example, but I'll add that shortly.
edit: 2.5.1 is out, with configsection and fixed auto-wired

Last edited by iphitus (2010-01-31 01:06:22)

Offline

#46 2010-02-01 19:56:29

mezcal
Member
From: Czech Republic
Registered: 2006-01-31
Posts: 64
Website

Re: [testing] netcfg v2.5.0rc1 - note: auto-wireless configuration changed

Thanks Iphitus. Great job. lol
It helped me.

Offline

#47 2010-02-06 10:27:14

ngoonee
Forum Fellow
From: Between Thailand and Singapore
Registered: 2009-03-17
Posts: 6,834

Re: [testing] netcfg v2.5.0rc1 - note: auto-wireless configuration changed

Hi Iphitus,

Am testing out the new net-auto-wired and net-auto-wireless, both work fine even when run concurrently. I do have a small issue though on net-auto-wireless after resuming from suspend.

I have location A and location B. At A I have a wireless network (my home network), at B I have a wired LAN connection and intermittent wireless connectivity (uni network).

When I suspend at A, and resume at A, everything works fine, I reconnect to my home network.

When I suspend at A, and resume at B, everything works fine, I get my LAN connection and sometimes the uni wifi is connected to, not that its needed of course.

When I suspend at B and resume at B, everything works fine.

When I suspend at B and resume at A, I never (after half an hour or so even) get a connection to my home wifi network, unless I restart net-auto-wireless or run netcfg manually.

I can help debug (but of course, it'll take a while since max I can do is one test a day, when I get home from uni), but would appreciate instructions.

Thanks so much for this package.


Allan-Volunteer on the (topic being discussed) mailn lists. You never get the people who matters attention on the forums.
jasonwryan-Installing Arch is a measure of your literacy. Maintaining Arch is a measure of your diligence. Contributing to Arch is a measure of your competence.
Griemak-Bleeding edge, not bleeding flat. Edge denotes falls will occur from time to time. Bring your own parachute.

Offline

#48 2010-02-08 15:22:27

thujone
Member
From: Firenze, Italy
Registered: 2007-01-01
Posts: 17

Re: [testing] netcfg v2.5.0rc1 - note: auto-wireless configuration changed

Pank wrote:

PS: Can I somehow provide more than one SSID in netcfg/wpa_supplicant lingo? My school uses two SSIDs; they are equally good and I would like to have a single profile.

This is something I'm looking for too: my school uses a dozen different SSIDs (somewhere the same SSID is used with different APs and radio channels -- maybe due to repeaters?), then I've been using a custom script that generates Netcfg profiles out of iwlist scan output.

I never tried Autowifi, but it looks it provides a way to do it, hence I guess wpa_supplicant has not such a feature, but please correct me if I'm wrong.
Some way to set "ESSID=any" for an open wireless profile could be nice too, would these both be valid feature requests for Netcfg?

Cheers.

Offline

#49 2010-02-08 16:51:39

Gusar
Member
Registered: 2009-08-25
Posts: 3,452

Re: [testing] netcfg v2.5.0rc1 - note: auto-wireless configuration changed

thujone wrote:

Some way to set "ESSID=any" for an open wireless profile could be nice too, would these both be valid feature requests for Netcfg

That's already possible. ESSID=""

Offline

#50 2010-02-08 17:26:37

thujone
Member
From: Firenze, Italy
Registered: 2007-01-01
Posts: 17

Re: [testing] netcfg v2.5.0rc1 - note: auto-wireless configuration changed

Gusar wrote:

That's already possible. ESSID=""

You're right, unfortunately it didn't work for me, I suspect a faulty AP is picked up and no further attempt is made -- it is handled at the wireless_tools level, isn't it? I mean: is it the same of running

iwconfig $IFACE essid "" && dhcpcd $IFACE

without Netcfg taking any special step due to the empty SSID?

Offline

Board footer

Powered by FluxBB