You are not logged in.

#1 2005-02-27 12:49:45

Eltnux
Member
Registered: 2005-02-01
Posts: 12

pacman / flac error [solved]

I have just tried to upgrade my system by issueing pacman -Syu but when i answer Y to Proceedwith Upgrade i get the following error message

checking package integrity...
error: archive flac-1.1.1-2.pkg.tar.gz is corrupted

If i issue the following command pacman -S flac i get the following message

:: flac-1.1.2-1: local version is newer.  Upgrade anyway? [Y/n] n

I then tried to see what version of flac i have by typing flac -v and got the following message.

flac: error while loading shared libraries: libFLAC.so.6: cannot open shared object file: No such file or directory

Any advice?

Offline

#2 2005-02-27 15:57:51

T-Dawg
Forum Fellow
From: Wilmington, NC
Registered: 2005-01-29
Posts: 2,734

Re: pacman / flac error [solved]

it has been discovered that flac 1.1.2 has a bug in it that disables xmms. This package is being removed from the servers this is why its giving you the 'local version is newer' message. If your getting 1.1.1 as corrupt go into your /var/cache/pacman/pkg folder find and delete flac 1.1.1. Then go to /etc/pacman.d and edit the 'current' file (I believe this is were it gets it from) and move a server up on the list until you get flac 1.1.1 with integrety. If you still can get it, go to http://ftp.nluug.nl/ftp/pub/os/Linux/di … pkg.tar.gz
and download it manually. You can install by cd'ing into the directory it is saved and do

pacman -U flac-1.1.1-2.pkg.tar.gz

Offline

#3 2005-02-27 20:52:16

Eltnux
Member
Registered: 2005-02-01
Posts: 12

Re: pacman / flac error [solved]

Thanks for the helpPenguin, it works fine now.

Offline

Board footer

Powered by FluxBB