You are not logged in.

#1 2010-02-09 10:25:20

thomaslundgaard
Member
Registered: 2009-05-26
Posts: 3

Cannot upgrade to KDE SC 4.4: polkit-kde and shared-desktop not found!

Hi.

I'm trying to upgrade to KDE SC 4.4, but get the following errors:

bash$ sudo pacman -Suy
:: Synchronizing package databases...
core is up to date
extra is up to date
community is up to date
archlinuxfr is up to date
:: Starting full system upgrade...
resolving dependencies...
warning: cannot resolve "polkit-kde", a dependency of "kdebase-workspace"
warning: cannot resolve "polkit-kde", a dependency of "kdebase-workspace"
warning: cannot resolve "shared-desktop-ontologies", a dependency of "kdelibs"
:: the following package(s) cannot be upgraded due to unresolvable dependencies:
      kbluetooth  kdebase-workspace  kdelibs

Do you want to skip the above package(s) for this upgrade? [Y/n] n
error: failed to prepare transaction (could not satisfy dependencies)
:: kdebase-workspace: requires polkit-kde
:: kdebase-workspace: requires polkit-kde
:: kdelibs: requires shared-desktop-ontologies


Seems like an error in the packages dependencies - maybe polkit-kde should be the polkit-qt package?
Any ideas?

Offline

#2 2010-02-09 10:30:29

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: Cannot upgrade to KDE SC 4.4: polkit-kde and shared-desktop not found!

pacman -Sy --asdeps qt
pacman -Su

http://bbs.archlinux.org/viewtopic.php?id=90629

Last edited by wonder (2010-02-09 10:50:09)


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#3 2010-02-09 11:51:13

Karmadon
Member
Registered: 2009-04-15
Posts: 6

Re: Cannot upgrade to KDE SC 4.4: polkit-kde and shared-desktop not found!

I've got the same problem:
pacman -Sy --asdeps qt
:: Synchronizing package databases...
core is up to date
extra is up to date
community is up to date
archlinuxfr is up to date
warning: qt-4.5.3-4 is up to date -- reinstalling
resolving dependencies...
looking for inter-conflicts...

... everything went fine here, but when I did pacman -Su I got this:

# pacman -Su
:: Starting full system upgrade...
resolving dependencies...
warning: cannot resolve "polkit-kde", a dependency of "kdebase-workspace"
warning: cannot resolve "shared-desktop-ontologies", a dependency of "kdelibs"
:: the following package(s) cannot be upgraded due to unresolvable dependencies:
      kdebase-workspace  kdelibs

Do you want to skip the above package(s) for this upgrade? [Y/n]

Is it ok?

Offline

#4 2010-02-09 11:53:44

flamelab
Member
From: Athens, Hellas (Greece)
Registered: 2007-12-26
Posts: 2,160

Re: Cannot upgrade to KDE SC 4.4: polkit-kde and shared-desktop not found!

Pierre just posted that there is a problem with the scripts. I think we are gonna have a problem :-/

Offline

#5 2010-02-09 11:54:55

Karmadon
Member
Registered: 2009-04-15
Posts: 6

Re: Cannot upgrade to KDE SC 4.4: polkit-kde and shared-desktop not found!

Hm, probably the mirror I'm using is not fully synced because when I do
pacman -Ss polkit-kde
it returns nothing.

Offline

#6 2010-02-09 13:15:32

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,335
Website

Re: Cannot upgrade to KDE SC 4.4: polkit-kde and shared-desktop not found!

There's no polkit-kde nor shared-desktop packages on ftp://ftp.archlinux.org/extra/os/x86_64  <~~ and yes, i know that this mirror is also a mirror but it's most current mirror. Also while -Syu from this mirror im getting no errors...

But to solve this i know 2 methods, both dirty sad

First method, will install new qt, while some qt apps may not work untill update's end:
sync pacman -Syy
remove qt: pacman -Rd qt
install qt: pacman -S qt
update: pacman -Su
Edit: this method works exactly like wonder's mentioned above:
pacman -Sy --asdeps qt
pacman -Su


also if you still wanna work on while updating you can remove qt after pacman -Syud, in that way:
pacman -Syud
pacman -Rd qt
pacman -S qt
pacman -Su

Last edited by Vi0L0 (2010-02-09 13:23:39)

Offline

#7 2010-02-09 13:29:28

Vegita
Member
Registered: 2009-10-06
Posts: 111

Re: Cannot upgrade to KDE SC 4.4: polkit-kde and shared-desktop not found!

[root@myhost ~]# pacman -Ss kdebase
extra/kde-meta-kdebase 4.3-7 (kde-meta)
    Meta package for kdebase
extra/kdebase-dolphin 4.3.4-1 (kde kdebase)
    File Manager
...

and tons of mirrors plays that. When it would be solved? What is the average "mirrorlagg" time? Site sais, that 4.4.0 is in extra since 10.30PM (gmt+1) and it's 14.35 here

Edit: after doing "pacman -Syyu" with tons of mirrors I get this...

Last edited by Vegita (2010-02-09 13:30:24)

Offline

#8 2010-02-09 14:30:57

noalwin
Member
From: Spain
Registered: 2007-06-08
Posts: 115

Re: Cannot upgrade to KDE SC 4.4: polkit-kde and shared-desktop not found!

Vegita wrote:

What is the average "mirrorlagg" time? Site sais, that 4.4.0 is in extra since 10.30PM (gmt+1) and it's 14.35 here

Check http://wiki.archlinux.org/index.php/Mir … ror_status

ftp://ftp.archlinux.org/$repo/os/x86_64  seems updated, but I had to download the qt package from testing and install it with pacman -U

Riight now I'm also having issues

[0][me@myhost ~]$ sudo pacman -Su
Password:
:: Starting full system upgrade...
warning: bin32-wine: local (1.1.38-1) is newer than archlinuxfr (1.1.24-1)
:: Replace kdelibs-experimental with extra/kdelibs? [Y/n]
resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: kde-meta-kdepim: requires kdepim-akonadiconsole
[1][me@myhost ~]$ sudo pacman -S kdepim-akonadiconsole
resolving dependencies...
looking for inter-conflicts...
:: kdepim-akonadiconsole conflicts with kdepim-runtime. Remove kdepim-runtime? [Y/n]
error: failed to prepare transaction (could not satisfy dependencies)
:: kdepim-kresources: requires kdepim-runtime
[1][me@myhost ~]$

Offline

#9 2010-02-09 15:01:51

Pierre
Developer
From: Bonn
Registered: 2004-07-05
Posts: 1,950
Website

Re: Cannot upgrade to KDE SC 4.4: polkit-kde and shared-desktop not found!

Please wait at least a few hours. The packages should be all there but it needs time to get them on every mirror. I'll recheck this tonight.

Offline

#10 2010-02-09 15:07:40

flamelab
Member
From: Athens, Hellas (Greece)
Registered: 2007-12-26
Posts: 2,160

Re: Cannot upgrade to KDE SC 4.4: polkit-kde and shared-desktop not found!

I have these mirrors first:

Server = http://archlinux.limun.org/$repo/os/x86_64                           
Server = http://mir.archlinux.fr/$repo/os/x86_64

and I just upgraded to 4.4 succesfully.

Offline

#11 2010-02-09 15:23:51

ungoliant
Member
Registered: 2009-05-17
Posts: 39

Re: Cannot upgrade to KDE SC 4.4: polkit-kde and shared-desktop not found!

I'm having the same issue as noalwin, tried using your mirrors, still the same. Doesn't seem like a mirror lag issue...

Offline

#12 2010-02-09 15:32:52

admsimat
Member
Registered: 2010-02-09
Posts: 4

Re: Cannot upgrade to KDE SC 4.4: polkit-kde and shared-desktop not found!

Well, it seems that the i686 repositories do not have akonadi-1.3.1-1-i686.pkg.tar.gz and libv4l-0.6.4-1-i686.pkg.tar.gz. THe 64-bit repositories look ok.

Offline

#13 2010-02-09 15:36:11

Pierre
Developer
From: Bonn
Registered: 2004-07-05
Posts: 1,950
Website

Re: Cannot upgrade to KDE SC 4.4: polkit-kde and shared-desktop not found!

So, what did I just tell you about waiting and that the mirrors will have to sync? Does anybody actually read my posts?

Offline

#14 2010-02-09 16:02:42

thomaslundgaard
Member
Registered: 2009-05-26
Posts: 3

Re: Cannot upgrade to KDE SC 4.4: polkit-kde and shared-desktop not found!

Ok, I also just upgraded successfully

If you get a:
error: failed to prepare transaction (could not satisfy dependencies)
:: kdelibs: requires phonon

You need to do the previously mentioned
pacman -Sy --asdeps qt
pacman -Su

Offline

#15 2010-02-09 16:11:15

noalwin
Member
From: Spain
Registered: 2007-06-08
Posts: 115

Re: Cannot upgrade to KDE SC 4.4: polkit-kde and shared-desktop not found!

After remove kde-meta-kdepim  I tried to upgrade and I got conflicting files:

error: failed to commit transaction (conflicting files)
kdelibs: /usr/share/apps/cmake/modules/FindKDevPlatform.cmake exists in filesystem
kdebase-workspace: /usr/lib/kde4/plasma_applet_windowlist.so exists in filesystem
kdebase-workspace: /usr/share/kde4/services/plasma-applet-windowlist.desktop exists in filesystem
Errors occurred, no packages were upgraded.

Nibble also had that problem http://bbs.archlinux.org/viewtopic.php? … 14#p704914


I'm upgrading from kdebase-workspace 4.3.4-2 and kdelibs 4.3.4-3 to  kdebase-workspace 4.4.0-3 and kdelibs 4.4.0-3

Offline

#16 2010-02-09 16:15:55

*blasco*
Member
Registered: 2008-12-08
Posts: 40

Re: Cannot upgrade to KDE SC 4.4: polkit-kde and shared-desktop not found!

noalwin wrote:
Vegita wrote:

What is the average "mirrorlagg" time? Site sais, that 4.4.0 is in extra since 10.30PM (gmt+1) and it's 14.35 here

Check http://wiki.archlinux.org/index.php/Mir … ror_status

ftp://ftp.archlinux.org/$repo/os/x86_64  seems updated, but I had to download the qt package from testing and install it with pacman -U

Riight now I'm also having issues

[0][me@myhost ~]$ sudo pacman -Su
Password:
:: Starting full system upgrade...
warning: bin32-wine: local (1.1.38-1) is newer than archlinuxfr (1.1.24-1)
:: Replace kdelibs-experimental with extra/kdelibs? [Y/n]
resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: kde-meta-kdepim: requires kdepim-akonadiconsole
[1][me@myhost ~]$ sudo pacman -S kdepim-akonadiconsole
resolving dependencies...
looking for inter-conflicts...
:: kdepim-akonadiconsole conflicts with kdepim-runtime. Remove kdepim-runtime? [Y/n]
error: failed to prepare transaction (could not satisfy dependencies)
:: kdepim-kresources: requires kdepim-runtime
[1][me@myhost ~]$

Now I have the same problem as noalwin!

I have also installed qt with "pacman -Sy --asdeps qt " command.

Offline

#17 2010-02-09 21:32:35

Malakin
Member
From: Santiago, Chile
Registered: 2007-04-29
Posts: 34
Website

Re: Cannot upgrade to KDE SC 4.4: polkit-kde and shared-desktop not found!

I have the same problem than noalwin. I just uninstalled kde-pim and now I am upgrading. I will try installing kde-pim after the upgrade is complete.

Offline

#18 2010-02-09 21:36:21

*blasco*
Member
Registered: 2008-12-08
Posts: 40

Re: Cannot upgrade to KDE SC 4.4: polkit-kde and shared-desktop not found!

Malakin wrote:

I have the same problem than noalwin. I just uninstalled kde-pim and now I am upgrading. I will try installing kde-pim after the upgrade is complete.

can you post in this thread your results?!
Thanks.

Offline

#19 2010-02-09 23:08:21

Malakin
Member
From: Santiago, Chile
Registered: 2007-04-29
Posts: 34
Website

Re: Cannot upgrade to KDE SC 4.4: polkit-kde and shared-desktop not found!

It works! Though I recommend installing from outside of KDE because in my desktop all windows and toolbars dissapeared, except for the skype window contents. This means I couldn't see the results of the upgrade process.

I will try again, this time in my laptop which has the same kdepim problem.

Offline

#20 2010-02-10 01:15:01

Malakin
Member
From: Santiago, Chile
Registered: 2007-04-29
Posts: 34
Website

Re: Cannot upgrade to KDE SC 4.4: polkit-kde and shared-desktop not found!

It worked. In my case I just did:

yaourt -Rcs kde-meta-kdepim
yaourt -Su
yaourt -S kde-meta-kdepim

Using KDE 4.4 and liking it :-)

Offline

#21 2010-02-10 09:04:58

trunneml
Member
From: Germany Stuttgart
Registered: 2010-02-09
Posts: 21

Re: Cannot upgrade to KDE SC 4.4: polkit-kde and shared-desktop not found!

Hi,

pacman -R kde-meta-kdepim
pacman -Su
pacman -S kde-meta-kdepim

seems to be enough. :-)

Offline

Board footer

Powered by FluxBB