You are not logged in.

#1 2010-01-24 21:19:03

MTsoul
Member
From: Vancouver, BC
Registered: 2008-08-14
Posts: 95
Website

QT fonts aliased

I don't when but after one of the upgrades (maybe a while back), all QT applications' fonts became all aliased, including Picard, Skype, Opera, among many other things.

16dRN.png

What happened?

Offline

#2 2010-01-25 03:51:25

cookiecaper
Member
Registered: 2007-09-22
Posts: 197

Re: QT fonts aliased

Same thing here.

Offline

#3 2010-02-09 04:22:06

MTsoul
Member
From: Vancouver, BC
Registered: 2008-08-14
Posts: 95
Website

Re: QT fonts aliased

Bumpidy bump? Nobody has this problem? This is happening on my laptop and desktop.

Offline

#4 2010-02-09 10:36:14

Aidenn
Member
Registered: 2006-03-20
Posts: 51

Re: QT fonts aliased

works for me.

anyway, please try to provide more details, what DE/WM are you using, are you using XSETTINGS based font preferences (GNOME, XFCE, LXDE etc.) or just plain .fonts.conf and so on.

I'd wager you haven't got your .fonts.conf set up properly. see the wiki for details.

Last edited by Aidenn (2010-02-09 10:37:11)

Offline

#5 2010-02-10 05:32:20

MTsoul
Member
From: Vancouver, BC
Registered: 2008-08-14
Posts: 95
Website

Re: QT fonts aliased

I'm using Awesome, and am not aware of any font configuration programs on my computer.

I read through the wiki page on Fonts, and still have no clue what to do. What is the problem here? It says anti-alias is enabled by default, and I don't see any configuration on my side that disables this.

Offline

#6 2010-02-10 09:01:04

Aidenn
Member
Registered: 2006-03-20
Posts: 51

Re: QT fonts aliased

MTsoul wrote:

I'm using Awesome, and am not aware of any font configuration programs on my computer.

I read through the wiki page on Fonts, and still have no clue what to do. What is the problem here? It says anti-alias is enabled by default, and I don't see any configuration on my side that disables this.

try and put this .fonts.conf in your home dir:

<?xml version='1.0'?>
<!DOCTYPE fontconfig SYSTEM 'fonts.dtd'>
<fontconfig>
   <match target="font" >
      <edit mode="assign" name="rgba" >
         <const>rgb</const>
      </edit>
   </match>
   <match target="font" >
      <edit mode="assign" name="hinting" >
         <bool>true</bool>
      </edit>
   </match>
   <match target="font" >
      <edit mode="assign" name="hintstyle" >
         <const>hintslight</const>
      </edit>
   </match>
   <match target="font" >
      <edit mode="assign" name="antialias" >
         <bool>true</bool>
      </edit>
   </match>
</fontconfig>

and reload X. defaults be defaults, one can never be too careful. maybe something changed in recent qt.

Offline

#7 2010-03-23 18:48:36

Hy Ginsberg
Member
From: Massachusetts
Registered: 2008-08-22
Posts: 74
Website

Re: QT fonts aliased

I am having this problem, too.  I just installed Opera 10.10 (along with all new everything -- new hard drive).  I am also using Awesome and no DE.  I tried the suggested .fonts.conf; no help.

Thanks - Hy

Offline

#8 2010-03-24 18:52:13

Hy Ginsberg
Member
From: Massachusetts
Registered: 2008-08-22
Posts: 74
Website

Re: QT fonts aliased

I installed ttf-ms-fonts and that fixed the problem.

- Hy

Offline

Board footer

Powered by FluxBB