You are not logged in.

#1 2005-03-01 19:54:29

ganja_guru
Member
Registered: 2005-02-14
Posts: 464

bare minimum groups required during 'adduser'

i need a working user account where i can mount/unmount,play music, video,blah blah..basically do everything i can as root ,(but obviously not edit system files..) ...what groups do i need to add this user to? ive added this user to some groups, and strangely im able to access my fat32, but not my ntfs partition using this account..(fstab has "defaults,user" for both partitions)

oh and how do i give this user write access to these partitions?(ntfs/vfat and  backup reiser partition)?

is there anyway to give user access to pacman? what do groups like bin.adm,tty,daemon do exactly? (manpage?)

thanks very much!

Offline

#2 2005-03-01 19:57:07

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: bare minimum groups required during 'adduser'

i think you need to add a umask to the ntfs fstab entry, IINM

Offline

#3 2005-03-01 20:17:30

ganja_guru
Member
Registered: 2005-02-14
Posts: 464

Re: bare minimum groups required during 'adduser'

if i remember correctly, umask=000 should be added to fstab ...such as:


/dev/discs/disc0/part2 / reiserfs defaults,user,umask=000   0 0

thats what i tried...however when i try to mount, i get an error ..and a dmesg | tail gives me

ReiserFS: hda2: warning: unknown mount option "umask=000"
ReiserFS: hda2: warning: unknown mount option "umask=000"
ReiserFS: hda2: warning: unknown mount option "umask=000"

so where do i shove umask=000 ??

Offline

#4 2005-03-01 20:34:09

kth5
Member
Registered: 2004-04-29
Posts: 655
Website

Re: bare minimum groups required during 'adduser'

NTFS in linux still does not have full write support. you can only overwrite an existing file and may not change it in size. read <kernelsource>/Documentation ;p


I recognize that while theory and practice are, in theory, the same, they are, in practice, different. -Mark Mitchell

Offline

#5 2005-03-01 21:18:15

T-Dawg
Forum Fellow
From: Wilmington, NC
Registered: 2005-01-29
Posts: 2,734

Re: bare minimum groups required during 'adduser'

Maybe try umask=0002 0 0 or umask=0007 0 0
for pacman you can get the sudo package and run it as sudo -u root pacman -you_command. The user has to be added to the wheel group and the sudoers config files has to have wheel group uncommented

Offline

#6 2005-03-02 03:11:01

ganja_guru
Member
Registered: 2005-02-14
Posts: 464

Re: bare minimum groups required during 'adduser'

ok umask doesnt seem to work..i managed to get the vfat and backup reiserfs partition to work by removing the default line in fstab and just using the "user" option...however, im still not able to see my ntfs partition...(i dont need to write, just read)

Offline

#7 2005-03-02 06:28:07

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: bare minimum groups required during 'adduser'

Here's the ntfs line from my fstab:

/dev/discs/disc0/part1 /mnt/winxp ntfs noauto,user,ro,umask=022 1 0

Just modify the first two items to reflect your ntfs partition and mount point.

Offline

#8 2005-03-02 07:44:59

ganja_guru
Member
Registered: 2005-02-14
Posts: 464

Re: bare minimum groups required during 'adduser'

thanks...it worked fine!

Offline

#9 2005-03-02 15:53:28

jerem
Member
From: France
Registered: 2005-01-15
Posts: 310

Re: bare minimum groups required during 'adduser'

You can list all available groups with :

cat /etc/group

Usually, here is how a set up a simple user :

useradd username -m -G users,wheel,audio,optical,games -s /bin/bash

Offline

#10 2005-03-02 20:56:27

Gullible Jones
Member
Registered: 2004-12-29
Posts: 4,863

Re: bare minimum groups required during 'adduser'

You'll have to add the games group yourself...

(Hmm... I don't think a games group is needed to play games in Arch by default. I could see why you'd want to set it up that way, but if nobody else is using your box, I don't really see the need. Then again, I am a newbie.)

Also, bash is used as the shell by default, unless my command line is lying to me.

Offline

Board footer

Powered by FluxBB