You are not logged in.

#1 2010-02-15 03:00:05

MJBoa
Member
Registered: 2009-03-31
Posts: 31

[SOLVED] Awesome and GDM

Hey guys,

I'm having a bit of trouble getting GDM and awesome to play nice. What I want to do is set up some applications to start automatically with awesome.
I have in /usr/share/xsessions a file called awesome.desktop and inside is this:
[Desktop Entry]
Encoding=UTF-8
Name=Awesome
Comment=Awesome
TryExec=/usr/local/bin/awesome
Exec=/usr/local/bin/awesome
Type=Application

What I want instead is for it to be something like
Exec=$HOME/.config/awesome/xinitrc

and inside xinitrc will be
gnome-volume-control-applet &
dropbox start &
exec awesome

But when I run this have this, it either resets back to the login screen, logs me into GNOME or just doesn't show the "awesome" entry at all in the session menu.
I assume is has something to do with the $HOME variable but how can I get the home directory of the user logging in otherwise?

Thanks.

Last edited by MJBoa (2010-02-15 03:20:23)

Offline

#2 2010-02-15 03:28:05

gaunt
Member
Registered: 2009-12-13
Posts: 62

Re: [SOLVED] Awesome and GDM

Have you tried just doing whatever you want from rc.lua?

I just dumped this at the end of mine:

function run_once(prg)
    if not prg then
        do return nil end
    end
    awful.util.spawn_with_shell("pgrep -u $USER -x " .. prg .. " || (" .. prg .. ")")
end

run_once("tilda")

Also, look up slim in the wiki.  I know you want GDM, but that article has a really nice xinitrc that might be helpful in some way to you.

EDIT:  my bad, didn't see the solved tag.  sorry.

Last edited by gaunt (2010-02-15 03:28:51)

Offline

#3 2010-02-15 04:11:06

MJBoa
Member
Registered: 2009-03-31
Posts: 31

Re: [SOLVED] Awesome and GDM

Well I just linked to a file in /etc/ to start all my programs, so no per-user configuration. Not really the best solution but I stopped caring.
Unrelated, how well is tilda working for you? Are you using transparency?

Offline

#4 2010-02-15 13:47:51

gaunt
Member
Registered: 2009-12-13
Posts: 62

Re: [SOLVED] Awesome and GDM

Very nicely actually.

The only problem is I accidentally type exit to make it go away instead of it's keybinding.  Transparency works nicely if you set it reasonably low (mine is about 40/50% iirc) and use wallpapers that are fairly monochromatic in that portion of the screen.  One problem is that if you open tilda in certain layouts (might be 'anything but floating' - I know fullscreen does it) awesome and tilda will get into a fight about it's size, but I think that can be fixed in rc.lua by setting tilda to always float.

Offline

#5 2010-02-15 14:38:36

outerdark
Member
From: Germany, Freiburg
Registered: 2007-04-02
Posts: 38

Re: [SOLVED] Awesome and GDM

i'm using xsession for gdm

/usr/share/xsessions/xsession.desktop

[Desktop Entry]
Encoding=UTF-8
Name=Xsession
Comment=oldschool
Exec=/etc/gdm/Xsession custom

ln -s .xinitrc .xsession

and

chmod +x .xsession

et voilà!

Offline

#6 2010-02-23 13:41:02

x33a
Forum Fellow
Registered: 2009-08-15
Posts: 4,586
Website

Re: [SOLVED] Awesome and GDM

outerdark wrote:

i'm using xsession for gdm

/usr/share/xsessions/xsession.desktop

[Desktop Entry]
Encoding=UTF-8
Name=Xsession
Comment=oldschool
Exec=/etc/gdm/Xsession custom

Thanks a lot for this. I had wasted hours trying to get .xsession to work, and this line made my day.

Exec=/etc/gdm/Xsession custom

I wasn't adding custom to the Exec line and that was running the .Xclients script instead.

Offline

Board footer

Powered by FluxBB