You are not logged in.

#1 2005-03-02 14:28:53

ganja_guru
Member
Registered: 2005-02-14
Posts: 464

/sbin/fsck Permission denied > Deep shit.

ok this is like the 2rd time im having this problem, and its happened only in arch:

/etc/rc.sysinit line 57 /sbin/fsck Permission denied


******************FILE SYSTEM CHECK FAILED******************
Please repair manually and reboot

Note that root is mounted  RO ,To remount it RW type :mount -n -o remount,rw. When you exit tjis maintenance shell wil l reboot automatically.

/etc/rc.sysinit => line 71 => /sbin/sulogin ..Permission Denied

Automatic reboot in progress

/bin/umount (umount and reboot too) = permission denied


INIT : Entering Run level 3
INIT : cannot execute "/sbin/agetty"
INIT : cannot execute "/sbin/agetty"
INIT : cannot execute "/sbin/agetty"
INIT : cannot execute "/sbin/agetty"
INIT : cannot execute "/sbin/agetty"
INIT : cannot execute "/sbin/agetty"

INIT : ID "c2" respawning too fast : disabled for 5 minutes
INIT : ID "c3" respawning too fast : disabled for 5 minutes
INIT : ID "c4" respawning too fast : disabled for 5 minutes
INIT : ID "c6" respawning too fast : disabled for 5 minutes
INIT : ID "c1" respawning too fast : disabled for 5 minutes
INIT : ID "c5" respawning too fast : disabled for 5 minutes

INIT: No more processes are left in this runlevel


****************************


( i wrote down all of this , so please forgive me if the format isnt exactly what it should be ) :?

this has happened before, but i never foundout why ...please help..

oh yeah last time this happened i reinstalled...not willing to do it again  big_smile

Offline

#2 2005-03-02 14:47:21

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,751

Re: /sbin/fsck Permission denied > Deep shit.

Use Arch install CD to chroot in , check fstab HTH


Mr Green

Offline

#3 2005-03-02 15:09:48

ganja_guru
Member
Registered: 2005-02-14
Posts: 464

Re: /sbin/fsck Permission denied > Deep shit.

what i usually do is mount the root partition in /mnt ..then check if /mnt/etc/fstab is ok...in this case it is...is this the right way to do it? how do i chroot in ?

Offline

#4 2005-03-02 15:11:39

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,366
Website

Re: /sbin/fsck Permission denied > Deep shit.

ganja_guru wrote:

/etc/rc.sysinit line 57 /sbin/fsck Permission denied

it seems as if rc.sysinit has not the right to run /sbin/fsck - strange!

ganja_guru wrote:

/etc/rc.sysinit => line 71 => /sbin/sulogin ..Permission Denied

very strange

ganja_guru wrote:

Automatic reboot in progress

/bin/umount (umount and reboot too) = permission denied


INIT : Entering Run level 3
INIT : cannot execute "/sbin/agetty"
INIT : cannot execute "/sbin/agetty"
INIT : cannot execute "/sbin/agetty"
INIT : cannot execute "/sbin/agetty"
INIT : cannot execute "/sbin/agetty"
INIT : cannot execute "/sbin/agetty"

INIT : ID "c2" respawning too fast : disabled for 5 minutes
INIT : ID "c3" respawning too fast : disabled for 5 minutes
INIT : ID "c4" respawning too fast : disabled for 5 minutes
INIT : ID "c6" respawning too fast : disabled for 5 minutes
INIT : ID "c1" respawning too fast : disabled for 5 minutes
INIT : ID "c5" respawning too fast : disabled for 5 minutes

INIT: No more processes are left in this runlevel


****************************

what filesystem do you use? i suspect it is ext2. what about a journaling fs? i never had trouble with reiserfs or xfs

it very much looks like either the initscripts are broken handling this situation or your root filesystem is not longer usable (means: /sbin/... is not accessible for some reason)

i have no solution to this situation but for a start you should use knoppix or another life linux to check your drive. you can do this also with the arch installation CD

run fsck manually against your partitions and see what it is doing and what is maybe wrong (use knoppix and you can copy output of the xterm to this forum if you can configure knoppix to access internet)


The impossible missions are the only ones which succeed.

Offline

#5 2005-03-02 15:15:11

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,366
Website

Re: /sbin/fsck Permission denied > Deep shit.

ganja_guru wrote:

what i usually do is mount the root partition in /mnt ..then check if /mnt/etc/fstab is ok...in this case it is...is this the right way to do it? how do i chroot in ?

do not mount it - run fsck against it


The impossible missions are the only ones which succeed.

Offline

#6 2005-03-02 16:17:20

ganja_guru
Member
Registered: 2005-02-14
Posts: 464

Re: /sbin/fsck Permission denied > Deep shit.

no its reiserfs

Offline

#7 2005-03-02 17:00:00

ganja_guru
Member
Registered: 2005-02-14
Posts: 464

Re: /sbin/fsck Permission denied > Deep shit.

ok i did an
$ fsck.reiserfs 

and an

fsck.reiserds --fix-fixable

it said no errors found, and i still get the same error messages..

Offline

#8 2005-03-02 17:06:21

ganja_guru
Member
Registered: 2005-02-14
Posts: 464

Re: /sbin/fsck Permission denied > Deep shit.

oh and the last thing i remember doing was playing around with sudo to set up a user account ...i uncommented the wheel line usine visudo to give any user who is a part of the wheel group full root priveliges...does this have anything to do with it?

Offline

#9 2005-03-02 17:13:08

i3839
Member
Registered: 2004-02-04
Posts: 1,185

Re: /sbin/fsck Permission denied > Deep shit.

What is your filesystem layout? Everything on one partition or is your /etc seperate from /bin and /sbin? Make sure that the files are still executable.

Offline

#10 2005-03-02 17:33:02

ganja_guru
Member
Registered: 2005-02-14
Posts: 464

Re: /sbin/fsck Permission denied > Deep shit.

all are on the same partition...could someone tell me whats the default permissions for /etc  /bin and /sbin in arch? ...is it rwx-r-x-r-x ??

Offline

#11 2005-03-02 18:13:03

i3839
Member
Registered: 2004-02-04
Posts: 1,185

Re: /sbin/fsck Permission denied > Deep shit.

Yes, it's drwxr-xr-x. What is the permission of, for instance, /sbin/agetty? Is it -rwxr-xr-x?

And this weirdness happened before? Ugh, did you run memtest and checked for badblocks? E.g. badblocks -n /dev/rootpartition.

Offline

#12 2005-03-02 19:35:38

ganja_guru
Member
Registered: 2005-02-14
Posts: 464

Re: /sbin/fsck Permission denied > Deep shit.

ok im doing a badblocks -n /dev/hda3 now.... the permissions for /sbin/agetty are fine -rwx-r-x-r-x-

Offline

#13 2005-03-02 19:37:11

ganja_guru
Member
Registered: 2005-02-14
Posts: 464

Re: /sbin/fsck Permission denied > Deep shit.

shouldn't i just be able to change the permissions of something and get things back again?could this have somethin to do with sudo?

Offline

#14 2005-03-02 20:06:32

i3839
Member
Registered: 2004-02-04
Posts: 1,185

Re: /sbin/fsck Permission denied > Deep shit.

/etc/rc.sysinit is executed by /sbin/init as user root, sudo isn't used anywhere.

It's so strange that it looks like broken hardware somewhere, like filesystem corruption caused by bad memory (overheating?) or plain simple bad hd. Though it may be as wel something else silly.

No warnings or errors in the kernel log while booting? And what is the very first error you get while booting?

Although unlikely, are you sure that your udev config is correct? There were some recent changes which had a big impact on the config.

Offline

#15 2005-03-03 00:51:43

skoal
Member
From: Frequent Flyer Underworld
Registered: 2004-03-23
Posts: 612
Website

Re: /sbin/fsck Permission denied > Deep shit.

Well, it's just quite likely that you've corrupted your `/etc/passwd` file, by file system error luck or something else.  If you had a boot disk you could issue a `passwd` to restore the root password.

Boot from floppy, mount the hd under your floppy `/mnt`, and change into that directory.  Chroot by:  "chroot . /bin/bash".  Then, issue the `passwd` command to restore your passwd and associated shadow files.

You could also try to pass "init=/bin/bash" to the grub or lilo menu.  For grub, just hit "e" and add that option.  That will skip the init process and login as well, taking you to bash.  Then try and fix your passwd file that way.  Be sure to change your grub or lilo entry back after you fix it.

It's always nice to have a second partition with a minimal Linux installation for cases like this.  IE. /dev/hda1 = Arch Rescue (<100MB), and /dev/hda2 = Arch (full blown).  That way you can fsck that other unmounted bastard with ease.  Ideally, it's nice to have a second HD with a linux partition on it.

Offline

#16 2005-03-03 04:25:41

ganja_guru
Member
Registered: 2005-02-14
Posts: 464

Re: /sbin/fsck Permission denied > Deep shit.

tried chroot thing and changed the passwd ....didnt help..

it fails here:

starting Devfs Daemon : Ok
Activating Swap : Ok
Mounting Read Only : Ok
checking file system .....hear it flashes the messages which i mentioned in the first post..

init=/bin/bash in lilo gets me into bash, but what do i do after that?chroot doesnt work when i use init=/bin/bash...so i did the chroot thing using the mepis live cd

other things im not too sure of:

most files under /sbin /bin and /etc are -rwx-rx-rx-...expect:

/bin/ps which is r-xr-xr-x
/sbin/unix_chkpwd -r-sr-xr-x

is that abnormal?

thanks for all the replies!

Offline

#17 2005-03-03 05:38:03

skoal
Member
From: Frequent Flyer Underworld
Registered: 2004-03-23
Posts: 612
Website

Re: /sbin/fsck Permission denied > Deep shit.

Hmm...

post your `/etc/fstab` here.

Make sure that your "reiserfs" root partition has something like this:

/dev/discs/disc0/part3 / reiserfs defaults 0 0

* Change the first part to match your partition information...

Are you still getting fsck errors? or just "agetty" respawn crap?

and, yes, those last 2 files you asked about have the proper permissions, including your `/sbin` and `/bin` paths.

Offline

#18 2005-03-03 05:54:39

ganja_guru
Member
Registered: 2005-02-14
Posts: 464

Re: /sbin/fsck Permission denied > Deep shit.

# This file is edited by fstab-sync - see 'man fstab-sync' for details
#
# /etc/fstab: static file system information
#
# <file system>        <dir>         <type>    <options>          <dump> <pass>
none                   /dev/pts      devpts    defaults            0      0
none                   /dev/shm      tmpfs     defaults            0      0
tmpfs                  /tmp          tmpfs     defaults            0      0
usbfs                  /proc/bus/usb usbfs  defaults            0      0

/dev/cdroms/cdrom0     /mnt/dvd   iso9660   ro,user,noauto,unhide   0      0
/dev/cdroms/cdrom1     /mnt/rw    iso9660   ro,user,noauto,unhide   0      0
/dev/floppy/0          /mnt/fl    vfat      user,noauto             0      0

/dev/discs/disc0/part4         swap        swap      defaults          0 0
/dev/discs/disc0/part3         /           reiserfs  defaults,user     0 0
/dev/discs/disc0/part2         /backup     reiserfs  user              0 0
/dev/discs/disc1/part1         /d          vfat      user              0 0
/dev/discs/disc0/part1         /c          ntfs      user,ro,umask=022 0 0
/dev/sda2                      /mnt/ipod   vfat      defaults,noauto,user,rw  0  0
/dev/sdb                       /mnt/cfdisk vfat      defaults,noauto,user,rw  0  0

Offline

#19 2005-03-03 06:05:23

ganja_guru
Member
Registered: 2005-02-14
Posts: 464

Re: /sbin/fsck Permission denied > Deep shit.

ok i figured it out....it was cause of this line

/dev/discs/disc0/part3 / reiserfs defaults,user 0 0

basically the user part...so i just removed the user line and left it as

/dev/discs/disc0/part3 / reiserfs defaults 0 0

and everything is great again..thanks for the fstab pointer!

Offline

#20 2005-03-03 06:28:43

skoal
Member
From: Frequent Flyer Underworld
Registered: 2004-03-23
Posts: 612
Website

Re: /sbin/fsck Permission denied > Deep shit.

Ah, indeed.  Someone's been "playing with fire" in their "fstab" recently, I can tell...

From the "mount" man pages:

user implies the options noexec, nosuid, and nodev...

No worries...looks like you medicated your 3rd degree computer burn with a skin graft.  I still smell smoke in some of those other partitions.  I've never seen anyone use those options together like that before.  But, smoke normally doesn't imply fire...

I guess using "defaults" with "noauto" and "user" gets overidden by the latter.  If it ain't broke...you know the old saying...

* By the way, I'm glad you finally stepped out of the "cow patty" (your subject line).  I've been there before.  It stinks...

Offline

#21 2005-03-03 06:39:47

ganja_guru
Member
Registered: 2005-02-14
Posts: 464

Re: /sbin/fsck Permission denied > Deep shit.

looks like its time for me to actually read the mount man pages..(too lazy to do it so far )  : P

yup...shit stinks.

Offline

Board footer

Powered by FluxBB