You are not logged in.

#1 2005-03-04 02:59:07

T-Dawg
Forum Fellow
From: Wilmington, NC
Registered: 2005-01-29
Posts: 2,734

fontconfig 2.3.0-2

has anyone else experienced blurred letters and jumbo-sized console font with this new update? Just wondering if its something I need to configure correctly on my end.

Offline

#2 2005-03-04 03:32:09

MNKyDeth
Member
From: MI
Registered: 2003-09-13
Posts: 89

Re: fontconfig 2.3.0-2

I updated to the 2.3.0-1 before the -02 came out and the fonts have never looked better on my machine. it was a big surprise when I re-logged in on my end.

With you saying that they are fuzzy kinda scares me that I'll loose the best looking font setup in Arch I ever had lol. Guess I'll have to try it once then go back if there are issues, I'll let you know how I fare.

Offline

#3 2005-03-04 03:42:16

stonecrest
Member
From: Boulder
Registered: 2005-01-22
Posts: 1,190

Re: fontconfig 2.3.0-2

I'm having font problems too after the update :? The verdana font that is on a lot of websites is very small for me now. Someone on IRC said that the update (I don't know if it's -1 or -2, presumably -1) overwrites your /etc/fonts config files. Apparently his fix was to change "autohint" in /etc/fonts/local.conf to false. I haven't tried it yet.


I am a gated community.

Offline

#4 2005-03-04 03:51:13

T-Dawg
Forum Fellow
From: Wilmington, NC
Registered: 2005-01-29
Posts: 2,734

Re: fontconfig 2.3.0-2

...hmm I had 2.2.3-1 before any of this and it was fine. Yeah its definitely 'autohinting' way too much. I noticed the smaller fonts in web pages too. I'll try that suggestion.

Offline

#5 2005-03-04 03:58:09

MNKyDeth
Member
From: MI
Registered: 2003-09-13
Posts: 89

Re: fontconfig 2.3.0-2

Just tried the -2 version and I don't see any difference in my stuff from the -1 version. Maybe it is DE/WM specific?  I am using Enlightenment, I havn't tried any otehr WM/DE's yet though.

Offline

#6 2005-03-04 04:06:06

T-Dawg
Forum Fellow
From: Wilmington, NC
Registered: 2005-01-29
Posts: 2,734

Re: fontconfig 2.3.0-2

dont know..I tried switching autohint value to false and its normal again. Except for that dopey terminal font.

Offline

#7 2005-03-04 04:08:43

stonecrest
Member
From: Boulder
Registered: 2005-01-22
Posts: 1,190

Re: fontconfig 2.3.0-2

Switching autohint to false worked for me too, everything is back to normal smile


I am a gated community.

Offline

#8 2005-03-04 04:21:58

dk
Member
Registered: 2004-04-20
Posts: 106

Re: fontconfig 2.3.0-2

The latest uprgade made my fonts look terrible. I just happend to have  /etc/fonts/local.conf.bak  smile  I switched back and all the fonts look good again.


<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<!-- /etc/fonts/local.conf file for local customizations -->
<fontconfig>
<--
Disable anti-aliasing for fonts that are size <=12
        <match target="pattern">
                <test qual="any" name="size" compare="less_eq">
                        <int>12</int>
                </test>
                <edit name="antialias" mode="assign"><bool>false</bool></edit>
        </match>
-->
<--
  Enable sub-pixel rendering
        <match target="font">
                <test qual="all" name="rgba">
                        <const>unknown</const>
                </test>
                <edit name="rgba" mode="assign"><const>rgb</const></edit>
        </match>
-->
<--
        <match target="pattern">
                 <edit name="dpi" mode="assign"><double>100</double></edit>
         </match>
-->

</fontconfig>

Offline

#9 2005-03-04 04:28:00

neotuli
Lazy Developer
From: San Francisco, CA
Registered: 2004-07-06
Posts: 1,201
Website

Re: fontconfig 2.3.0-2

Yea I was the one from the irc and it was definitly autohinting. My oversized font issues went away with that as well. I'm thininking that I'm obligated to say that we can prevent this in the future (no..it's not the first time) by simply adding something like this to our /etc/pacman.conf's:

NoUpgrade = etc/fonts/fonts.conf etc/fonts/local.conf

The suggestion box only accepts patches.

Offline

#10 2005-03-04 04:54:40

T-Dawg
Forum Fellow
From: Wilmington, NC
Registered: 2005-01-29
Posts: 2,734

Re: fontconfig 2.3.0-2

Yep, tested it that works neotuli. I'm still getting the strange fonts in Konsole though....anyone else?

Offline

#11 2005-03-04 10:22:08

torindan2
Member
Registered: 2004-07-15
Posts: 74

Re: fontconfig 2.3.0-2

I also saw a big change in how my fonts look now.
I like it, but it looks like X is somehow slow... very visible when I move a window (100% of CPU).
I have a P3-600MHz...crappy Savage4 (8Mb = no DRI)..so it sucks.

Any ideas how to improve it?

Offline

#12 2005-03-04 13:22:18

iphitus
Forum Fellow
From: Melbourne, Australia
Registered: 2004-10-09
Posts: 4,927

Re: fontconfig 2.3.0-2

heh, my fonts have never looked better!

Offline

#13 2005-03-04 23:55:15

cascat
Member
Registered: 2004-02-24
Posts: 62

Re: fontconfig 2.3.0-2

I agree.  My fonts have never looked better.  Now if I can just get hal and my cdwriter to get along with each other.  Looking forward to the radeon "dri" improvements in 2.6.11.

Offline

#14 2005-03-05 01:42:16

puntmuts
Member
Registered: 2005-02-22
Posts: 138

Re: fontconfig 2.3.0-2

They looked different, but I did not any configuration of my fonts yet. But after setting some options regarding anti aliasing and subpixel hinting they never looked better. big_smile


Out / Gone
Mirgrating all my machines off ArchLinux . No longer part of the ArchLinux community / users .
Done. Goodbye.

Offline

#15 2005-03-05 02:09:07

z4ziggy
Member
From: Israel
Registered: 2004-03-29
Posts: 573
Website

Re: fontconfig 2.3.0-2

smile tnx for this tip my eyes dont hurt anymore... i just couldnt look at the screen for the last 20 minutes since my last update... but its all ok now... tnx smile

Offline

#16 2005-03-05 16:08:23

noah
Member
Registered: 2005-02-23
Posts: 14

Re: fontconfig 2.3.0-2

Font issues will be different depending on whether or not you are using imported MS true type fonts.  If you are, the new fontconfig will mess up the beautiful anti-aliasing already enabled by freetype 2.1.9 compiled with bytecode interpreter enabled.

If you are using only distro-supplied fonts, the new fontconfig makes them look better (but at the expense of most imported TTF fonts).

Also, if you are a kde user, the new fontconfig will break some of the font locations for fonts you've added with the kcontrol font installer (such as the terminal font that allows the "linux" font to work for console.

Here's my local.conf from a slackware install.  Copying this to arch fixed everything back to normal for me (TTF's installed, KDE user):

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
 <dir>/usr/local/share/fonts</dir>
 <dir>/usr/X11R6/lib/X11/fonts</dir>
 <dir>/usr/share/fonts</dir>
</fontconfig>

You really don't need the anti-aliasing info in local.conf - just the font directories.

Offline

#17 2005-03-05 16:20:04

sorcerer
Member
Registered: 2005-02-25
Posts: 18

Re: fontconfig 2.3.0-2

thx, for the autohinting tip, i couldn't find what happend to my fonts either smile

Offline

Board footer

Powered by FluxBB