You are not logged in.

#1 2010-02-24 08:43:45

Hesam
Member
Registered: 2010-02-14
Posts: 24

Screen settings when booting up

When I turn on the machine after GRUB there is a screen when Arch is loading. In the middle of this process the screen resolution changes and the formatting of the text gets screwy then it changes yet another time and then finally you get to the login screen. This is not exactly a bug but it does bother me so anyway of fixing this?

Offline

#2 2010-02-24 09:04:08

hw-tph
Member
Registered: 2006-11-01
Posts: 149

Re: Screen settings when booting up

That would be kernel modesetting at work. With Intel graphics, this is default behaviour since 2.6.32 I believe (prior to this release you needed to enabled it manually). With Intel graphics you can disable it with i915.modeset=0 on the kernel line in grub's menu.lst, but this will break X.

Offline

#3 2010-02-24 09:12:51

Hesam
Member
Registered: 2010-02-14
Posts: 24

Re: Screen settings when booting up

With Intel graphics you can disable it with i915.modeset=0 on the kernel line in grub's menu.lst, but this will break X.

so no fix then :(

Offline

#4 2010-02-24 09:35:37

loafer
Member
From: the pub
Registered: 2009-04-14
Posts: 1,757

Re: Screen settings when booting up

Look at KMS in the Wiki, it tells you how to enable it earlier in the boot process.


All men have stood for freedom...
For freedom is the man that will turn the world upside down.
Gerrard Winstanley.

Offline

#5 2010-02-24 10:27:59

Hesam
Member
Registered: 2010-02-14
Posts: 24

Re: Screen settings when booting up

Look at KMS in the Wiki, it tells you how to enable it earlier in the boot process.

hw-tph is saying that this will break X though.

Offline

#6 2010-02-24 10:32:13

loafer
Member
From: the pub
Registered: 2009-04-14
Posts: 1,757

Re: Screen settings when booting up

He is talking about disabling it.

 It is possible however to enable KMS during bootstrap itself, allowing the entire boot process to run at native resolution. 

Note: When using KMS, you must remove any references to "vga" or "video" from the kernel line in /boot/grub/menu.lst
Add the intel_agp and i915 modules to the MODULES line in /etc/mkinitcpio.conf: 

MODULES="intel_agp i915"
Now, regenerate the initramfs: 

# mkinitcpio -p kernel26

This worked for me.


All men have stood for freedom...
For freedom is the man that will turn the world upside down.
Gerrard Winstanley.

Offline

#7 2010-02-24 12:47:54

hw-tph
Member
Registered: 2006-11-01
Posts: 149

Re: Screen settings when booting up

Hesam wrote:

Look at KMS in the Wiki, it tells you how to enable it earlier in the boot process.

hw-tph is saying that this will break X though.

No, entirely disabling kernel modesetting will break xf86-video-intel version 2.10.

Offline

#8 2010-02-24 14:28:49

Hesam
Member
Registered: 2010-02-14
Posts: 24

Re: Screen settings when booting up

loafer your advice worked :)

Initially I was confused because I misunderstood hw-tph's comment (mixing up enabling and disabling). Thanks everyone.

Offline

Board footer

Powered by FluxBB