You are not logged in.

#301 2010-02-27 11:00:48

neubauten84
Member
Registered: 2010-02-27
Posts: 49

Re: gnome unstable repository

local/pango 1.27.1-1
    A library for layout and rendering of text
local/pangomm 2.26.0-1
    C++ bindings for pango

Offline

#302 2010-02-27 11:43:50

combuster
Member
From: Serbia
Registered: 2008-09-30
Posts: 711
Website

Re: gnome unstable repository

Just try pacman -S pango , I had similar problem with atk untill I reinstalled it...

Offline

#303 2010-02-27 17:43:35

neubauten84
Member
Registered: 2010-02-27
Posts: 49

Re: gnome unstable repository

Ok..after reinstalling pango th error changes:

[neubauten84@~]$ gnome-shell --replace
    JS ERROR: !!!   Exception was: Error: Requiring Gdk, version none: Typelib file for namespace 'Gdk' (any version) not found
    JS ERROR: !!!     lineNumber = '0'
    JS ERROR: !!!     fileName = 'gjs_throw'
    JS ERROR: !!!     stack = 'Error("Requiring Gdk, version none: Typelib file for namespace 'Gdk' (any version) not found")@:0
("Requiring Gdk, version none: Typelib file for namespace 'Gdk' (any version) not found")@gjs_throw:0
@/usr/share/gnome-shell/js/ui/main.js:5
'
    JS ERROR: !!!     message = 'Requiring Gdk, version none: Typelib file for namespace 'Gdk' (any version) not found'
    JS ERROR: !!!   Exception was: Error: Requiring Gdk, version none: Typelib file for namespace 'Gdk' (any version) not found
    JS ERROR: !!!     lineNumber = '0'
    JS ERROR: !!!     fileName = 'gjs_throw'
    JS ERROR: !!!     stack = 'Error("Requiring Gdk, version none: Typelib file for namespace 'Gdk' (any version) not found")@:0
("Requiring Gdk, version none: Typelib file for namespace 'Gdk' (any version) not found")@gjs_throw:0
@/usr/share/gnome-shell/js/ui/main.js:5
Error("Chained exception")@:0
("Chained exception")@gjs_throw:0
@<main>:1
'
    JS ERROR: !!!     message = 'Requiring Gdk, version none: Typelib file for namespace 'Gdk' (any version) not found'
Avviso del window manager: Log level 32: Execution of main.js threw exception: Error: Requiring Gdk, version none: Typelib file for namespace 'Gdk' (any version) not found

but it doesn't start!!

Offline

#304 2010-02-27 17:48:03

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: gnome unstable repository

Gdk-2.0.gir is owned by gtk2 2.19.6-1

reinstall that. i don't know what happened on your system.


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#305 2010-02-27 17:56:19

neubauten84
Member
Registered: 2010-02-27
Posts: 49

Re: gnome unstable repository

I think the problem is that I used gnome-shell-git & dependencies..perhaphs removing them I made the crack!!!!

EDIT:
Now the problem is on Meta:

    JS ERROR: !!!   Exception was: Error: Requiring Meta, version none: Typelib file for namespace 'Atk', version '1.0' not found
    JS ERROR: !!!     lineNumber = '0'
    JS ERROR: !!!     fileName = 'gjs_throw'
    JS ERROR: !!!     stack = 'Error("Requiring Meta, version none: Typelib file for namespace 'Atk', version '1.0' not found")@:0
("Requiring Meta, version none: Typelib file for namespace 'Atk', version '1.0' not found")@gjs_throw:0
@/usr/share/gnome-shell/js/ui/main.js:10
'
    JS ERROR: !!!     message = 'Requiring Meta, version none: Typelib file for namespace 'Atk', version '1.0' not found'
    JS ERROR: !!!   Exception was: Error: Requiring Meta, version none: Typelib file for namespace 'Atk', version '1.0' not found
    JS ERROR: !!!     lineNumber = '0'
    JS ERROR: !!!     fileName = 'gjs_throw'
    JS ERROR: !!!     stack = 'Error("Requiring Meta, version none: Typelib file for namespace 'Atk', version '1.0' not found")@:0
("Requiring Meta, version none: Typelib file for namespace 'Atk', version '1.0' not found")@gjs_throw:0
@/usr/share/gnome-shell/js/ui/main.js:10
Error("Chained exception")@:0
("Chained exception")@gjs_throw:0
@<main>:1
'
    JS ERROR: !!!     message = 'Requiring Meta, version none: Typelib file for namespace 'Atk', version '1.0' not found'
Avviso del window manager: Log level 32: Execution of main.js threw exception: Error: Requiring Meta, version none: Typelib file for namespace 'Atk', version '1.0' not found
[

What can I do?
I'm really sorry..Tks

Last edited by neubauten84 (2010-02-27 17:58:45)

Offline

#306 2010-02-27 18:01:39

flamelab
Member
From: Athens, Hellas (Greece)
Registered: 2007-12-26
Posts: 2,160

Re: gnome unstable repository

wonder wrote:

Gdk-2.0.gir is owned by gtk2 2.19.6-1

reinstall that. i don't know what happened on your system.

Wonder, where can I find the gnome-shell PKGBUILD so that I can update the gnome-shell-git's dependencies accordingly ? smile

Offline

#307 2010-02-27 18:11:53

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: gnome unstable repository

flamelab wrote:
wonder wrote:

Gdk-2.0.gir is owned by gtk2 2.19.6-1

reinstall that. i don't know what happened on your system.

Wonder, where can I find the gnome-shell PKGBUILD so that I can update the gnome-shell-git's dependencies accordingly ? smile

http://repos.archlinux.org/wsvn/package … ell/trunk/


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#308 2010-02-27 18:12:42

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: gnome unstable repository

neubauten84 wrote:

I think the problem is that I used gnome-shell-git & dependencies..perhaphs removing them I made the crack!!!!
What can I do?
I'm really sorry..Tks

reinstall atk


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#309 2010-02-27 18:23:49

neubauten84
Member
Registered: 2010-02-27
Posts: 49

Re: gnome unstable repository

Perfect!
Now it started!
Just another question: I installed gir-repository even if it wasn't a dep, can I remove it?
Tks!

Offline

#310 2010-02-27 18:37:47

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: gnome unstable repository

neubauten84 wrote:

Perfect!
Now it started!
Just another question: I installed gir-repository even if it wasn't a dep, can I remove it?
Tks!

yes


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#311 2010-03-01 19:33:08

frosth
Member
Registered: 2010-02-13
Posts: 6

Re: gnome unstable repository

meijin wrote:

gnome-shell look awesome. just one question:
how can i start it not with gnome-shell --replace?
is it possible that compiz-icon/gdm will recognize it automaticly and give me the option?

BTW, the new icons are really looking great.

Assaf

try gconf-editor


DESKTOP->GNOME->SESSION->reqired_comp.... ->windowmanager     and replace metacity with gnome-shell
for me it's working
i dont know what  GDM do to recognize sessions but if you find solution, tell me

Offline

#312 2010-03-09 10:37:04

combuster
Member
From: Serbia
Registered: 2008-09-30
Posts: 711
Website

Re: gnome unstable repository

I have a problem with desktop zooming out after changing fonts or creating a new file on desktop, white vertical lines pop up on left and right side of the desktop.

Offline

#313 2010-03-11 13:20:16

dieghen89
Member
From: Italy
Registered: 2009-06-24
Posts: 134

Re: gnome unstable repository

I can't see the close-minimize-maximize buttons in metacity theme after the upgrade in my eeepc....Nobody has the same problem??

scrotq.png


XPS 13 DE 2015 + K*5
"Machines are so stupid that if you tell them to do something perfect, they'll do it"

Offline

#314 2010-03-12 16:03:17

Giselher
Member
From: Austria
Registered: 2010-02-02
Posts: 150
Website

Re: gnome unstable repository

dieghen89 wrote:

I can't see the close-minimize-maximize buttons in metacity theme after the upgrade in my eeepc....Nobody has the same problem??

http://img214.imageshack.us/img214/1592/scrotq.png

In GConf you can change the buttons.

/apps/metacity/general/button_layout

EDIT
Mine is         :minimize,maximize,close
With Icon:    menu:minimize,maximize,close

Last edited by Giselher (2010-03-12 16:04:21)

Offline

#315 2010-03-12 16:21:57

dieghen89
Member
From: Italy
Registered: 2009-06-24
Posts: 134

Re: gnome unstable repository

I haven't that key so I've created it...Thank you Giselher! Now works!! wink


XPS 13 DE 2015 + K*5
"Machines are so stupid that if you tell them to do something perfect, they'll do it"

Offline

#316 2010-03-12 16:43:49

Giselher
Member
From: Austria
Registered: 2010-02-02
Posts: 150
Website

Re: gnome unstable repository

dieghen89 wrote:

I haven't that key so I've created it...Thank you Giselher! Now works!! wink

You're Welcome. cool


Transparancy and 3d support is broken in gnome-shell but works in gnome.

Offline

#317 2010-03-13 00:02:28

ahioros
Member
From: Panamá
Registered: 2005-11-26
Posts: 41
Website

Re: gnome unstable repository

Where i can find all PKGBUILD? , gnome-media it's compile with pulse flag enable?..

Offline

#318 2010-03-13 01:31:25

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: gnome unstable repository

ahioros wrote:

Where i can find all PKGBUILD? , gnome-media it's compile with pulse flag enable?..

search for gnome-media or other packages on our front page and i'll find a link in the right for trunk. No pulse support in this version big_smile

Last edited by wonder (2010-03-13 01:34:26)


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#319 2010-03-13 01:51:22

ahioros
Member
From: Panamá
Registered: 2005-11-26
Posts: 41
Website

Re: gnome unstable repository

Tnks wonder :-)

Offline

#320 2010-03-13 20:28:44

descendent87
Member
From: Wales
Registered: 2009-07-23
Posts: 105
Website

Re: gnome unstable repository

Thanks for these, apart from gnome-media what other packages need to have pulse enabled?

Offline

#321 2010-03-13 21:15:35

napsy
Member
Registered: 2009-03-07
Posts: 48

Re: gnome unstable repository

I installed gnome-unstable. But now metacity won't run and I have borderless windows. If I manually run metacity I get:

% metacity
Window manager warning: "(null)", that was found in the database isn't a valid modifier for mouse buttons.
Window manager warning: could not parse description "(null)" from GConf key /apps/metacity/general/titlebar_font
Window manager warning: 0 saved in GConf key /apps/metacity/general/num_workspaces is not between 1 and 36
**
metacity:ERROR:core/prefs.c:2482:meta_prefs_get_workspace_name: assertion failed: (workspace_names[i] != NULL)

I translated the output from my language to english so it's not quote on quote.

Offline

#322 2010-03-15 16:10:22

jorchube
Member
Registered: 2009-04-05
Posts: 55

Re: gnome unstable repository

napsy wrote:

I installed gnome-unstable. But now metacity won't run and I have borderless windows. If I manually run metacity I get:

% metacity
Window manager warning: "(null)", that was found in the database isn't a valid modifier for mouse buttons.
Window manager warning: could not parse description "(null)" from GConf key /apps/metacity/general/titlebar_font
Window manager warning: 0 saved in GConf key /apps/metacity/general/num_workspaces is not between 1 and 36
**
metacity:ERROR:core/prefs.c:2482:meta_prefs_get_workspace_name: assertion failed: (workspace_names[i] != NULL)

I translated the output from my language to english so it's not quote on quote.

I think that you should install and use mutter... but  I'm not sure if in gnome 2.30 is default, or still is supposed to use metacity

Last edited by jorchube (2010-03-15 16:11:19)

Offline

#323 2010-03-20 19:58:41

ahioros
Member
From: Panamá
Registered: 2005-11-26
Posts: 41
Website

Re: gnome unstable repository

descendent87 wrote:

Thanks for these, apart from gnome-media what other packages need to have pulse enabled?

just gnome-media with enable pulseaudio flag and follow this http://wiki.archlinux.org/index.php/Pulseaudio :-)

Offline

#324 2010-03-29 15:53:04

blasse
Member
From: Poland
Registered: 2008-04-24
Posts: 303

Re: gnome unstable repository

Hi, according to namcap with have some not needed dependencies:

[sigma@blasse-laptop ~]$ namcap /var/cache/pacman/pkg/gnome-terminal-2.30.0-1-x86_64.pkg.tar.xz 
gnome-terminal W: Dependency 'glib2' on your system is a testing release
gnome-terminal W: Dependency included and not needed ('libgnome')

btw. I thought libgnome will be deprecated since 2.30? (I'm trying to get rid of gnome-vfs to deal with hal dependencies) smile


Proud ex-maintainer of firefox-pgo

Offline

#325 2010-03-29 16:20:35

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: gnome unstable repository

blasse wrote:

Hi, according to namcap with have some not needed dependencies:

[sigma@blasse-laptop ~]$ namcap /var/cache/pacman/pkg/gnome-terminal-2.30.0-1-x86_64.pkg.tar.xz 
gnome-terminal W: Dependency 'glib2' on your system is a testing release
gnome-terminal W: Dependency included and not needed ('libgnome')

btw. I thought libgnome will be deprecated since 2.30? (I'm trying to get rid of gnome-vfs to deal with hal dependencies) smile

http://bugs.archlinux.org/task/18561


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

Board footer

Powered by FluxBB