You are not logged in.

#1 2005-03-01 03:58:32

lazychris2000
Member
Registered: 2004-11-29
Posts: 35

MP3=Crash

Whenever I try to play an audio file (mp3, wav, ogg, etc), my computer crashes.  the entire thing locks up and makes me feel like im using windows (minus the blue screen).  it happens no matter what program i use to listen to 'em.....rhythmbox, mplayer, muine, mpg123, you name it, it doesnt work.  it also crashes when i try to plat games with sound, mainly ut2004.  it also crashes 50% of the time when i watch movies...dvd's, avi's, etc....i tried reinstalling mplayer and rhythmbox and gstreamer.  my roommate suggested i run 'gst-register-0.8' to load all the plugins an such....that worked up until i tried to watch a dvd, then after rebooting, it still didnt work.  this is very annoying because what good is a computer if you cant listen to music, watch movies, and play games? :x
It worked perfectly before i broke my install and had to reinstall arch.  ive also had no problems with suse, mandrake, fedora, knoppix, and ubuntu.
does anyone have any suggestions?
im running arch .7, kernel 2.6.10, CMedia sound card, alsa 1.0.8-1, gnome 2.8
if you need more information, feel free to ask


Arch .7.1, 2.6.15, 1024 MB PC2700, Athlon XP 2600+, Soyo KT400 Dragon Ultra Platinum, NVIDIA GeForceFX 5700 256MB

Compaq Armada E500--Arch .7.1, 2.6.14, 256MB PC100, 900MHz PIII, Netgear WG511T

Offline

#2 2005-03-01 04:09:47

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: MP3=Crash

can you play wav files?

try using aplay...

also, try:

# cat /dev/urandom > /dev/dsp

t see if you get any sound output (ctrl+c to stop)

Offline

#3 2005-03-01 04:25:57

lazychris2000
Member
Registered: 2004-11-29
Posts: 35

Re: MP3=Crash

i got a buncha static when i did that...no crash, either  big_smile, but mp3s and oggs still crash


Arch .7.1, 2.6.15, 1024 MB PC2700, Athlon XP 2600+, Soyo KT400 Dragon Ultra Platinum, NVIDIA GeForceFX 5700 256MB

Compaq Armada E500--Arch .7.1, 2.6.14, 256MB PC100, 900MHz PIII, Netgear WG511T

Offline

#4 2005-03-01 04:48:13

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: MP3=Crash

lazychris2000 wrote:

i got a buncha static when i did that...no crash, either  big_smile, but mp3s and oggs still crash

yeah it should give you static and crap.. so your sound setup works, I guess, but there may be a library error...

Offline

#5 2005-03-07 00:01:21

T-Dawg
Forum Fellow
From: Wilmington, NC
Registered: 2005-01-29
Posts: 2,734

Re: MP3=Crash

Just curious, what version of flac do you have? When I got the update for 1.1.2, it gave me problems with xmms. My only solution was to downgrade.

Offline

#6 2005-03-07 02:57:56

lazychris2000
Member
Registered: 2004-11-29
Posts: 35

Re: MP3=Crash

i uninstalled the alsa that i pacmaned, then recompiled alsa using ./configure --with-card=cmipci (i think thats the command)....after that was done, i rebooted (just to be sure everything reloaded), it worked up until i did a pacman -Syu....then it locked up....im running alsa 1.0.8

penguin, i got flac 1.1.1....altho, im not entirely sure how flac would affect my computer.....do mp3 players use it or something?  as you can tell, im not very experienced with flac....

hope that helps......right now, i have my walkman hooked up to my speakers so i can have some music.....the UT withdrawl is starting to set in....


Arch .7.1, 2.6.15, 1024 MB PC2700, Athlon XP 2600+, Soyo KT400 Dragon Ultra Platinum, NVIDIA GeForceFX 5700 256MB

Compaq Armada E500--Arch .7.1, 2.6.14, 256MB PC100, 900MHz PIII, Netgear WG511T

Offline

#7 2005-03-07 03:48:12

T-Dawg
Forum Fellow
From: Wilmington, NC
Registered: 2005-01-29
Posts: 2,734

Re: MP3=Crash

flac is a codec similar to mp3 except it uses lossless compression. I knew there was a bug with 1.1.2 that wouldn't even let me open xmms on my box....just thought it was worth looking into. smile

Offline

#8 2005-03-07 04:44:29

lazychris2000
Member
Registered: 2004-11-29
Posts: 35

Re: MP3=Crash

good to know.....thanks for the info!


Arch .7.1, 2.6.15, 1024 MB PC2700, Athlon XP 2600+, Soyo KT400 Dragon Ultra Platinum, NVIDIA GeForceFX 5700 256MB

Compaq Armada E500--Arch .7.1, 2.6.14, 256MB PC100, 900MHz PIII, Netgear WG511T

Offline

Board footer

Powered by FluxBB