You are not logged in.

#101 2010-03-05 20:04:09

Daenyth
Forum Fellow
From: Boston, MA
Registered: 2008-02-24
Posts: 1,244

Re: Plymouth is working! How to have a great splash in your box

The patch to the encrypt hook doesn't work. That's why it didn't apply. Use the second url I posted, it has the source files. The non-applying patch I meant was the one for plymouth-update-initrd (which you don't even need). After installing, replace "encrypt" with "plymouth-encrypt" in mkinitcpio.conf.

I recommend setting a new initrd preset; I made a kernel26-plymouth one so that I could regen it and still have my normal initrd bootable as a fallback.

Offline

#102 2010-03-06 10:53:18

goran'agar
Member
From: Nothern Italy
Registered: 2009-05-19
Posts: 167

Re: Plymouth is working! How to have a great splash in your box

Daenyth wrote:

The patch to the encrypt hook doesn't work. That's why it didn't apply. Use the second url I posted, it has the source files. The non-applying patch I meant was the one for plymouth-update-initrd (which you don't even need). After installing, replace "encrypt" with "plymouth-encrypt" in mkinitcpio.conf.

I recommend setting a new initrd preset; I made a kernel26-plymouth one so that I could regen it and still have my normal initrd bootable as a fallback.

Will try and report back, thanks.

OK. This is what I've been able to test so far.

First, I think there's a typo in /lib/initcpio/install/plymouth-encrypt: the "SCRIPT=" entry should eval to "plymouth-encrypt" instead of "encrypt", otherwise the password prompt never fires.

Second: the password dialog seems not working for me: the box appears, if I type some characters the points are printed within the box but the password is not accepted. Pressing ESC to switch back to the text console does not change the situation (even worse, after the third failed attempt the kernel panics (in the i915module).

Third, plymouth+decryption-with-usb-key works perfectly.

Hope this helps.

Last edited by goran'agar (2010-03-06 13:13:39)


Sony Vaio VPCM13M1E  - Arch Linux - ZFS - Syslinux - XFCE .
Samsung SGS - CM10.1 - Semaphore 2.8.0 .

Offline

#103 2010-03-06 16:09:22

Daenyth
Forum Fellow
From: Boston, MA
Registered: 2008-02-24
Posts: 1,244

Re: Plymouth is working! How to have a great splash in your box

Are you sure you used the *second* link and not the first? Those should both be fixed.

Offline

#104 2010-03-06 17:14:26

goran'agar
Member
From: Nothern Italy
Registered: 2009-05-19
Posts: 167

Re: Plymouth is working! How to have a great splash in your box

Daenyth wrote:

Are you sure you used the *second* link and not the first? Those should both be fixed.

Well, just to be sure, can you please post again the correct link?


Sony Vaio VPCM13M1E  - Arch Linux - ZFS - Syslinux - XFCE .
Samsung SGS - CM10.1 - Semaphore 2.8.0 .

Offline

#105 2010-03-06 17:31:25

Daenyth
Forum Fellow
From: Boston, MA
Registered: 2008-02-24
Posts: 1,244

Re: Plymouth is working! How to have a great splash in your box

Offline

#106 2010-03-06 20:36:22

goran'agar
Member
From: Nothern Italy
Registered: 2009-05-19
Posts: 167

Re: Plymouth is working! How to have a great splash in your box

This is the x86-64 bit package. I'll need an x86 on or, in alternative, the files needed to run makepkg.


Sony Vaio VPCM13M1E  - Arch Linux - ZFS - Syslinux - XFCE .
Samsung SGS - CM10.1 - Semaphore 2.8.0 .

Offline

#107 2010-03-06 21:09:35

Daenyth
Forum Fellow
From: Boston, MA
Registered: 2008-02-24
Posts: 1,244

Re: Plymouth is working! How to have a great splash in your box

huh? Oh, I must have uploaded the wrong package. I'll get the source files up shortly. In the meantime extracting the plymouth-encrypt files from /lib/initcpio should work.

Offline

#108 2010-03-06 21:21:12

goran'agar
Member
From: Nothern Italy
Registered: 2009-05-19
Posts: 167

Re: Plymouth is working! How to have a great splash in your box

Daenyth wrote:

huh? Oh, I must have uploaded the wrong package. I'll get the source files up shortly. In the meantime extracting the plymouth-encrypt files from /lib/initcpio should work.

LOL, I just did that and, indeed, it worked perfectly. Really great job.


Sony Vaio VPCM13M1E  - Arch Linux - ZFS - Syslinux - XFCE .
Samsung SGS - CM10.1 - Semaphore 2.8.0 .

Offline

#109 2010-03-06 22:03:49

Daenyth
Forum Fellow
From: Boston, MA
Registered: 2008-02-24
Posts: 1,244

Re: Plymouth is working! How to have a great splash in your box

Alright, this should all be working now.

http://omploader.org/vM3I2MA - plymouth-git with support for encryption. To use it, replace "encrypt" with "plymouth-encrypt" in mkinitcpio.conf

Offline

#110 2010-03-06 22:23:31

goran'agar
Member
From: Nothern Italy
Registered: 2009-05-19
Posts: 167

Re: Plymouth is working! How to have a great splash in your box

Daenyth wrote:

Alright, this should all be working now.

http://omploader.org/vM3I2MA - plymouth-git with support for encryption. To use it, replace "encrypt" with "plymouth-encrypt" in mkinitcpio.conf

Just a small note:

patching file usr/sbin/plymouth-set-default-theme
Hunk #1 FAILED at 2.
1 out of 1 hunk FAILED -- saving rejects to file usr/sbin/plymouth-set-default-theme.rej
==> ERROR: Build Failed.
    Aborting...

This patch is not needed anymore.


Sony Vaio VPCM13M1E  - Arch Linux - ZFS - Syslinux - XFCE .
Samsung SGS - CM10.1 - Semaphore 2.8.0 .

Offline

#111 2010-03-07 00:20:11

Daenyth
Forum Fellow
From: Boston, MA
Registered: 2008-02-24
Posts: 1,244

Re: Plymouth is working! How to have a great splash in your box

As I said above, modify that bit by hand. I'm too lazy to fix it after spending so many hours just getting the initrd hook to work. I've emailed the AUR maintainer and he should hopefully merge my changes soon

Offline

#112 2010-03-07 04:27:54

jarryson
Member
Registered: 2007-02-18
Posts: 298

Re: Plymouth is working! How to have a great splash in your box

Thnaks very much! i have seen you gus discuss this tof days. Seems now i can merge this.

Offline

#113 2010-04-28 15:20:57

mirhciulica
Member
From: Romania
Registered: 2009-09-23
Posts: 13

Re: Plymouth is working! How to have a great splash in your box

So, I gave plymouth a try and I'm really impressed. But, yes there is a but... I can't get rid of the black squares "automatically".
I added /bin/plymouth quit --retain-splash to rc.local and it has no effect on Plymouth because it's frozen when rc.local is processed.
Plymouth freezes after 4-5 seconds of running; and after adding printf "  ${C_OTHER}[${C_FAIL}FAIL${C_OTHER}]${C_CLEAR} \n" > /var/aa (note the "> /var/aa") in the stat_fail() function from /etc/rc.d/functions.d/plymouth.functions, a file was created with this output:

   [1;34;40m[[1;31;40mFAIL[1;34;40m][1;0m

.

And there is nothing to be stopped and I don't have a smooth boot. I'm using openbox with X session started automatically at boot and latest nvidia driver(195.36.24).

Here is my daemon list

DAEMONS=(tmpfs-varlog hal syslog-ng @networkmanager @fcron @alsa @mpd @samba @cups)

and rc.local

#!/bin/bash
#
# /etc/rc.local: Local multi-user startup script.
#

/bin/plymouth quit --retain-splash &
/usr/local/bin/hda-verb /dev/snd/hwC0D0 0x15 SET_EAPD_BTLENABLE 2 > /dev/null &
/bin/bash /etc/acpi/handler.sh ac_adapter &

In my opinion this behavior isn't relevant to the driver and I want to help resolve this issue, but I don't really know from where to start.

Offline

#114 2010-04-29 11:30:25

sundown
Member
Registered: 2009-09-13
Posts: 14

Re: Plymouth is working! How to have a great splash in your box

You'll have to have Kernel Mode Setting in order to run Plymouth. The official Nvidia drivers don't support that. For KMS you can use http://wiki.archlinux.org/index.php/Nouveau and I doubt you'll be using that one.
Also:

If you don't have KMS you will need to use framebuffer instead.
Note: This may well not work. Plymouth is designed to work with KMS, although it can sometimes work with framebuffer.

Offline

#115 2010-04-29 11:55:21

mirhciulica
Member
From: Romania
Registered: 2009-09-23
Posts: 13

Re: Plymouth is working! How to have a great splash in your box

sundown wrote:

You'll have to have Kernel Mode Setting in order to run Plymouth. The official Nvidia drivers don't support that. For KMS you can use http://wiki.archlinux.org/index.php/Nouveau and I doubt you'll be using that one.
Also:

If you don't have KMS you will need to use framebuffer instead.
Note: This may well not work. Plymouth is designed to work with KMS, although it can sometimes work with framebuffer.

ok. thanks for reply.

Offline

#116 2010-08-12 10:27:29

havok
Member
Registered: 2007-12-07
Posts: 13

Re: Plymouth is working! How to have a great splash in your box

Hey,
This looks awesome! Great work.
I have some trouble though, just before plymouth starts, and between plymouth exits and my display manager starts, it goes back into console and prints a glib error, something about getpwuid_r(), roughening up my boot. Is this a known problem with a known fix, or is it just my system?

Offline

#117 2010-08-12 23:30:20

mcmillan
Member
Registered: 2006-04-06
Posts: 698

Re: Plymouth is working! How to have a great splash in your box

It's a known problem, as far as I know there isn't a fix, unless one has cropped up since I last went looking for it.

Offline

#118 2011-01-14 12:43:54

jack.mitchell
Member
From: Ely, Cambridgeshire, UK
Registered: 2008-08-28
Posts: 156
Website

Re: Plymouth is working! How to have a great splash in your box

I'm having issues with plymouth.

Running nvidia with framebuffer, x86_64. I have the problem where the black squares are present in top left hand corner as discussed in the wiki. However adding

sudo /bin/plymouth quit &

to .xinitrc and also giving /bin/plymouth nopasswd sudo access doesn't solve it. The funny thing is that if I don't use a login manager and just drop into tty then startx from there I don't get the squares. However if I use slim then the squares are present. Therefore I believe it might be a bug related to starting X from within plymouth, or starting x while plymouth has control of the framebuffer. I've check the bugzilla (https://bugs.freedesktop.org//buglist.c … h=plymouth) and can't see a bug relating to this, does anyone have any suggestions?

.xinitrc

sudo /bin/plymouth quit &
exec i3 &
dropboxd &
sh ~/.startup.sh

Daemons

DAEMONS=(syslog-ng hal !network @netfs @crond @alsa @wicd @cpufreq @openntpd @mysqld @php-fcgi @hiawatha @slim)

Offline

#119 2011-06-07 17:36:20

samsagax
Member
Registered: 2011-03-18
Posts: 33

Re: Plymouth is working! How to have a great splash in your box

Any news on eliminating the ugly progess bar in themes like spinfinity?

Offline

#120 2011-06-07 19:17:18

BasT
Member
Registered: 2010-08-28
Posts: 78

Re: Plymouth is working! How to have a great splash in your box

Is it possible to run Plymouth using a custom kernel without ramdisk?

Offline

#121 2011-06-07 20:03:21

ANOKNUSA
Member
Registered: 2010-10-22
Posts: 2,141

Re: Plymouth is working! How to have a great splash in your box

BasT wrote:

Is it possible to run Plymouth using a custom kernel without ramdisk?

As far as I know, the ramdisk has no bearing on whether Plymouth works or not.  Isn't the kernel line in grub essentially the same regardless of the image?

Offline

#122 2011-06-07 21:48:55

BasT
Member
Registered: 2010-08-28
Posts: 78

Re: Plymouth is working! How to have a great splash in your box

For my setup with initrd i have no additions to the kernel line in grub, just the hooks in mkinitcpio. On the wiki there's no mention of how to do a non-initrd setup.

Last edited by BasT (2011-06-07 21:49:43)

Offline

#123 2011-06-24 11:22:01

vit
Member
Registered: 2008-12-28
Posts: 79

Re: Plymouth is working! How to have a great splash in your box

BasT wrote:

For my setup with initrd i have no additions to the kernel line in grub, just the hooks in mkinitcpio. On the wiki there's no mention of how to do a non-initrd setup.

The same for me. Have you found the way to enable it without ramdisk?

Offline

#124 2011-08-21 23:33:35

zephyr
Member
Registered: 2008-03-20
Posts: 103

Re: Plymouth is working! How to have a great splash in your box

Hello everyone smile

I have uploaded a package named plymouth-systemd-git in AUR so that people that use systemd and plymouth can test the
Smooth Transition from Plymouth to DM.

https://aur.archlinux.org/packages.php?ID=51715
(Essentially copied from plymouth-git and added the systemd integration bits so thanks to everyone involved in the
original package smile)

To test it after installing it (Only for KDM,GDM,LXDM for now):

----------INTEL GRAPHICS CARD USERS---------
Use xf86-video-intel-plymouth: https://aur.archlinux.org/packages.php?ID=51858

----------ATIGRAPHICS CARD USERS---------
Use xf86-video-ati-plymouth: https://aur.archlinux.org/packages.php?ID=51864

-------------LXDM---------------
LXDM is the only DM I know that has upstream plymouth support, so for the transition to work you just have to edit
/etc/lxdm/lxdm.conf and uncomment the arg= line under service:

[server]
## arg used to start xserver, not fully function
# arg=/usr/bin/X -background vt1  <-------UNCOMMENT THIS LINE

Disable your preferred DM Unit e.g.

systemctl disable lxdm.service

Enable the lxdm-plymouth.service:

systemctl enable lxdm-plymouth.service

---------------KDM------------
For KDM there are two options:

1st Method.  (EXPERIMENTAL=If it does not work for you, try method 2)
Edit /usr/share/config/kdm/kdmrc and change the following lines to the values you see below:

[General]
ServerVTs=1

[X-:*-Core]
ServerArgsLocal=-nolisten tcp -background none

This method has the drawback that if you boot using normal sysVinit/initscripts to init 5 (if you remove init=/bin/systemd
from kernel command line) a race will occur between agetty in tty1 and X so your CPU gets stuck at 100%.
If you have switched permanently to systemd this will not bother you I suppose.

Disable your preferred DM Unit e.g.

systemctl disable kdm.service

Enable the kdm-unpatched-plymouth.service:

systemctl enable kdm-unpatched-plymouth.service

2.nd Method Installed a patched kdebase-workspace so that KDM supports plymouth. I will upload this to the AUR soon. UPDATE: Uploaded kdebase-workspace-plymouth: https://aur.archlinux.org/packages.php?ID=51786
You must also change ServerVTs to ServerVTs=-1 (notice the minus sign before 1) and add "-background none" to ServerArgsLocal like in method one in your /usr/share/config/kdm/kdmrc.
(These changes will be in the kdmrc.pacnew file in the package I am making.)
This method has the advantage of compatibility with sysVinit/initscripts but the drawback that you have to build kdebase-workspace (~70mb package).

Disable your preferred DM Unit e.g.

systemctl disable kdm.service

Enable the kdm-plymouth.service:

systemctl enable kdm-plymouth.service

----------------GDM-----------

This is the only DM from the three that I have not tested.
GDM needs to be patched for this to work. I could provide a PKGBUILD after some digging but I cannot test it or
maintain it. If anybody is interested to test/use/maintain please tell me.

UPDATE: gdm-plymouth can be found in AUR: https://aur.archlinux.org/packages.php?ID=51739
Just install gdm-plymouth package and plymouth-systemd-git , setup plymouth and systemd(systemctl enable gdm-plymouth.service)

However I have provided a gdm-plymouth.service that should work IF gdm is patched:

Disable your preferred DM Unit e.g.

systemctl disable gdm.service

Enable the gdm-plymouth.service:

systemctl enable gdm-plymouth.service

------------------------

Final note:
I have this working flawlessly on my system using KDM(patched and unpatched from [extra]), and have also tested LXDM (from [community]) that also works.

This has the "side-effect"/intended behaviour that X now starts on tty1 (i.e. Ctrl-Alt-F1). Switching between
multi-user.target/rescue.target and graphical.target works fine without race issues.

UPDATE: Added gdm-plymouth package info.

UPDATE: Added kdebase-workspace-plymouth package info (for Method2 KDM plymouth transition)

UPDATE: Intel Users should use xf86-video-intel-plymouth: https://aur.archlinux.org/packages.php?ID=51858

UPDATE: ATI Users should use xf86-video-ati-plymouth: https://aur.archlinux.org/packages.php?ID=51864

Last edited by zephyr (2011-08-26 13:56:10)

Offline

#125 2011-08-24 05:04:38

framas
Member
Registered: 2009-07-24
Posts: 48

Re: Plymouth is working! How to have a great splash in your box

zephyr wrote:

This method has the drawback that if you boot using normal sysVinit/initscripts to init 5 (if you remove init=/bin/systemd
from kernel command line) a race will occur between agetty in tty1 and X so your CPU gets stuck at 100%.
If you have switched permanently to systemd this will not bother you I suppose.

To avoid it you can modify your /etc/inittab and disable getty on tty, I guess?

Offline

Board footer

Powered by FluxBB