You are not logged in.

#1 2008-08-05 12:42:43

mindfall
Member
From: berlin
Registered: 2007-07-03
Posts: 57

Kde4 forgets my preferred screen resolution

Since I upgraded Kde it always starts up in the highest possible resolution I have in my xorg.conf.
I have to open system settings->display every time. Seems to be a bug, because I don't even have to change anything, it is enough just to open the display settings and instantly the resolution changes.

Is there a known workaround other than setting it with xrandr in my xinitrc? I'd like it to remember the last used resolution.

Offline

#2 2008-08-05 19:38:26

staple
Member
Registered: 2007-09-28
Posts: 81

Re: Kde4 forgets my preferred screen resolution

you should probably just set it in xorg.conf

Offline

#3 2008-08-16 16:58:45

billbar
Member
Registered: 2004-02-14
Posts: 100

Re: Kde4 forgets my preferred screen resolution

So lead me to xorg.conf.
"whereis xorg.conf responds '/usr/lib/xorg & /usr/include/xorg'" and that is as root user.
Even Dolphin cannot find xorg.conf

So far - a pox on KDE4.

Bill

Offline

#4 2008-08-16 17:49:00

djclue917
Member
Registered: 2006-12-03
Posts: 121

Re: Kde4 forgets my preferred screen resolution

Use krandrtray. Your settings should be restored everytime it runs on KDE startup.  I use it since changing of screen resolution doesn't work in System Settings.

Offline

#5 2008-08-17 05:47:33

billbar
Member
Registered: 2004-02-14
Posts: 100

Re: Kde4 forgets my preferred screen resolution

Sorry to appear dense on this but isn't the tray icon that produces a list of screen resolutions from krandrtray.  I think I have seen it called 'Screen Resize and Rotate'?.
Otherwise, executing the binary krandrtray produces nothing.

I left Linux 18 months ago over wireless issues and am now anxious to again run Arch.  Didn't think things had changed much, but maybe so.

Appreciate any specifics you can offer on resolving screen resolution silliness.  Can't believe this is only my problem.

Bill

Offline

#6 2008-08-29 07:59:36

H2O
Member
Registered: 2007-10-09
Posts: 19

Re: Kde4 forgets my preferred screen resolution

Yup, I have the same problem. I even removed the highest resolutions from /etc/X11/xorg.conf and it didn't work. Also using System Settings->Display, can give very strange effects like desktop of about 75% size of the physical display (rest is the opacity checkerboard) or really magical behaviour of the panel (it looks ok, but when clicking configuration button it looks like it's stretched to full desktop height). I'll dig through the KDE forums but I would also appreciate some help if anybody already knows how to solve it.

Offline

#7 2008-08-29 09:17:19

byte
Member
From: Düsseldorf (DE)
Registered: 2006-05-01
Posts: 2,045

Re: Kde4 forgets my preferred screen resolution

If you want /etc/X11/xorg.conf you have to create it: X -configure


1000

Offline

#8 2008-10-09 22:58:41

markisthejob
Member
From: Cork, Ireland
Registered: 2008-09-01
Posts: 63

Re: Kde4 forgets my preferred screen resolution

I had the same problem.I run my computer through a widescreen tv which only looks right at 1360x768.That particular resolution was not available in xorg.conf or system settings>display but enabling kRandRTray to run at startup gets me straight into 1360x768.

Offline

#9 2008-10-10 13:15:28

uberamd
Member
Registered: 2008-10-09
Posts: 4

Re: Kde4 forgets my preferred screen resolution

I was just about to post about this same issue. I'll see if running KRandRTray fixes it for me, its only a minor annoyance. This is my first time moving away from GNOME and over to KDE since early 2000's. Wish me luck :)

Last edited by uberamd (2008-10-10 13:15:43)

Offline

#10 2008-10-15 14:37:16

Onwards
Member
From: Pakistan
Registered: 2007-04-18
Posts: 108

Re: Kde4 forgets my preferred screen resolution

KRandRTray did it for me as well. I am using Intel Corporation 82845G/GL[Brookdale-G]/GE chipset. xorg.conf wasn't helping me either...

Offline

#11 2009-02-21 16:52:25

AndrewW
Member
Registered: 2008-06-27
Posts: 3

Re: Kde4 forgets my preferred screen resolution

KRandRTray fixed it for me too! Thanks guys!

[ATI Radeon Mobile X1600]

Offline

#12 2010-03-10 11:27:47

Onwards
Member
From: Pakistan
Registered: 2007-04-18
Posts: 108

Re: Kde4 forgets my preferred screen resolution

Onwards wrote:

KRandRTray did it for me as well. I am using Intel Corporation 82845G/GL[Brookdale-G]/GE chipset. xorg.conf wasn't helping me either...

I have now instaed put the following in a file, and placed that file in .kde4/Autostart/. I am not sure whether making that file executable is necessary or not. Mine is executable though.

#!/bin/bash
xrandr --output VGA1 --mode 1280x1024

Offline

#13 2010-03-12 03:37:39

Allan
Developer
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,394
Website

Offline

Board footer

Powered by FluxBB